Upgrading w/USB image from 15.0 to 15.1, .. boot crashes with "invalid arch-independent ELF magic"

Watched the installation carefully, it seemed to have the boot loader configured properly, installing the boot loader on each of the five disks in the system.

System was running fine with 15.0, …

Note: Last winter the MB was swapped EFI -> Legacy, if that could affect the problem.

In case anyone has this problem in the future, … the issue was that “Upgrade” does not rewrite the MBR and does not know that it has changed from EFI to Legacy.

Select the update option on the Boot configuration subpage and all is well.