Upgrade to 15.3

At what point, if any, will 15.2 say: “An upgrade to 15.3 is available; click here to begin?”

I’ve seen the command-prompt heavy instructions here: https://en.opensuse.org/SDB:System_upgrade

…but I’m guessing there is an easier way.

Can I just insert the 15.3 USB and click upgrade?

If you have ever installed openSUSE from an installation ISO (wether from a DVD or from USB memory), you know that there is an Upgrade item at almost the first screen that is shown. Not much to explain about that.

But many people want to avoid downloading the whole ISO, copying it to a medium, then doing the Upgarde, and then still having to do a zypper up (or YaST equivalent) to get what is changed since release. They prefer to upgrade directly from the new version repositories. And that is what is described in the SDB.

‘zypper refresh’ or ‘update’ => Problem retrieving files

Is anybody else experiencing this issue??


Okay … so repos are back up and pre-upgrade moves smoothly along to the final screen before making changes, where i am asked to manually solve a long list of confilcts.

Cannot solve all conflicts. Manual intervention is required

with a long list where i am asked to choose between ‘Install’ or ‘Keep Obsolete’ files, and an indication that more than 13GiB is the package size to be updated.

Is this normal/expected?

What is the recommendation in dealing with all the manual conflict choices?


Depends upon which repositories you’ve still enabled… Perhaps share the output of:

sudo zypper lr -d

Personally, on a distribution upgrade I disable all additional repositories and would leave only:



Then after a successful upgrade re-enable any additional repositories dealing with any conflicts as they arise…

But, as they say, “There is more than one way to skin a cat” World Wide Words: More than one way to skin a cat

I do not quite understand this as an answer or addition to the quoting of my text.
Also I fail to see this as an additional answer to the question the OP asked.

When you have a problem, please start a thread of your own, and do not hijack a thread.

Thanks for the suggestion. However, I still get a long list of conflicts. I have moved posting my issues to this thread to continue as apparently i am ‘off topic’ here. Apologies to all.

Please check the Release Notes – <https://doc.opensuse.org/release-notes/x86_64/openSUSE/Leap/15.3/index.html&gt;.

  • N.B.: The section 2.1 – <Release Notes | openSUSE Leap 15.3.
    *=2]Before you begin, from Leap 15.2, check that you have an actual version of the »Leap 15.2« package “openSUSE-build-key”.

The import thing is, that the key “gpg-pubkey-39db7c82-*” has to be present on the Leap 15.2 system, before the Upgrade is started …

 > rpm -ql openSUSE-build-key 

The openSUSE-build-key wasn’t installed on Leap 15.2 until the 9 June (I think); I upgraded an old notebook from the command line the following day and all went well. Then I began to get three patches which conflict with part of webkit, libreoffice-writer and libreoffice-pyuno and can only be installed by deleting most of libreoffice and several other programs I use.

I had already installed Leap 15.3 Release Candidate on a laptop and this is running fine except that I had already been getting the same three patches asking me to delete the same software. On a positive note, an earlier patch had wanted me to delete most of lxqt but that one seems to have disappeared. So I assume the same thing will happen in due course with these three patches.

The three patches that wanted to deinstall lots of programs have disappeared and I had a straightforward set of patches for 15.3 today. So it looks as if the teething problems are over.

Upgrades from ISO (USB) continues failing even with 15.3 version in some PCs. The is the detailed way to hell:
1 - Burn ISO in USB. I upgraded some days before a Legacy PC from LEAP 15.1 to 15.3 without any issue, so the installation media is ok.
2 - Boot (in UEFI mode) with that USB on a functional an up-to-date openSUSE 15.2 version (UEFI too)
3 - Select “Upgrade” and continue normal process
4 - When last installation screen is reached, a YaST2 window appear, showing first attached screenshot https://postimg.cc/LhDsPLyX
5 - Click on “Yes” to (as suggested) run “save_y2logs” to get and share complete logs
6 - In the new window, I type “save_2logs” and then I get the second attached screenshot https://postimg.cc/4mnXhM7L

As result, I can’t upgrade using ISO-USB (I tried with another USB-ISO downloaded LEAP 15.3 and same result).
Curiosity: If I boot from that USB in Legacy (non UEFI) mode, when I reach last upgrade window, that error doesn’t appear BUT a (logical) warning about trying to upgrade Legacy on UEFI system, is showed.

Any suggestion? Am I doing something wrong in this case?

If you have a decent wi-fi connection, you could try the Command line upgrade (https://en.opensuse.org/SDB:System_upgrade) which worked fine for me. As you have an up-to-date version of Leap 15.2, you can go straight to step 3 if your root partition is btrfs or step 4 if your root partition is ext4. This is the sequence I used from step 4:

zypper ref
zypper up
nano /etc/zypp/vars.d/releasever -- To set releasever to 15.3
cp -Rv /etc/zypp/repos.d /etc/zypp/repos.d.Old
sed -i 's/15\.2/${releasever}/g' /etc/zypp/repos.d/*.repo
zypper --releasever=15.3 ref
zypper --releasever=15.3 dup
zypper verify

I updated 3 installs of 15.2 while 15.3 was RC or golden master iirc. All of them started to behave strangely after 2-3 updates (and zypper dup after release of final 15.3). One didn’t find the SSD on boot, instability, strange desktop behaviour etc pp.

I all re-installed (two with TW, one 15.3) in the meantime.