Upgrade question.

Hi, I am running tumbleweet on an AMD ryzen 7 / Nvidia Geforce GTX laptop. I have some 2000+ udates available. Started the update (zypper dup) and zypper comes back with some (3) problems :

noot@localhost:~> sudo zypper dup
[sudo] password for root:  
Loading repository data...
Reading installed packages...
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Computing distribution upgrade...
3 Problems:
Problem: the to be installed layer-shell-qt5-5.23.4-1.3.x86_64 requires 'libQt5Gui.so.5(Qt_5.15.2_PRIVATE_API)(64bit)', but this requirement cannot be provided
Problem: the to be installed qtdeclarative-imports-provides-qt5-1.0-1.7.x86_64 requires 'libQtQuick5 = 5.15.2+kde36', but this requirement cannot be provided
Problem: the to be installed vlc-beta-20211210.736213df13-17.4.x86_64 requires 'libQt5Core.so.5(Qt_5.15)(64bit)', but this requirement cannot be provided

Problem: the to be installed layer-shell-qt5-5.23.4-1.3.x86_64 requires 'libQt5Gui.so.5(Qt_5.15.2_PRIVATE_API)(64bit)', but this requirement cannot be provided
  deleted providers: libQt5Gui5-5.15.2+kde254-1.1.x86_64
not installable providers: libQt5Gui5-5.15.2+kde268-1.2.x86_64[download.opensuse.org-oss]
 Solution 1: deinstallation of layer-shell-qt5-5.23.2-1.1.x86_64
 Solution 2: deinstallation of libQt5WebKit5-5.212~alpha4-4.8.x86_64
 Solution 3: install layer-shell-qt5-5.23.4-1.3.i586 despite the inferior architecture
 Solution 4: keep obsolete libQt5WebKit5-5.212~alpha4-4.8.x86_64
 Solution 5: break layer-shell-qt5-5.23.4-1.3.x86_64 by ignoring some of its dependencies

**Choose from above solutions by number or skip, retry or cancel [1/2/3/4/5/s/r/c/d/?] (c): **

I am not that experienced, so I cannot determine what the best solution would be. I tried some logical answers for me, but after some trials I ended up with 30+ problems. What would you advise ? I have a stable system, so simply stop updating ?

I would choose #4 and expect a resolution in the next TW release.

What/how old is your current TW version?

I feel these zypper prompts are for advanced users. A shame since zypper dup is the advised upgrade method for Tumbleweed. This is in contrast with “zypper up” which is used on Leap. I’ve seen someone suggest exactly this method for TW when conflict happens, which I think it is a good idea rather than picking an option from zypper dup (IMO it presents four bad choices in your case, that is, for a person that clearly did not install manually any of those packages so wouldn’t know better).

If you want to take a choice you can go with mrmazda suggestion, I recall a similar issue not too long ago that went away in a few days.

But in general, whenever a prompt like this is presented to you, cancel, run “sudo zypper up” which will update the easy parts. In a few days zypper dup will work again. If it persist for more than a week then reach out.

The issue is using non standard repositories with Tumbleweed… your pulling updates from a KDE:Qt repository…


If your a) Using Tumbleweed and b) using non standard repos, there is some expectation you can handle this scenario… this is just an observation, not a criticism :wink:

You might want to check your repositories, maybe something was added without realizing?

Your problem is clearly related to a fancy list of repos. Stick to the basic repos and retry:

[FONT=monospace]**i3-4130:~ #** zypper lr -uEP           
# | Alias                            | Name                            | Enabled | GPG Check | Refresh | Priority | URI 
7 | packman                          | packman                         | Yes     | (r ) Yes  | Yes     |   90     | http://ftp.fau.de/packman/suse/openSUSE_Tumbleweed/ 
3 | download.opensuse.org-non-oss    | Haupt-Repository (NON-OSS)      | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/tumbleweed/repo/non-oss/ 
4 | download.opensuse.org-oss        | Haupt-Repository (OSS)          | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/tumbleweed/repo/oss/ 
5 | download.opensuse.org-tumbleweed | Hauptaktualisierungs-Repository | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/update/tumbleweed/ 
**i3-4130:~ #**[/FONT]

zypper dup started at 2022-01-09 23:18:48 and successfully installed some 2000 packages in 10 minutes. It completed at 23:28:42 without a single glitch. When adding more repos make sure you understand what you are going to do.:wink:

Thanks for the tips. I removed all dubious repositories and then was able to perform all (3000+ by now) updates.
Issue solved.

karlmistelberger, great tips, thank you!! :)](https://bank-nearme.com/)