Updating Zoom and importing public key - need help please

I was invited to join a Zoom meeting by an email which I received a week ago. I have used this before so knew a link would be enclosed but when I opened this link at the agreed time I was told that the Zoom app needed to be updated and a download link was offered with which I was able to download the update package:-


All OK so far and I noted some instructions for importing the public key with the instruction:-

rpm --import package-signing-key.pub

I ran into difficulty when I tried to put these two commands together. I was able to open Yast to run the rpm but am stuck with how to import key during the update process. Made me very late for meeting and in the end I had to use a windows laptop.
Please can somebody advise how this should be done so I shall know next time.

You need to import the key before installing the rpm with YaST. If the key file you downloaded is package-signing-key-5-12-6.pub, you need to run “rpm --import package-signing-key-5-12-6.pub” to import the key. You do not need to import it again for updates until zoom issues a new key.

Is there any other trick to this signing key? I’ve never seen that work on a direct Zoom. I still get the signing key warning. I just hit ignore and continue with installation. That’s why I now just do a direct install via opi instead. It works that way, accepting the signing key just fine.

1 Like

I don’t know if this is of help. I used the instructions here Downloading the public key
It works BUT, some of the text is incorrect, check it against what you download. The package signing key has 5-12-6 in it. sudo rpm --import ~/Downloads/package-signing-key.pub And I had to add openSUSE to rpm -K ~/Downloads/zoom_x86_64.rpm
My other mistake was to try to install Zoom first. I deleted it and did the above and tried again. It worked fine.