Updating the Kernel to 6.3.1-2 makes my most played game LOCK at 30FPS

Hello guys I need your help because I don’t know what the cause of my problem. I updated my system yesterday and reboot my system. And I let my system boot on Kernel 6.3.1-2 and my old Kernel 6.2.12 got automatically deleted. And now I’m stuck at Kernel 6.3.1-1 and 6.3.1-2. Which where my problem start. I’m playing Guild Wars 2 on my system all the time and I have decent fps on it. But after I tried to update on Kernel 6.3.1-1 my FPS on GW2 goes to 30fps (LOCK where usually I get 85 to 100 fps) on character section and in game world goes down to 25fps to 15fps (where usually I get 70 to 65 fps). Since Tumbleweed deleted the old Kernel Kernel 6.2.12 I can’t go back and hoping there’s a fix on my problem! Can you guys help me on my problem.

Edit: The game still stuck at 30fps not matter what the graphics setting I set.

Welcome to the forum!

I see currently:

$ rpm -qa | grep “kernel-default”

I have 5 because of:

$ grep ‘^multiversion’ /etc/zypp/zypp.conf
multiversion = provides:multiversion(kernel)
multiversion.kernels = latest,latest-1,latest-2,latest-3,latest-4,running

If you did one update I expect you that have at least on 6.2 kernel.

I am not surprised a new major kernel version can break things, I saw already other problems being reported.

Btw which tool do you use to measure your ingame FPS, as the Steam overlay seems to be disabled for GW2?

rpm -qa | grep “kernel-default”

I tried this command but there’s not output I guess TW already delete those, sir.

Mine sir, I only have the current one. Because I never thought TW won’t be hasty on removing the Kernel

I thought their will be fix on my problem I guess none since I didn’t any answer. I guess I just need to wait until the problem got fix itself

Update: I got alot of Mesa update and I change my proton to GE-proton 7-29. Now GW2 is running the FPS as it used to. The last time I tried it the fps lock at 30. Maybe the Mesa did something but I’m happy right now lol

That is what I call typical for Tumbleweed as rolling release, things break more often but are also solved quicker.

Yes, Tumbleweed by default only keeps the last kernel and I think that is the wrong default.

1 Like

I never thought this will be this fast lol. Thanks for the help sir!