Updating StarOffice

I have Star Office 8. I downloaded the update for it When I cd to it’s file int terminal as su I type “./setup” SUSE tells me I don’t have permission. Whats up with that?
this is on a new OS11.1 64bit laptop.


Just a guess. Is this file executable? You may need to do

chmod +x setup


Thanks Deano,
I tried your code but did nothing, So, for the fun of it I tried “./setup” again and it worked.


Thats correct. That command sets the executable (permissions) flag of the file called ‘setup’, so that you can then run it with ./setup

Good result. :slight_smile:

By the by, why use StarOffice when OpenOffice is available?

Free is fine. Sometimes some of us just like to help support linux development. Supporting StarOffice helps with OpenOffice does it not?


I used StarOffice long time back. Then, I thought KOffice, due to its closeness to KDE, should be the way forward. However, KOffice didn’t come to my expectations, mainly in handling the MS file formats. OpenOffice started its own development branch with initial StarOffice help, matured to a stable product.

This may not be the correct thread to discuss but my feeling is that there must be only one office suite for Linux. (This is my personal feeling). Since, an office suite is not a single program, modules (or parts) can be enabled/disabled to make it suitable for specific requirements. Why duplicate the development efforts on so many implementations?