Updating kernel in openSuse Leap 15.5

Try repo which nrickert recommended:


http://download.opensuse.org/repositories/Kernel:/stable:/Backport/standard/

Looking at the video that you linked – it is hard to read. But I think that gave you a Tumbleweed compatible kernel. That used to work. But there have been changes to Tumbleweed that are not compatible with Leap, and that’s why they created the backports kernel repo mentioned in my earlier post and in the post by @hui.

Tumbleweed made some file system changes, most notably “/bin” became a symlink to “/usr/bin”. And Leap has not made those changes. That’s the reason for the incompatibility. The backports kernel repo basically has the same kernel, except adapted to the file system layout used by Leap.

2 Likes

It works, I added this repo and able to update the kernel.

1 Like

What was the experience with an updated Backport-Kernel in Leap? What happened to the dependencies tracked in zypper/Yeast? Did any programs fail? Do Leap’s updates still work? How is that Kernel updated? Will the next upgrades to Leap 15.6 and later Slowroll still work?

I am super interested having gaming (Wine & Flathub Steam) in mind plus primary Libre Office and Thunderbird. And I need reliable and ongoing storage support for documents - so wipe out and new install would be semi-optimal.

Thanks for any info. Would be lovely learning from your experiences.

It should be fine.

I used the backport kernel for several months, without problems.

As long as the repo is enabled, it will update. But it won’t update if you only use “yast online update”. It (the backport kernel) will update with “zypper up” or with the desktop update applet.

1 Like

Thanks for the positive feedback. :+1:
I added that repo as posted above via zypper (did not work in YaST), then changed it’s priority for being top on the list. Finally did launch ‘sudo zypper up’, which appears not to be happy as such:
Not_Kernel

What am i missing? :thinking:

Btw: I am not aware of a Desktop Update Applet :woozy_face:. I am on Gnome.

Here my repos - maybe i messed up here?

Your repos look okay. I mostly use KDE. I think “Gnome Software” handles update in the same way as the KDE update applet. Well, not quite the same, because it wants to install updates on reboot. I turn that off when I try Gnome.

Hmmm. I did reboot meanwhile a few times and get nothing via ‘Software’ (that nice app installer including Flatpack) nor via Yeast Online Update. And zypper up does not want to touch the Kernel as displayed above.

Do I need a brute force command for zypper running the update? If yes, which?

Sorry for flooding this threat. It just happen to be super-interesting for a Newbie like me.

That’s the current kernel in the backports kernel repo. Until that changes, there’s nothing to update.

For me, I’m not seeing that kernel because I deleted the kernel from that repo. But when I was using it, update did update that kernel.

Thanks, nrickert. It smells to me as if i may have a major misunderstanding.
I thought, that the purpose of this exercise is to replace the current kernel with a high, new kernel. But as you can see, even after adding the backport repo and running zypper up, i am still on the old kernel:

OLD_KERNEL

I am bit lost. What do i get wrong?

I misread your earlier post. I saw 6.7.0, but I did not notice the “will NOT be installed”.

Go into Yast software management. Search for “kernel-default”.

Click on the “Versions” tab. You should then see that backport version.

Select that for install.

It didn’t install, because it has a different vendor. So you have to specifically select it.

Once you have a backport kernel installed, it will continue to update it when a newer one is available.

I reckon, i was able to identify the root cause of my problems being me.

This Kernel upgrade failed again on my PC with not being able to launch the new leap version due to SHIM issues. So i rolled back the Snapshot and ‘upgraded’ from the original Leap 15.5 USB.

Bur this time the boot menu did NOT fix itself - instead the default still goes to the new Kernel and fails on GRUB2 due to SHIM, telling me, that i should load the Kernel first.

Question 1: How can i remove a not wanted Kernel from my System? (In this case the failed 6.7 Kernel)

Since this failed to me similar as me having had tried to upgrade to Tumbleweed before, i guess that Suse is smarter than me with Linux and i must have made a common mistake in both scenarios.

I gut feeling is that the ‘MOK Management’ blue screen having appeared after the upgrades would be important. In both cases i went just for ‘Continue’ without selection of any key because i am not aware having defined a key in UEFI nor did i get any offered in the MOK’s menu for keys.

But then i found this good documentation, which explains that there should always be a key after an upgrade. And this chat in our Forum suggests, that there needs to be done something.

Sadly i am not (yet) smart enough to understand, what i am supposed to do, when the blue ‘MOK Management’ window appears.

Question 2: Does anybody have a hint, tip or link to a good read of what i am supposed to do with that MOK Management would be very much appreciated.

Minor update. I found in ‘Software Management’ how i can remove the new Kernel via Multipackages and Version. So all fine here. :laughing: I am back to a clean Leap 15.5.

But the question regards ‘MOK Managment’ stands, coz i am pretty sure, that such is where i screwed up :sleepy:: I have NO admin key defined in UEFI - so what am i supposed to do with the blue ‘MOK Management screen’ after upgrade where just ‘Continue’ appears to lead into failure :face_with_monocle:?

See as example here:
https://en.opensuse.org/SDB:NVIDIA_drivers#Secureboot

If you have not set an password, use the root’s password.

Yes. I should have warned you about that.

The backports kernel is signed with a different key. When you install the kernel, it does also install the key (in “/etc/uefi/certs”). But you need to respond to that blue screen to enroll it with MokManager.

When that asks for a password, use the root password.

@Sauerland : I tried those steps for MOK Management as referenced by you:
1.Enroll MOK
2. Continue
3.Yes
4. Password from Root
5. Reboot

My System is not launching anymore and stays in the boot screen endlessly

Any chance that a Kernel upgrade requires the MOK option of ‘Enroll from Disc’? Nrickert mention a certificate to be in /etc/UEFI/certs.

Btw: Not launching anymore for all Linux boot options. So far the worst result of all upgrade activities. Now hoping that the USB stick may save the day … fingers crossed.

If the missing MOK key is the only issue, then you should be able to boot a different kernel.

At the “grub” menu, select the “Advanced options” entry. Then you can select the kernel to use for this boot.

Just in case somebody googles into this at some point in time later. :sunglasses:

This Suse page indicates that the steps listed by Sauerland :vulcan_salute: are correct and the way to go - but having followed those steps, i experienced that all options for booting ended up in an endless Boot Screen and did NOT launch (see chapter installation). :nauseated_face:

When me trying to upgrade from Leap 15.5 to Tumbleweed failed :sleepy: due a SHIM issue, i was immediately able to launch other snapshots and the re-‘upgrade’ back to the original via my Leap 15.5 USB Installation stick worked well - no data lost. :blush:

But with this upgrade of a Kernel, no boot whatsoever worked anymore. :cold_face:
Even the re-upgade via my Leap 15.5 USB Installation stick gave me a heart attack when presenting a MOK Management screen after installation. :open_mouth:
First i thought that a key needs to be installed as discussed here in this chat, so i tried each of the some key-looking lines in the key menu only for being informed for each that a .cert is missing. Checking the option ‘Enable from Disc’ did provide me wild and cryptic list with lines like $Action and $Boot, non allowed any key selection. :grimacing:
Eventually i decided to use the ‘Delete Key’ option - which actually worked and all could be launched fine again. :partying_face:

Having made these interesting experiences with MOK Management gives me a bit weak knees thinking about upcoming upgrades to Leap 15.6 or later migrations to Slowroll. :face_with_monocle:

Anyway, the help having received here in this forum is fantastic - extremely useful for pushing my process of thinking into the right direction, which is very much appreciated. A big thanks to all of you. :heart: :+1:

And for providing at least something constructive:

  1. Adding the Kernel repository in YaST did not work, but this command:
    sudo zypper ar -f http://download.opensuse.org/repositories/Kernel:/stable:/Backport/standard/ Kernel_Backport
  2. YaST did not trigger any Kernel upgrade but this command:
    sudo zypper dup --from http://download.opensuse.org/repositories/Kernel:/stable:/Backport/standard/ --allow-vendor-change

It works, but zypper Yast do not switch to the packages of an other Repo by default.
That has to be done manually by f. e. using the second command: zypper dup --from xxxxxxx
After that, zypper/Yast will use the packages of that Repo and also update the packages if newer packages are available from that Repo.