update status says I'm offline

but I’m using the browser to post this question

I guess you’re referring to the desktop updater utility. That can happen when using NetworkManager with a user-defined connection. If you need the network connection up earlier (before login) then you can change it to a system(wide) connection instead.


BTW, (if using KDE) then the checkbox in the connection editor is ‘All users may connect to this network’.

i’m having trouble with finding either a network manager or connection manager. I’ve got the k in a gear circle, so i’m guessing the desktop is kde. That’s the only thing that seems familiar about it being kde as it seems more like old-style win3.0 with dos menus. Maybe I need to install something from the package manager?

Well, you provided so little information in your opening post, we’re left to guess the details :wink:

This might tell us definitively…

systemctl status display-manager
systemctl status network

fiddling around in yast and found a wicked setting, don’t know what that means but the other choice allowed for another choice that made a widget gizmo appear and that allowed for an ethernet choice to be made. overly complicated for something that should have been a default isn’t it? I’ll repost if this didn’t fix it.

Post the output from commands given in post #5 please.

@linux-nbow:~> systemctl status display-manager
display-manager.service - X Display Manager
Loaded: loaded (/usr/lib/systemd/system/display-manager.service; disabled)
Active: active (running) since Sun 2017-02-26 12:26:28 PST; 4 days ago
Main PID: 2324 (sddm)
CGroup: /system.slice/display-manager.service
├─2324 /usr/bin/sddm
└─2327 /usr/bin/X -nolisten tcp -auth /run/sddm/{e4627083-7e66-4379-b576-1…

@linux-nbow:~> systemctl status network
NetworkManager.service - Network Manager
Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled)
Active: active (running) since Thu 2017-03-02 22:40:51 PST; 33min ago
Main PID: 25916 (NetworkManager)
CGroup: /system.slice/NetworkManager.service
├─25916 /usr/sbin/NetworkManager --no-daemon
└─25950 /sbin/dhclient -d -q -sf /usr/lib/nm-dhcp-helper -pf /var/run/dhcl…

Okay, that shows sddm, so likely KDE Pasma 5, and NetworkManager is in use.

Wicked is for the most part used in hardwired connection and NetworkManager is mostly used for WiFi.

If using NM then you should see a network icon on your system tray. You configure NetworkManager there Wicked is configured in Yast

updating was not working, it kept saying I was offline. I did not see a network icon on kick panel until I found the wicked buried in the yast menus. I tried the network manager pull-down and voila! A network manager icon appeared! Was unaware this variety of Linux would have one on the panel only by user invitation. I could not figure out what the wicked wanted or what it was for, sure didn’t seem to work well with the updates. I installed this several months ago, and realized the updates weren’t happening. The sleep screen with the light bulb is pretty-cool, though!

Thanks for helping me fix the problem!

The openSUSE guides are a good source of information. Even though they’re listed for Leap 42.2, the info applies to Leap 42.1 as well…

In particular, for basic networking in openSUSE…