Update problem

I recently noticed that some updates were available so activated them. It failed out due to one dependency - detail in a some log some where and I have no idea where.

So I fired up YAST and selected update. That allowed me to identify the problem very quickly by selecting don’t install for just one package. The problem seemed to be that file called libtirc.so.1 wasn’t available, YAST search couldn’t find it with all of the location options checked.

That’s one problem.

Looking at the desktop update it still reckons that I need to do an update. All 46 of them. I’m pretty sure that the YAST did it apart from the one item as above. Another problem.

I then looked at the YAST’s update option - it’s changed and switched me totally over to auto updates. How do I get this back? As mentioned the update mechanism told me what was wrong in seconds and also should have found the missing lib file. The fact that it wasn’t there may be down to a multimedia update from packman using zypper. There was no sign of packman repo in yast’s list. Leaves me wondering if zypper is maintaining another one. If it had been listed in YAST I would have disabled it until it was needed again.


I’ve managed to answer my own question a little …

I have libtirpc3 installed. The update seems to want version 1. 3 came from opensuse with the distro,

Zypper does maintain repo’s that aren’t mentioned in yast. Fixed by removing it from it’s list and adding it to yast and checking that zypper could show it both enabled and disabled. Surely this is a bug ?? The wrong version of the lib isn’t down to the multimedia update.

So 2 problems left. Auto update is blocked due to libtirpc and getting YAST’s update feature back, That feature can be very useful at times.


YAST does have update via another button but the option has gone from software management…

The problem update is a recommended one nfs-client from to which needs the libtirpc.so.1 that doesn’t seem to exist in any of the repo’s.

So ???

Having done the updates apart from this one the desktop icon still reckons that there are 40 odd to do.

:)Bit of a lack of communication.


Not sure how but the problem has part cured by a log out from the desktop that just happened. Nothing to do with me. It just happened.

However there is one update left that has the dependency problems. It seems to be the same one mentioned here some years ago but on 64bit this time.


but I can’t understand how as surely the problem has been cured by now. I also don’t see why anything I have installed would be interested in nfs. Opera was installed but removed. The two packages I have installed from development are Rawtherapee and Fotoxx. I always install these as I do a lot of photography at times. Neither has ever caused a problem before. I also installed sylpheed from source. It compiled without needing any further dependencies.


Which problem is “cured” now?

If you install updates by other means (YaST, zypper), the update applet won’t notice that, until it checks for updates itself again (that’s normally done once per day, i.e. every 24 hours).
So this “problem” likely disappeared because the applet did check again meanwhile.

For “the missing button in YaST”: can you please be a bit more specific which button is missing where?
Or is this solved now as well?

However there is one update left that has the dependency problems. It seems to be the same one mentioned here some years ago but on 64bit this time.

[SOLVED] lib32-pam links to old lib32-libtirpc / Pacman & Package Upgrade Issues / Arch Linux Forums

Definitely not.
That is/was Arch specific.

Can you please post the exact error/conflict message?
nfs-client in the 42.2 standard repos does not require libtirpc.so.1 (otherwise this would be available in the standard repos too), it actually requires libtirpc.so.3.

And actually there is not even an update to available currently:

zypper se -s nfs-client
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S | Name             | Typ   | Version    | Arch   | Repository     
i | nfs-client       | Paket | 1.3.0-24.1 | x86_64 | openSUSE-42.2-0
i | yast2-nfs-client | Paket | 3.1.17-1.2 | noarch | openSUSE-42.2-0

So you must have some incompatible repo in your list.
Please post your repo list too:

zypper lr -d

This is the repo list

| Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service

1 | download.nvidia.com-leap | nVidia Graphics Drivers | Yes | (r ) Yes | Yes | 99 | rpm-md | Index of /opensuse/leap/42.2 |
2 | google-chrome | google-chrome | No | ---- | ---- | 99 | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64 |
3 | http-download.opensuse.org-64d911e9 | openSUSE.org:openSUSE:Leap:42.1:Update | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/42.1/oss/ |
4 | http-download.opensuse.org-7492e1ea | home:Kenzy:packages | No | ---- | ---- | 99 | rpm-md | http://download.opensuse.org/repositories/home:/Kenzy:/packages/openSUSE_Leap_42.2/ |
5 | http-download.opensuse.org-7b61e500 | multimedia:photo | No | ---- | ---- | 99 | rpm-md | http://download.opensuse.org/repositories/multimedia:/photo/openSUSE_Leap_42.2/ |
6 | http-download.opensuse.org-87633179 | home:rawtherapee | No | ---- | ---- | 99 | rpm-md | http://download.opensuse.org/repositories/home:/rawtherapee/openSUSE_Leap_42.2/ |
7 | http-download.videolan.org-ac27df37 | SuSE | No | ---- | ---- | 99 | rpm-md | http://download.videolan.org/SuSE/Leap_42.1/ |
8 | openSUSE-42.2-0 | openSUSE-42.2-0 | No | ---- | ---- | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-hp_DVD_A_DH16ACSHR_2L8221912016 |
9 | packman.inode.at-suse | Packman Repository | No | ---- | ---- | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_42.2/ |
10 | repo-debug | openSUSE-Leap-42.2-Debug | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/distribution/leap/42.2/repo/oss/ |
11 | repo-debug-non-oss | openSUSE-Leap-42.2-Debug-Non-Oss | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/distribution/leap/42.2/repo/non-oss/ |
12 | repo-debug-update | openSUSE-Leap-42.2-Update-Debug | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/update/leap/42.2/oss/ |
13 | repo-debug-update-non-oss | openSUSE-Leap-42.2-Update-Debug-Non-Oss | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/update/leap/42.2/non-oss/ |
14 | repo-non-oss | openSUSE-Leap-42.2-Non-Oss | Yes | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/leap/42.2/repo/non-oss/ |
15 | repo-oss | openSUSE-Leap-42.2-Oss | Yes | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/leap/42.2/repo/oss/ |
16 | repo-source | openSUSE-Leap-42.2-Source | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/distribution/leap/42.2/repo/oss/ |
17 | repo-source-non-oss | openSUSE-Leap-42.2-Source-Non-Oss | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/distribution/leap/42.2/repo/non-oss/ |
18 | repo-update | openSUSE-Leap-42.2-Update | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/42.2/oss/ |
19 | repo-update-non-oss | openSUSE-Leap-42.2-Update-Non-Oss | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/42.2/non-oss/ |

And this is the dependency problem

I’m pretty sure I haven’t done any updates with the “unusual” repo’s enabled but can’t be 100% sure.


No missing button in YAST. Initially I viewed updates via an option in software management - not the software update button. The option appears to have gone from software management and now come up with auto update in a fashion that suggests it can be set so I assume auto and unattended. Not sure on that point.

Just add that the only update I did when I am sure a none standard repo was enabled was the pacman one and maybe another as I didn’t realise that it was enabled as it didn’t show in the YAST list. The multimedia pacman upgrade did mention down gradiing one package but I didn’t note which one.


You are using the update repo for 42.1:

3 | http-download.opensuse.org-64d911e9 | openSUSE.org:openSUSE:Leap:42.1:Update | Yes | (r ) Yes | Yes | 99 | rpm-md |http://download.opensuse.org/update/leap/42.1/oss/ | 

I.e. you are trying to install an update for 42.1, that’s why a dependency is missing.

Remove that repo! It will just cause problems, and there is absolutely no point in having it on a 42.2 system.

You mean “View” -> “Installation Summary”?
Or do you actually mean the “Online Update” icon in the YaST Control Center?

The option appears to have gone from software management and now come up with auto update in a fashion that suggests it can be set so I assume auto and unattended.

I still cannot imagine what your problem is.
There is no “auto update” in YaST->Software Management.
There is a “Online Update Configuration” icon in YaST Control Center though with which you can setup automatic updates. And that module is exactly for that (only), to configure automatic updates, it doesn’t allow to view and install updates at all. For that you have “Online Update” and “Software Management”.

Please post a screenshot of what you are seeing.

Thanks Wofi. I had stared at the repo’s for ages and hadn’t noticed that. Must have been from a 1 click install but not sure which one. I’ve had fotoxx crash on closing so may be that one. I prefer to do that one from source really.

The view that has changed for me anyway on yast is software management. There was a facility there to see the updates that had arrived via the desktop auto update button. I have used it several times without even thinking about but believe it was one of the options under configuration. Now it just offers auto update setting in exactly the same way as yast’s online configuration button does. Yast’s online update button looks to give me the same view as the option in software management did.

:)To be honest I prefer the older way where the updates where categorised — security etc and were available from software management but I can live with using a different button rather than an option.


You are talking about the “Configuration” menu in YaST->Software Management then?

Yes, “Online Update” in there actually opens “Online Update Configuration”, what else would you expect in a menu that’s labelled “Configuration”?
Listing and installing Updates has nothing to do with “Configuration”. :wink:

I just had a look in openSUSE 13.1 (released 2013), and it was exactly the same there.
So I’m still not sure what your sudden problem is, your comment sounds as an entry to start “Online Update” has been there yesterday and suddenly disappeared…

Btw, you can do in “Online Update” everything that you would do in “Software Management”, so if you want to have “Online Update” there’s no point in running Software Management before (and then “switch” to “Online Update” inside there).

:)You have hit the nail on the head wolfi. When I had the dependency problem I went into software management using the button in YAST clicked something - pretty sure it was under configuration and all of the updates were shown there. I ran the updates selecting don’t install on the problem one.

Prior to maybe 2 weeks ago I had been using 12.3 since it was released so I never even noticed the 2 update related buttons. I was waiting for 13.3 so on leap thought I had better go for 42.2 just in case.

Anyway as the config options in management just duplicate the action of a button it has clearly changed and very probably did something else once else why have it there. It’s not needed now.