update error Subprocess failed. Error: RPM non riuscito: error: can't create transaction lock

on my samsung rv520running leap 15.0 and kde I tried to update but I have this error:
Subprocess failed. Error: RPM non riuscito (in english it is don’t succeed): error: can’t create transaction lock on /var/lib/rpm/.rpm.lock (Resource temporarily unavailable)
I tried to reboot but it remain.
how can I solve?

Perhaps you have a lock file left behind for some reason?

Does “/var/lib/rpm/.rpm.lock” exist ?

If it does try deleting it and then see if update works OK.

The only time I’ve seen something similar (a long time ago…) was after YaST2 Software Management crashed.

…I don’t know anything about lock files

no, “/var/lib/rpm/.rpm.lock” doesn’t exist

Just to be sure, because it does look from the error message as if your database is locked.:slight_smile: … you did note it was a hidden file?

What does …

sudo ls -lha /var/lib/rpm/.rpm.lock

… show?

Or you could just delete anyway (provided yast2/zypper is not running).

sudo rm -rf /var/lib/rpm/.rpm.lock

It will be recreated as needed.

I assume updates had previously been running OK?

The most common reason for failing to get a transaction lock is because something else is accessing the resource already and doesn’t want anything else to access and possibly make changes in the meantime.

In your case, you’re running KDE which by default would be running its own updater (typically apper) on every bootup.

You didn’t state how you attempted to update your system (YaST? zypper?).
You can either wait until the running updater finishes (you’ll typically see a Desktop notification that updates need to be installed), or if you prefer to manually update on a regular basis, you can disable the KDE updater.