Update-bootloader fails when the entire /boot is an efi system part

default script seems that not include --efi-directory parameter?
can i change the “update default location” to 0 and set a custom efi-directory? :sweat_smile:
Thanks

# target = amd64-efi, update default location = 1
# + /usr/sbin/grub2-install --target=amd64-efi
# Installing for amd64-efi platform.
# /usr/sbin/grub2-install: error: cannot find EFI directory.

As I understand the situation:
Every ESP must be formatted with type FAT.
FAT partitions do not support symlinks.
Kernel installations include symlinks in /boot/.
Thus, bootloader updates are entwined with symlinks in /boot/.

This can be solved by “grub2-install --target=amd64-efi --efi-directory=/boot”.
system can boot normally.

but whenever there is a grub2 update,I need to manually operate it. :joy:

Since there is such a parameter update default location = 1,there should be a way to modify it. :sweat_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.