Unsigned File repomd.xml from repository nVidia Graphics Drivers

On 2015-08-24 13:06, heyjoe wrote:
>
> robin_listas;2725514 Wrote:
>>
>> On the ftp server there is a readme with instructions for reports. :wink:
>
> Thanks. I have just sent them a link to this thread.

Nonono. Nobody will read that.

You have to email with a succinct, complete, and easy to read and
understand, email. All the needed information must be in the report.

At the end, you can add links for further reading.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Ok, I have send a second, more complete email.

I don’t know whether this is progress or regress.

At present, zypper appears to just be hanging while attempting to retrieve “repomd.xml” from the nvidia repo.

Hm, I don’t see that here.
Refreshing the repo works fine, there’s just the signature error when installing the packages, choosing “Ignore” does install them.

Anyway, somebody filed a bug report too:
http://bugzilla.opensuse.org/show_bug.cgi?id=942929

now this is strange
I did a zypper ref and did a refresh in yast, still didn’t get any key error or warning
and I don’t see the file that was reported in the bugzilla
ftp://77.67.22.188/opensuse/13.2/repodata/repomd.xml.asc
I see
ftp://77.67.22.188/opensuse/13.2/repodata/repomd.xml
ftp://77.67.22.188/opensuse/13.2/repodata/repomd.xml.key

yes the 13.1 repo does include the asc file
ftp://77.67.22.188/opensuse/13.1/repodata/repomd.xml.asc
why don’t I get an error?
kind of feel left out of the party.

As I wrote, I don’t get an error either when refreshing the repo.
Only when I actually try to install a package, but it’s possible to “ignore” that.

I believe it’s fixed as repomod.xml.asc is now accessible
ftp://download.nvidia.com/opensuse/13.2/repodata/repomd.xml.asc

Yes. I was suggested a new key today and accepted it. Update running fine.

A bit late with this comment but…
Thinking about it apper was a bit flaky when I updated the kernel and nvidia, it’s display bar was blank and I thought it was a bug, it probobly wanted to show me the missing key warning.
I didn’t kill it, I just did a logout and a shutdown. At next boot nvidia was updated.

sometimes appr windows get hidden below others

I’m still having problems with this.

I ran “zypper lu” around 12 minutes ago, and it is still hanging while attempting to read the nvidia repo.

There is an established connection the akamai host, but nothing is happening.

The “zypper” timeouts for this are too long (in my opinion).

Did you try what wolfi suggested above? (fixed IP and ftp) That one worked for me today.

No, I didn’t.

I don’t actually need to use the repo. The driver is already installed. I can just disble that repo.

I’m leaving it enabled to test whether the problem has been fixed.

Actually this shouldn’t be necessary anymore.
The issue should be fixed already.

I haven’t tried the other IP myself yet.
I just did though, and it worked fine.

Try to clean the caches. (“zypper clean -a”)

It seems to be okay after that.

Yes.

ftp://77.67.22.188/opensuse/13.2/
http://download.nvidia.com/opensuse/13.2/

Both work for me now.