Unresponsive system, but killing jdownloader (java) and MS Teams resolves

I cannot exactly say which snapshots but basically since the new plasma version my system shows strange behavior. When the system boots an plasma starts everything is very unresponsive, meaning that when i open the browser everything is slow, when hovering over buttons the mouse over effects are very slow and delayed.
But this is only when the browser was already open upon boot, i simply cannot use the taskbar to open apps. I also have a terminal windows always on the screen, which does not render and does not allow me to type anything in. Through an already opened conky window i can see that all my cpu cores are at 50%, but there does not seem to be any singular app which is responsible for that.

But i noticed some things, this seems to be related to java apps (jdownloader) and MS Teams, if i pkill both of them the system gets responsive again and everything is normal!

Which browser???

MS Teams when installed for the first time sets itself to start up on boot AND to keep running after closing (!?) >:)
You could try setting those options off (through the user icon, if I remember correct) to see if that is what causing the problem.

That is NOT true. When a user installs MS Teams in his/her desktop, it sets itself to starting on login. Depending upon the desktop (another piece of information that is missing in the OP’s post), one can unset this “start on login”. But alas, MS Teams sets it when it is started later, thus one has to unset it after almost every usage.

Firefox, but i think the problems here are related to general problems with the whole system. As i said, the taskbar is not responsible at all, i can alt tab between open windows but not via the task bar. But most windows does not render properly when brought to the foreground this way.

Currently everything is fine but as soon as i open jdownloader or teams the problems start again.

I use kde/plasma

When slow start a console and run ps -A see what is eating CPU usage or run top It is either the browser or or teams

Oops, of course you are right, I meant “on login”, (I think the option is called “autostart”) rather than “on boot”.

That has not been my experience in either Win10 or Leap 15.3/15.4. Once set not to autostart,(and “on close, keep application running”) those options are not reset in any of the computers I tried.

You may be right that there is some setting in MS Teams. Personally I am a bit anxious about meddling around in settings of MS programs :(. MS uses words that mean often something completely different in my Unix/Linux infested mind.

What I found that when I start it, the setting in KDE autostart is switched on. So after I close MS Teams I go there and switch it off. Happens only once every few months or so, thus it is not really a problem.

But your after your remark above, I may next time look for a way to switch the autostart off permanently in MS Teams itself.

Hm… could that setting be reset when there is a new version/update installation?

Hmm it is MS after all LOL