uname reports a wrong version

What’s this?

I did apply the updates on 11.1 32bit and upgraded the kernel from 2.6.27.45 to 2.6.27.56.

Now:

> uname -a
Linux myhost 2.6.27.45-0.1-default #1 SMP 2010-12-01 16:57:58 +0100 i686 i686 i386 GNU/Linux

but:

> cat /proc/version
Linux version 2.6.27.56-0.1-pae (geeko@buildhost) (gcc version 4.3.2 [gcc-4_3-branch revision 141291] (SUSE Linux) ) #1 SMP 2010-12-01 16:57:58 +0100

Did you reboot your machine after the kernel upgrade? It is one of the rare
cases where it makes sense to reboot a linux machine.
The currently running kernel is not magically replaced by a running newer
kernel after the upgrade, you need to boot with the new kernel (I remeber
there was a way to do that somehow without rebooting but do not remember
how).


openSUSE 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.5 | GeForce
9600 GT | 4GB Ram
openSUSE 11.3 64 bit | Intel Core2 Duo T9300@2.50GHz | KDE 4.5 | Quadro FX
3600M | 4GB Ram

Did you reboot your machine after the kernel upgrade?

Yes. Otherwise ‘cat /proc/version’ would not show the new kernel as demonstrated above.

There have been some issues after applying a delta package to the kernel.
https://bugzilla.novell.com/show_bug.cgi?id=571707#c17


openSUSE official member
LXDE team

There have been some issues after applying a delta package to the kernel.

Interesting. After reading this bugzilla report I tried to install another kernel: .default instead of .pae. No delta package. Still the same result:

> uname -a
Linux myhost 2.6.27.45-0.1-default #1 SMP 2010-12-01 16:57:58 +0100 i686 i686i386 GNU/Linux
> cat /proc/version
Linux version 2.6.27.56-0.1-default (geeko@buildhost) (gcc version 4.3.2 [gcc-4_3-branch revision 141291] (SUSE Linux) ) #1 SMP 2010-12-01 16:57:58 +0100

This is really kind of strange.

On 2011-01-06 22:36, vodoo wrote:

> This is really kind of strange.

It must be a bug of some kind… :-?

Incomplete update? The 11.1 version is about to be removed from normal
servers…


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

Incomplete update? The 11.1 version is about to be removed from normal servers…

Incomplete update? Probably yes. Another almost identical machine does not show this odd behaviour. But I can exclude any network problems for this update, because I mirrored the update repo with rsync and updated from the local repo on hard disk.

Anyone here knowing where uname gets the information it displays?

As for end of life of 11.1: these servers will run for quite some time to come.