Unable to use external DVD-RW Drive

I’ve got a problem and a couple quesitons. First the problem.

I’m running openSUSE 11.1 32-bit and I’m trying to use my external USB DVD-RW drive. I’ve tried loading two 11.1 discs in the drive and both of them fail. After putting the dvd in the drive I mount with::

mount /dev/scd0 /media/cdrom

and it comes back with:

mount: wrong fs type, bad option, bad superblock on /dev/sr0, missing codepage or helper program, or other error
In some cases useful info is found in syslog - try dmesg | tail or so

So when i run dmesg I get:

1198.836720] sr 3:0:0:0: [sr0] unaligned transfer
1198.866725] sr 3:0:0:0: [sr0] unaligned transfer
1198.875723] sr 3:0:0:0: [sr0] unaligned transfer
1198.883716] sr 3:0:0:0: [sr0] unaligned transfer
1198.892726] sr 3:0:0:0: [sr0] unaligned transfer
1199.108704] sr 3:0:0:0: [sr0] unaligned transfer
1199.117706] sr 3:0:0:0: [sr0] unaligned transfer
1199.158707] sr 3:0:0:0: [sr0] unaligned transfer
1199.242705] sr 3:0:0:0: [sr0] unaligned transfer
1199.242870] isofs_fill_super: bread failed, dev=sr0, iso_blknum=16, block=16

If I use -t auto, or -t iso9660 it comes back with the same results. I’ve put in a different data cd and it loaded just fine. I haven’t tried a data dvd but I’m assuming it should work as well. However I’ll test this.

I’ve used both these openSUSE 11.1 discs before and not had any problems so I don’t think there is a problem with the dvd’s. Is there something else I need to specify in my mount command or in fstab or mtab to get iso’s burned to a disc to work? I guess I’ll try putting in another iso disc just to see if it comes back with the same problem.

Just in case anyone asks here’s my fstab file:

/dev/Optional/Swap swap swap defaults 0 0
/dev/zipmaster07/Root / ext4 acl,user_xattr 1 1
/dev/disk/by-id/scsi-200e09e0030716f63-part2 /boot ext4 acl,user_xattr 1 2
/dev/Home/Josh /home ext4 acl,user_xattr 1 2
/dev/Optional/Opt /opt ext4 acl,user_xattr 1 2
/dev/Optional/Temp /tmp ext4 acl,user_xattr 1 2
/dev/scd0 /media/cdrom auto ro,user,noauto 0 0
proc /proc proc defaults 0 0
sysfs /sys /sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

My questions are pretty simple. first question is just plain curiosity. What is usbfs in my fstab? Is this my mouse?

Second question is can I use this external USB DVD-RW drive to install linux from, or does it have to be an internal drive? If so is there anything special I need to do to get it to look at the drive during boot. I take it this is dependant on a BIOS setting. This is all assuming of course I can get my dvd’s to read.

Thanks for your help.

Just tried a data dvd and it didn’t work, came back with the same problem. I tried putting in my data cd again and it failed. Not sure why it worked the first time and now it isn’t working. Also i found that under /dev I have several “cd-rom” devices like:


I also have several sgX devices too. I though those were related to optical drives but I can’t remember. Anyway I don’t think this is a problem they should all have a symbolic link to sr0 but I thought I’d mention it.

usbfs is present so you can mount usb flashdrives basically.
no the usbfs is not your mouse

The fstab file does not look right to me. Did you manually edit it or do it properly through YAST-Partitioner: edit mount points?

Yes you can use DVDRW externals to install Linux if and only if your bios is set to allow booting from usbhdd. Some MBO’s don’t support external USB DVD & some real old ones don’t support boot from CD/DVD. So check your bios for boot order and supported devices.

If you have Linux on DVD and want to install from the external first make sure the bios supports this and is configured to boot from the external. But I gather since you have read back fstab and posted it you either installed from an internal dvd or some other method.

/dev/scd0 /media/cdrom auto ro, user, noauto, 0 0
puzzles me. why would you auto mount read-only & say noauto mount?
check if there is a mount point /media/cdrom also.

You usually don’t edit a mount for the optical drive into fstab. The mount is supposed to auto-occur when you put in a disk. To put a mount for the optical drive in fstab is too constraining.

Here’s a few more questions, probably puzzling techwiz03 too:

  1. This is your root mount:
/dev/zipmaster07/Root / ext4 acl,user_xattr 1 1

How did it get like that?

  1. I’m puzzled that the computer could even boot, does it boot OK?
  2. Similarly, the mount in /home is puzzling too, what have you done to make it so unusual? And is there a valid home directory when the computer boots?
  3. Can you run this command and post the results back here:
df -Th

to techwiz03:

Yes I did edit my fstab manually but I only added the /dev/scd0 device, never touched the others. Yes there is a mount point in /media/cdrom, but I created it.

To swerdna:

  1. This is the way my system created the fstab file, like I said to techwiz03 I only added the /dev/scd0 device (I can remove it, I only added it to try and figure out this problem). I used LVM’s not disk partitions when setting up the OS. I believe this is what makes the differece. Whenever I format with disk partitions my devices always read something like /dev/sda1, /dev/sda2, /dev/sdb1, etc.

  2. Yes my computer boots just fine (a little slow because it’s old hardware, but that’s besides the point)

  3. I haven’t done anything… :D. Yes there is a valid home directory when my computer boots. I’m able to log in without any problems.

  4. Here’s my output from df -Th:

Filesystem Type Size Used Avail Use% Mounted on
/dev/mapper/zipmaster07-Root ext4 34G 4.4G 28G 14% /
udev tmpfs 441M 432K 440M 1% /dev
/dev/sda2 ext4 160M 69M 84M 46% /boot
/dev/mapper/Home-Josh ext4 67G 184M 64G 1% /home
/dev/mapper/Optional-Opt ext4 20G 172M 19G 1% /opt
/dev/mapper/Optional-Temp ext4 2.0G 68M 1.9G 4% /tmp

I took out the line I added in fstab, rebooted my computer, and then put in a cd and it now comes back with the following error:

Failed to mount “CD-ROM Disc”
Method “Mount” with signature “ssas” on interface “org.freedesktop.hal.device.volume” doesn’t exist.

This is just an error dialogue box, it’s not coming from the terminal. I’m not at my computer right now, but I’ll try manually mounting the cd and see what comes back when I can.

And do not assume that the device special file is /dev/scd0 because it probably isn’t. You know for sure that that is the one created by udevd on connection of the device?

EDIT: And of course, I am as curious as the others why you have (or how you got) such a strange setup. Please do explain a bit more. I can not take it for granted thht this is just an installation on a normal partitioned disk.

Thanks for the info. Every now and then in Linux I’m reminded of how little I know. I have diligently avoided LVM (because I’m lazy) and now it shows. I hope someone can help you.

LVM explains a lot about the strange set-up. Personally, I wouldn’t use LVM (which bypasses standard bios hdd i/o in favor of OS provided hdd low level hdd i/o). LVM was&is a disaster under M$ OS’s, not recommended under UNIX BSD and MAC OS/X, and considered still experimental under Linux.

For what it’s worth, here’s my take on it from a technical stand point. The Bios contains the disk i/o routines designed specifically to handle information and control with the HDD’s hardware through it’s firmware as a function of precise control. This interaction is based on principals of boot-sector & partition table and the local drive layout is governed by precise calculations that establish the boundaries.

People wanting to actively re-arrange the “logical volumes” without the need to change the partition table as a kind of hot-swap leaning towards creating a virtual drive. In the partitioned method, you have a calculated size, location and type that ideally rests on precise sector boundaries. Now along comes LVM where you move, resize, create, destroy, or format on the fly and don’t have to stay with-in sector boundaries. Now it is possible to end an LVM in the middle of a sector and orphan the rest of sector, or start a new LVM in the middle of a sector and even overlap one LVM over part of another LVM. Ouch! Because of these inherent possible problems I side with the engineers at Seagate, Maxtor, Western Digital when they say use of LVM should only be attempted by those with advanced HDD drive geometry knowledge.

Thanks techwiz03 for your interesting informartion concerning LVM. I’m a bit like Jonh (swerdna), in that I’ve managed to avoid knowing much or using this system. (I’ve never appreciated or needed the features it provides admittedly).

I was alarmed by this statement in wikipedia article though:

Until kernel 2.6.31[1], write barriers were not supported. This means that the guarantee against filesystem corruption offered by journaled file systems like ext3 and XFS is negated under some circumstances.[2] Most distros, with the notable exception of SUSE, turn off protective barriers by default anyway, to prevent performance degradation.

Backs up the inherent potential problems you mentioned. I’m sure it has its place though.

Back on subject with the external dvd drive. Plug it in and note the ouput of

dmesg |tail

You can also start this in a console, then plug in the dvd drive and note output

lshal -m

You must experience many troubles as me when you encounter your favorite flashes,audio or video files.I am so happy to find a powerful flv converter software to convert flv to ipod, convert flv to iphone, convert flv to psp, convert flv to xbox360, convert flv to blackberry etc.

Thanks for the info on the LVM, that was indeed very interesting. As for the security of the system, I could care less, there isn’t anything even on the computer, it’s just a test box. But the info is good to know especially when I setup different boxes.

To hcvv:

I used “wodim --devices” to find the device which returned:

wodim: Overview of accessible drives (1 found) :

0 dev=’/dev/scd0’ rwrw-- : ‘ATAPI’ ‘iHAS422 8’

I’m still very new to linux so please feel free to “supportively” :wink: criticize if this is an incorrect way of finding the device, or if there is a better way.

to deano_ferrari:

I posted what comes back in dmesg|tail in my original post. Unplugged the drive, plugged it back in and ran dmesg again and it still has the same info. From lsusb this is what I get:

Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 010: ID 046d:c012 Logitech, Inc. Mouseman Dual Optical
Buss 001 Device 011: ID 1c6b:a122 Philips & Lite-ON Digital Solutions Corporation

I unplugged the device again, ran lshal -m, then plugged the device back in and this is what came back:

Start monitoring devicelist:

04:46:03.139: usb_device_1c6b_a122_20090107000000047BA0 added
04:46:03.176: usb_device_1c6b_a122_20090107000000047BA0_if0 added
04:46:03.198: usb_device_1c6b_a122_20090107000000047BA0_if0_scsi_host added
04:46:04.400: usb_device_1c6b_a122_20090107000000047BA0_if0_scsi_host_0 added
04:46:04.417: usb_device_1c6b_a122_20090107000000047BA0_if0_scsi_host_0_scsi_device_lun0 added
04:46:04.433: usb_device_1c6b_a122_20090107000000047BA0_if0_scsi_host_0_scsi_device_lun0_scsi_generic added
04:46:05.613: storage_serial_ATAPI_iHAS422_8_20090107000000047BA0_0_0 added
04:46:05.646: storage_serial_ATAPI_iHAS422_8_20090107000000047BA0_0_0 property info.interfaces = {‘org.freedesktop.Hal.Device.Storage’, ‘org.freedesktop.Hal.Device.Storage’, ‘org.freedesktop.Hal.Device.Storage.Removable’}
04:46:08.400: storage_serial_ATAPI_iHAS422_8_20090107000000047BA0_0_0 property storage.partitioning_scheme = ‘’ (new)
04:46:16.040: storage_serial_ATAPI_iHAS422_8_20090107000000047BA0_0_0 property storage.removable.media_available = true
04:46:16.118: storage_serial_ATAPI_iHAS422_8_20090107000000047BA0_0_0 property storage.removable.media_size = 185071616 (0xb07f800) (new)
04:46:16.124: storage_serial_ATAPI_iHAS422_8_20090107000000047BA0_0_0 property storage.cdrom.read_speed = 8468 (0x2114)
04:46:17.380: volume_part_1_size_185071616 added

Also I did forget to mention that I’m using USB 1.1 (yeah I know old hardware), but this shouldn’t effect anything except perforance… shouldn’t it?

Thanks again for all your guys help.

Never knew about wodim. I did use it here (after consulting the man page). It produced also* /dev/scd0*. Normaly, when the automatic mount, that seems to fail at yours, functions /dev/sr0 is used. But I see:

henk@boven:~> l /dev/scd0
lrwxrwxrwx 1 root root 3 apr 16 09:39 /dev/scd0 -> sr0

It may be that scd0 is there for a compatibility with older usage.

Maybe it is not an incorrect way to find the device, but I never understood why you used scd0 where nobody does. In any case most people never try to find out because after udev creates it, HAL (or its modern replacement) then creates the mount dir and mounts it (using sr0) after consulting the Desktop software.

It sure is. I used to have an external SCSI cd burner (really nice actually - Yamaha, “superfast” 4x burning, never failed. Probably still works) that turned up in my red hat as /dev/scd0.

I read it as “device scsi cd number 0” not really at the time knowing my arse from my elbow wrt linux.

At some point a kernel update (when udev etc came along) changed it all to become /dev/sr0, which played merry hell with everything. No-one could find the device and people were hacking udev conf (distros even shipped modified versions to ‘fix’ it) files to change the name back :slight_smile:

Oh the laughs we had …

I’m new to linux so when I was looking up information about this problem I can across “wodim”. I used it found the device. I’ve also tried sr0 but that returns the same errors.

I just got this from Linux CD/DVD RW tech forum post by Jafres338 on mar 31/2010 in response to Can’t open /dev/scd0 or /dev/sr0 and can’t mount them either … just get errors.

“Wodim is full of bugs, and has been for close to 2 years now, with little to no updates/fixes. .”

Following more or less my own strain of thoughts (thus please forgive me when I am talking OOT with respect to your problem) My idea until thus far is:
. you have an openSUSE 11.2 system, but we have no information if you use a ‘text only’ or a system with X and when with X, what DE.
. you have a CD/DVD device connected to your system and know for sure that it has got /dev/sr0 (and the old fashioned* /dev/scd0*, but that is exactly the same) as device special file.
. you put in a DVD, of which you did not tell us what it contains (I am a bit better with CDs, and there it could contain an ISO9660 file system, or be a musical CD without file system, or a blank CD with nothing, etc).
. you checked if this resulted in a mount by using


and there was no line shown with /dev/sr0 in it, alo you do not mention any action talen by your DE (if you have one running).
. you then created the directory /media/crom.
. you then did

$ mount /dev/scd0 /media/cdrom
mount: wrong fs type, bad option, bad superblock on /dev/sr0, missing codepage or helper program, or other error
 In some cases useful info is found in syslog - try dmesg | tail or so

(the above is fake, not litteraly from your post, because you did not cut/paste from your system, but I hope I am back as good as possible to what happened on the system). (btw see how it uses sr0 in spite of your scd0, as the second is only an ‘alias’ of the first this is nothing to bother).

When you read the man page of mount, you will find out that mount needs to know the file system type. Either from the command (-t option) and without that it will try to find out by itself by reading from the device, and when that fails it will look if there is an /etc/fstab entry that fits to the other parameter(s) and then use the fs type mentioned there.
Thus my first action on such an eror would be to use the* -t <fs-type>* option to see if that helps. Do you now the fs-type and did you try this?