Unable to upgrade from Leap 42.2 to 42.3

Hi,
I am using the guide on

https://kamarada.github.io/en/2017/08/03/how-to-upgrade-from-opensuse-leap-422-to-423/#.Wsqv7UxFy4w
to upgrade from Leap 42.2 to 43.3. I’ve done everything stated step by step until I switch to a purely textual interface, go to init 3 and then zypper --no-refresh dup. I then get the messages:

Download (curl) error for ‘http://download.opensuse.org/update/leap/42.3/oss/X86_64/drm-kmp-default-4.9.33_k4.4.126_48-13.3.X86_64.rpm
Error code: Connection failed
Error message: Could not resolve host: download.opensuse.org Abort, retry, ignore?

When I tried retry or ignore nothing happened except I was returned to [LEFT]Abort, retry, ignore? When I entered Abort upgrade was terminated.[/LEFT]
I do not know what the above error messages were referring to. It could not have been anything to do with connection to the internet because my windows machine was connected to the internet and was working fine.
Any ideas as to what went wrong and how things could be put right? All help will be greatly appreciated.

Hi, please retry with the correct address, with a small “x” as in x86_64:

http://download.opensuse.org/update/leap/42.3/oss/x86_64/drm-kmp-default-4.9.33_k4.4.126_48-13.3.x86_64.rpm

not as quoted in your post as:

Download (curl) error for ‘http://download.opensuse.org/update/leap/42.3/oss/X86_64/drm-kmp-default-4.9.33_k4.4.126_48-13.3.X86_64.rpm’

It could easily be lack of a logical connection. Is it a wireless connection? If so, exiting the X session might have terminated it (as suggested might happen on that Kamarada page). If you followed the instructions precisely, all needed packages should already have been downloaded before doing init 3, and zypper should not subequently be needing to use curl with the --no-refresh option. I would give it another try following those instructions closely, to make sure packages are downloaded in advance of exiting your X session. If that doesn’t help, please provide output from the following while in “init 3”:

cat /etc/resolv.conf
ip a
lspci

If the first two seem to indicate networking is working, you might try doing the whole update by booting directly to the shell prompt by appending “3” to the kernel cmdline (after splash=silent or quiet) by striking the e key in the Grub menu. Login as root at the prompt, then verify you have a network connection with

ping www.google.com

Since you’ve already updated the repos and should have the upgrade rpms already downloaded, if ping succeeds, go ahead and run

zypper --no-refresh dup

When you are in init 3, you are not loged in into the GUI. When you are using Network Manager that handles networking on behalf of the GUI user, there will be no network connection in run level 3.

BTW, why do you not use the description on how to update from openSUSE?