Unable to update!

Hi All,

Recently when i went to update i got this error message “patch:dbus-1-4962.noarch conflicts with dbus-1-devel.i586 < 1.4.1-7.8.1 provided by dbus-1-devel-1.4.1-7.1.i586”, Now i can’t apply any of my updates as this message keeps popping up!! I’m using opensuse 11.4 with kde version 4.6.00. Any help would be appreciated.

So, I normally suggest you start YaST / Software / Software Management (You must enter your password to start YaST).

Then, in Software Management I do a:

  1. Options / Allow Vendor Change (Place an X there)
  2. Package / All Packages / Update if Newer Version Available (Agree if there are several Packages to update)
  3. You will then be presented with your choices to remove the conflict. I most likely would remove the file dbus-1-devel.i586 or change its vendor, but I don’t know what else this might cause or why your have this problem.

I normally make the following suggestions to all that have such problems:

To avoid package problems, the most important thing to do is to: NEVER
ignore a dependency, even if YaST/zypper/updater gives you such an option!
In general, never switch to an >inferior< architecture and the solution is
most often to just switch Vendor to the >Packman< repository. So changing
the vendor is OK, but >ignoring< dependencies is never a very good idea!

Thank You,

All Right. That worked and they installed. Thank you!!!

All Right. That worked and they installed. Thank you!!!

It is good to hear of your success. And, we welcome you to the openSUSE forums Noob_Za1boot. If you have not seen this, new users should do some reading here:

New User How To/FAQ (read only)

Thank You,