Unable to run any Feral games, all others are fine!


I got this peculiar problem that all Feral linux ported games do not run at all, when I click play in steam, steam says that it is launching in about 1-2 second, then it aborts and nothing happens(I newer see the Feral game launcher).
Some weeks back they all worked without any problems! So I guess it has something to do with a library that has been updated?
All other non Feral games do work without any problem.
The only thing I have done are normal system updates.
I am running latest tumbleweed all updated, newest steam client and mesa driver.

Does any one else have the same problem, or have any idea what this problem can be?

Kind regards

I have the same problem, raised it with Feral related to Dawn of War 2. What I found that works is

  • start steam
  • navigate to the game’s installation folder, e.g. cd .steam/steam/steamapps/common/Dawn\ of\ War\ 2/bin
  • use ldd to make sure that all libraries are present, ldd DawnOfWar2 | grep ‘not found’
  • install all missing libraries

The last step is tricky, since the games now require /usr/lib64/librtmp.so.0 ( or the 32-bit variant ) which is not available for openSUSE. I have worked around this by:

  • installing librtmp1 and librtmp1-32bit from packman
  • creating symlinks from /usr/lib64/librtmp.so.1 to /usr/lib64/librtmp.so.0 and from /usr/lib/librtmp.so.1 to /usr/lib/librtmp.so.0

Quite annoying, but in the end it worked, tested on Dawn of War 2 and Mediaval: Total War.

Would be interesting to see if this fixes it for you, and please do mail Feral about so they are aware of the extent of the problem and do something about it.

Hi robert_munteanu thank you for your reply

I tried your steps and the command “ldd DawnOfWar2 | grep ‘not found’”, did return tat the library “librtmp” was missing. I then installed both and made the symlinks:

ln -s /usr/lib64/librtmp.so.1 /usr/lib64/librtmp.so.0
ln -s /usr/lib/librtmp.so.1 /usr/lib/librtmp.so.0

Is this the correct way to do this? I’m not an expert at the linux console, still learning :wink:
But I guess something worked because the command “ldd DawnOfWar2 | grep ‘not found’”, does not return any missing libraries now.

Sadly this does not fix the problem for me, exactly the same result as before.

So if I did not make any errors with the linking, this did not the trick :frowning:

I have contacted Feral about this, and we are working on finding the problem.

Did you:

  1. Lauch steam
  2. Try and start Dawn of War from the command line, e.g. using ./DawnOfWar2 ? Launching using steam still does not work for me

That did the trick! Having Steam running in the background and starting the games directly from the console works for the following games:
Life is strange
Mad Max
Dawn of war 2

So that is great, thank you!

For Company of heroes 2 I get that the following library is missing: libpcre.so.3**
**For Tom Raider the following library is missing: libSDL2-2.0.so.0

If I look in yast I find similar libraries but not exactly the same, so I am unable to fix those.

I will provide Feral the newest discoveries.

Glad to hear it worked out for you!

For Tomb Raider, you should be able to fix the issue, on my system zypper find the following SDL libraries:

$ zypper se --file-list libSDL2-2.0.so.0

S | Name                | Summary                          | Type   
i | libSDL2-2_0-0       | Simple DirectMedia Layer Library | package
i | libSDL2-2_0-0-32bit | Simple DirectMedia Layer Library | package

So install those two libraries ( not sure if Tomb Raider is 32 or 64-bit ).

The PRCE stuff I have no idea about.

Keep us posted about the Feral situation, would love to find out when they release a fix.

Thank you so far, I was looking for the libSDL2 libraries the other day, but didn’t see that the 32bit wasn’t installed, after installing that one it missed the following:
libSDL2_image-2.0, after that:
libgomp, then:
libXtst, and at last it is now missing:
Which I cant find, so that is where I am hanging now.
I needed to install the 32bit library of every one, then I could come a step forward…

A bit wired that all these games where working perfectly fine a couple of weeks back, I’m wondering if I am the one who has messed up my system?

I will keep you posted when I hear something from Feral :slight_smile:

No need to mess with system libraries, I always try to avoid it. This is what I did to fix DOW2 on Leap 42.2:

sudo zypper in libSDL2_ttf-2_0-0 libSDL2_image-2_0-0 librtmp1
ln -s /usr/lib64/librtmp.so.1 ~/.steam/steam/steamapps/common/Dawn of War 2/lib/x86_64/librtmp.so.0

Does this work with all Feral games?
I have Tomb Raider and Alien Isolation, both games won’t work on Tumbleweed.

I don’t know, the only feral game I have tested on openSUSE was DOW2, but this fix only permitted me to play offline, I couldn’t play any online game.
I emailed Feral with this workaround and they thanked me but I don’t know if they will ever fix this for openSUSE. They seem to support only Ubuntu and SteamOS :frowning:

Jut to clarify, I only tested this on Leap 42.2.

Looks like the issue has been fixed with today’s Steam update.

… and it conflicts with the opensuse provided fixes. What I ended up doing was:

  • editing /usr/bin/steam and commenting out the steamruntime-fix line
  • running steam --reset - the runtime was downloaded again but I had to re-login

unfortunate,after last update from Steam,

I get

symbol lookup error: /usr/lib/libxcb-dri3.so.0: undefined symbol: xcb_send_request_with_fds

It starts now if I do

LD_PRELOAD='/usr/$LIB/libstdc++.so.6 /$LIB/libgpg-error.so.0' steam

But still no luck with Feral games (Tomb Raider)

I finally found a solution to the missing libpcre for Company of Heroes 2 issue!
I found the library in the following steam folder:


When I copy these files:



/home/user/.local/share/Steam/steamapps/common/Company of Heroes 2/lib/x86_64/

Then the game runs again! :slight_smile:

(I have no idea if this is a proper way of doing this, if not please tell how I can do this in a better way)

You still have to run the games from the game folders, they will not run from within Steam.

Kind regards

Not sure why the problem but it is best rather then copy the file but put in a symbolic link to the file thus updates are passed through to the new location man ln for details

Thank you gogalthorp you are probably right, I symlinked both files and it worked, for others this are the symlinks:

ln -s ~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libpcre.so.3 ~/.local/share/Steam/steamapps/common/“Company of Heroes 2”/lib/x86_64/

ln -s ~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libpcre.so.3.12.1 ~/.local/share/Steam/steamapps/common/“Company of Heroes 2”/lib/x86_64/

Kind regards

Are you running Steam with the steam runtimes turned ON? By default Steam then should find the required libraries in “/home/user/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/”. To see if it’s ON or OFF, check the value of “$STEAM_RUNTIME” as an environment variable. That’s sort of Valve’s way of trying to avoid all of those library versioning issues. Still, I know how annoying this is since I had it on every GNU/Linux distribution, even including newer versions of Ubuntu ;].

In general to everyone, be extra careful with symlinking and moving libraries around in the main system library directory. It’s not adviced as a first measure. If you see the symlink didn’t help, remove it immediately :).

Hi AndyMender, thank you for the reply :slight_smile:

How do I specifically check the “$STEAM_RUNTIME”, I’m kinda new to all this :wink:
If I run Steam from the console it will say:

“Running Steam on opensuse 20170211 64-bit
STEAM_RUNTIME is enabled automatically”

So I guess it is activated?

Same issue with Feral games, did anyone find a “fix” for this?

I’ve searched for 2 days without luck :expressionless:

Any update on this?

I’m having the same trouble getting my games started. Linking the library works and also starting the game on command line. But when doing so I’m not able to use the steam controller. It’s not getting recognized by the game. So I’m not able to use the steam software to launch the game.

When I delete the steam configuration in my home directory reinstall all the steam related stuff again it works. I get the license agreement and then the feral launcher.
But when I close steam and start it again the game refuses to start. I need the command line.

I’m using Leap 42.2 and steam from game works repository. I don’t know the difference between the sources of the official repository. I guess the only difference is the steam tricks. But I don’t know what they do.

So anybody here who got it to work?