Unable to login (any user)

I have an opensuse 15.5 installation but after trying to setup active directory authentication I am unable to login to the server.

I entered into rescue mode and checked the ssh settings (PaswordAuthentication yes, PermitRootLogin yes). But still I cannot log in with neither root nor a local user.
I reset the root password in rescue mode to no avail.

login as: localuser (or root)
localuser@uyunisrv's password:
Access denied

What else can I try in rescue mode to regain access (I would just love not to reinstall the machine, it’s a Uyuni installation I just got working).
Thanks for any advice.

Kind regards

Sorry. Worked it out. Can login again.

Always nice if you spent some words on how things were solved, too often topics are found based on a search engine query and too bad then if there is not helpful information.


Right, sorry for that, I was nervous and it was late … long day.

So, I just mixed up some parameters in the wrong files between
/etc/pam.d/common-account, common-session, common-auth
copying from my notes.

I gained root access in rescue mode and corrected the errors, putting the correct parameters in the above mentioned files.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.