Unable to connect Windows 10 PC to Linux shares

I can see the Linux computer on the network devices from my Windows 10 pc, but it tells me, “The network path was not found” when I try to open it. I get the same error when I try to type in the IP address (\192.168.1.xxx).

I’ve followed the tutorial stickied here about setting up Samba. https://forums.opensuse.org/showthread.php/520609-Configure-Samba-for-a-Workgroup-in-the-local-LAN

I’ve installed the wsdd add-on (which is why I can see my computer on the network) following this: https://forums.opensuse.org/showthread.php/540083-Samba-Network-Device-Type-for-Windows-10

I can map the Windows 10 pc shares to my linux machine, and open those shares just fine, but I really need to be able to go the other direction.

I should also note that my Windows 10 pc and linux pc are both connected to the same Windows domain with the same credentials.

Here’s my smb.conf file contents:

# smb.conf is the main Samba configuration file. You find a full commented# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
    passdb backend = tdbsam
    printing = cups
    printcap name = cups
    printcap cache time = 750
    cups options = raw
    map to guest = Bad User
    logon path = \\%L\profiles\.msprofile
    logon home = \\%L\%U\.9xprofile
    logon drive = P:
    usershare allow guests = Yes
    security = ADS
    usershare max shares = 100
    wins support = No
    idmap config  : backend = rid
    idmap config  : range = 20001-99999
    idmap config * : backend = tdb
    idmap config * : range = 10000-20000
    idmap config domainname : backend = rid
    idmap config domainname : range = 20001-99999
    template homedir = /home/%D/%U
    template shell = /bin/bash
    winbind refresh tickets = yes
    workgroup = domainname
    wins server = 
[idmap config domainname]
    local : backend = rid
    local : range = 20001-99999

    comment = Home Directories
    valid users = %S, %D%w%S
    browseable = Yes
    read only = No
    inherit acls = Yes
    guest ok = Yes

    comment = Network Profiles Service
    path = %H
    read only = No
    store dos attributes = Yes
    create mask = 0600
    directory mask = 0700
    guest ok = Yes

    comment = All users
    path = /home
    read only = No
    inherit acls = Yes
    veto files = /aquota.user/groups/shares/
    guest ok = Yes

    comment = All groups
    path = /home/groups
    read only = No
    inherit acls = Yes
    guest ok = Yes

    comment = All Printers
    path = /var/tmp
    printable = Yes
    create mask = 0600
    browseable = No
    guest ok = Yes

    comment = Printer Drivers
    path = /var/lib/samba/drivers
    write list = @ntadmin root
    force group = ntadmin
    create mask = 0664
    directory mask = 0775
    guest ok = No

    inherit acls = Yes
    path = /home/chrisw/
    read only = No
    guest ok = Yes

    path = /home/domainname/cwoolly/Desktop/Share
    available = yes
    valid users = chrisw
    read only = no
    browsable = yes
    public = yes
    writable = yes

I changed the name of my domain to “domainname” here.

I don’t know if this will help, but here’s the contents of my “/etc/samba/” folder:

Let me know what other information you need, my brain is a little fired right now.

Thanks in advance.


Sorry, haven’t gone through the tutorials but one common pitfall is the firewall. Try disabling it and see if you get any better results.

Disabled the firewall, and still no dice. I’m sure there’s something simple that I’m missing because this is all new to me.