Unable to connect by USB to three Android 11 smartphones; 'file or folder does not exist' error

I transfer files from my Android 11 smartphone to my desktop by connecting the two via a USB cable and changing the Android’s USB preferences from ‘No data transfer’ to ‘File transfer.’ It worked only yesterday, has worked consistently in the past without glitches.

Today, no. I see the smartphone under ‘Devices’ in KDE dolphin after connecting the cable, but when I click the smartphone icon get:

The file or folder udi=/org/kde/solid/udev/sys/devices*** does not exist

I have two older smartphones, both running Android 11, dusted them off, plugged them in. Same error message.

Any troubleshooting advice will be appreciated, as always.

I’m on snapshot 20210817.

I tried first on snapshot 20210810 and everything worked fine, the updated to 20210817 and I also see the problem.

I did install mtfs (“sudo zypper in mtpfs”) but that also errors out, trying a second time triggers a warning that the device is busy:

$ sudo mtpfs /mnt
Listing raw device(s)
Device 0 (VID=2e04 and PID=c025) is a Nokia 6.
   Found 1 device(s):
   Nokia: 6 (2e04:c025) @ bus 2, dev 11
Attempting to connect device 0
Android device detected, assigning default bug flags

Listing File Information on Device with name: (NULL)

$ sudo mtpfs /mnt/xfs
Listing raw device(s)
Device 0 (VID=2e04 and PID=c025) is a Nokia 6.
   Found 1 device(s):
   Nokia: 6 (2e04:c025) @ bus 2, dev 11
Attempting to connect device 0
libusb_claim_interface() reports device is busy, likely in use by GVFS or KDE MTP device handling alreadyLIBMTP PANIC: Unable to initialize device
Unable to open raw device 0

The second problem is there because the was still a mtpfs process running, after killing it I can run it again without that problem.

Checking the error of Dolphin

The file or folder udi=/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:14.0/usb2/2-11/ does not exist.

I see that the problem seems to not with the low-level data:

$ ls /sys/devices/pci0000\:00/0000\:00\:14.0/usb2/2-11/
2-11:1.0             bDeviceProtocol     bNumInterfaces  devpath        ltm_capable   quirks     subsystem
authorized           bDeviceSubClass     busnum          driver         manufacturer  removable  tx_lanes
avoid_reset_quirk    bmAttributes        configuration   ep_00          maxchild      remove     uevent
bcdDevice            bMaxPacketSize0     descriptors     firmware_node  port          rx_lanes   urbnum
bConfigurationValue  bMaxPower           dev             idProduct      power         serial     version
bDeviceClass         bNumConfigurations  devnum          idVendor       product       speed

I think the problem could be well something like this patch is fixing, not sure if my mtpfs executable has already that fix.

I use neither Tumbleweed nor Android, but this looks to me like a regression and thus worth a bug report.

Report filed: https://bugzilla.opensuse.org/show_bug.cgi?id=1189687

I had a similar problem with an Android 10 phone and Leap 15.3. It was not consistent. When I got the error message, if I right clicked the phone in Dolphin and selected “Open in New Window”, it always worked. May not apply to your Tumbleweed and Android 11 though.

That was certainly worth a try, crmrhm, and thanks for the suggestion … but, unfortunately, it didn’t work, at least not in my case. Opening in a new window produced the same error message.

Hmmm. I connect Android and Iphones both up to my desktop and they work fine.

When I plug in the phone, a screen appears on the phone asking me if I want to trrust the desktop. I click trust. Then I go to the desktop and click try again.

I use Gnome and Nautilus. It works great.

Sorry I can’t comment on kde stuff. I just posted to see if anywhere in my experience you might find something helpful.

I did install mpt-tools (zypper in mtp-tools) and got some new tools (rpm -ql mtp-tools).

The (long) output of mtp-detect looks fine and mtp-folders does list the folders on my device so this seems not to be a problem with libmtp “an sich”.

Found this relative recent FreeBSB thread What’s the deal with dolphin and MTP devices.

The output of “solid-hardware5 list” does seem to list my connected phone:

$ solid-hardware5 list | grep usb2
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:14.0/usb2/2-11'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:14.0/usb2/2-13/2-13:1.2/sound/card2'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:14.0/usb2/2-13/2-13:1.2/sound/card2/pcmC2D0c'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:14.0/usb2/2-13/2-13:1.2/sound/card2/controlC2'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:14.0/usb2/2-14/2-14:1.0/net/wlp0s20u14'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:14.0/usb2/2-5/2-5.2/2-5.2:1.0/0003:046A:B091.0001/input/input18'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:14.0/usb2/2-5/2-5.2/2-5.2:1.0/0003:046A:B091.0001/input/input18/event18'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:14.0/usb2/2-5/2-5.2/2-5.2:1.0/0003:046A:B091.0001/input/input18/mouse0'

$ cat /sys/devices/pci0000:00/0000:00:14.0/usb2/2-11/idVendor

$ lsusb -d 2e04:c025
Bus 002 Device 013: ID 2e04:c025 HMD Global Nokia 8 (MTP mode)

iamjiwjr and marel, thanks for the additional input.

DUPing to snapshot 20210820 didn’t fix this problem, at least for me.

I also just filed a bug report for a relatively minor problem that could be related, as it also appeared with the 20210817 snapshot, and also relates to USB:


Thought checking what update could have caused the dolphin MTP problem and checked New Tumbleweed snapshot 20210817 released! and sure enough there are quite some MTP related changes in kio-extras5:

  • kio-mtp: register demon on D-Bus by service name org.kde.kmtpd5
  • [kio/mtp] Use forward declaration for MTPDevice*
  • [kio/mtp] Use ecm_qt_declare_logging_category

I think the first one is most suspected.

There is also a usb-mtp-avoid-dynamic-stack-allocation.patch but that is part of qemu it seems so that is likely not relevant.

In the bug report there it is mentioned that on KDE Neon things work.

For me things worked on snapshot 20210810 but not starting from snapshot 20210817.

I can not easily go back so if anybody is still on 20210810 or can go back to 20210810, can he/she share the info you can find under Start → Settings → System Settings → System Information, i.e. KDE Plasma Version, KDE Frameworks Version, Qt Version and Kernel Version

Meanwhile there is a work-around and a fix, see https://bugzilla.opensuse.org/show_bug.cgi?id=1189687

The fix worked for me, too!

  1. Open a terminal window.

  2. As non-root user, type:

$ qdbus-qt5 org.kde.kiod5

and plug in the smartphone to see if you can now access files.

I saw the update in New Tumbleweed snapshot 20210828 released!, did a “zypper dup” and a reboot and MTP access from Dolphin works again, issue solved!

still doesn´t work…

can someone give me a step by step?

Using tumbleweed on the computer
and android 11 on the phone.