Unable to Chainload opensuse

I have recently reinstalled my second OS linux mint. Earlier Linux Mint grub was chain loaded by my OpenSUSE leap 15.3 grub. It was done by OpenSuse installer, and was working fine. After reinstalling Mint is not detecting OpenSUSE (OS-prober is disabled). So I decided to chainload Opensuse. Leap is installed on sda7 (btrfs). Linux Mint is using Ext4. System uses BIOS.

menuentry "OpenSUSE" {
    insmod chain
    insmod btrfs
    set root=(hd0,6)
    chainloader +1

I tried this. but it gives an error like “This is not a bootable disk, please insert a bootable floppy and press any key to try again”.
Please help.

If you want that to work, then you have to install booting on the openSUSE system to boot from a partition. If you installed it to boot from the MBR, the chainloading won’t work.

I am using something like:

menuentry "configfile for openSUSE 15.3 on /dev/sdb4"  {
        set bootdir='hd2,gpt4'
        search --label --set=bootdir boot2
        configfile (${bootdir})/grub2/grub.cfg

I did have to define a label to do that. You can do similar by changing the search to use uuid.

I don’t think I have tried this with “btrfs”. And that “configfile” line might need to use “/boot/grub2/grub.cfg” as the relative path.

I used the following with ext4:

menuentry 'TW-SDC /dev/sdc5' { 
    search --fs-uuid --no-floppy --set=root 4A24-B10D 
    chainloader /EFI/tumbleweed-sdc5/grubx64.efi  

Try the above first. If chain loading works with ext4 try with btrfs.