Unable to boot since kernel update (grub1, lvm, dm-crypt)

I foolishly installed the newest kernel update… now I can’t boot anymore.

Once I rebooted, grub presented me it’s friendly console. I’ve used the installation DVD to check the boot partition, everything ok, except menu.lst and menu.lst.old having a size of 0 bytes …

So I tried

grub> kernel (hd0,0)/boot/vmlinuz root=/dev/system/root
grub> initrd (hd0,0)/boot/initrd
grub> boot

which only leads to a kernel panic, since the given ‘root’ parameter seems invalid:

VFS: Cannot open root device “system/root” or unknown-block(0,0)
Please append a correct “root=” boot option; here are the available partitions:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

All that seems wrong so far is the absence of any valid menu.lst. On the other hand, this is my first machine using lvm and dm-crypt(or something else?) and I don’t know the right kernel command line :frowning:

Can anyone give me a hint on what parameters are needed?

The setup (created by 11.3 installation GUI):
hda1 /boot
hda2 LVM
hdb1 LVM

Both LVM partitions go into the volume group ‘system’, to be mounted as follows:
/dev/system/root /
/dev/system/swap swap
/dev/system/home /home (crypted)

Thanks in advance,

In your root partition
Is there by any chance a menu at /boot/grub/menu.lst

FYI: I never use anything but standard partitioning (swap, root, home) saves any heartache

Hmm, /boot/ on root partition completely empty :frowning: … actually, the update wrote the kernel and initrd onto the boot partition, and set up the right symlinks, but completely killed the menu.lst, so that partition was mounted on /boot correctly.

Yeah, I usually prefer simple setups too :slight_smile:

First step would be to tell the kernel that the root partition is in the volume group ‘system’… I’ve tried root=/dev/system/root and root=/dev/mapper/system-root, no luck so far… most probably there will be missing some luks entries when the home partition needs to be mounted… I’m a complete novice concerning lvm and dm-crypt…

I’m a complete novice concerning lvm and dm-crypt…
Sorry I can’t really advise further.

Try writing a simple boot menu to menu.lst

title openSUSE
root (hd0,0)
kernel /boot/vmlinuz root=/dev/sda1 ro quiet splash
initrd /boot/initrd

That’s probably a load of old cobblers for your setup.

no problem, at least some emotional support :smiley:

so, now I’m able to boot, except being unable to reach runlevel 5 … I recreated the initial ramdisk.

In case anyone else needs this:

  1. Boot a rescue system
  2. mkdir /newroot
  3. mount /dev/system/root /newroot
  4. mount -o bind /dev /newroot/dev
  5. chroot /newroot /bin/bash
  6. mount /dev/sda1 /boot
  7. mkinitrd
  8. reboot

Now the crypted home partition can’t be mounted … I’ll get myself another coffee, I can’t imagine being the only one with a more esoteric setup messed up by the security update… if anyone else succeeds earlier, let me now :wink:

ok, should’ve removed the ro from the kernel command line, now almost everything is fine, though some service is complaining…

and these are the grub commands so far:

root (hd0,0)
kernel /vmlinuz root=/dev/mapper/system-root
initrd /initrd

Can anyone paste a standard menu.lst from a standard openSuSE installation, I’d like to fix things up as closely as possible… most probably I’m still missing some options.


Modified by YaST2. Last modification on Sat Jul 10 09:58:32 BST 2010


Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,4)/boot/message
##YaST - activate

###Don’t change this comment - YaST2 identifier: Original name: linux###
title Desktop – openSUSE 11.3 - 2.6.34-12
root (hd0,4)
kernel /boot/vmlinuz-2.6.34-12-desktop root=/dev/disk/by-id/ata-FUJITSU_MJA2250BH_G2_K95CT9A2D4UF-part5 resume=/dev/disk/by-id/ata-FUJITSU_MJA2250BH_G2_K95CT9A2D4UF-part2 splash=silent quiet showopts vga=0x314
initrd /boot/initrd-2.6.34-12-desktop

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – openSUSE 11.3 - 2.6.34-12
root (hd0,4)
kernel /boot/vmlinuz-2.6.34-12-desktop root=/dev/disk/by-id/ata-FUJITSU_MJA2250BH_G2_K95CT9A2D4UF-part5 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x314
initrd /boot/initrd-2.6.34-12-desktop

Actually mine just changed as I just this minute did a kernel update

Thanks, now everything’s back to normal.

I guess the initrd should’ve been recreated, but it wasn’t. The menu.lst was truncated, resulting in an empty file.

I guess some process incorporated by the update died prematurely.

This issue is resolved.