Unable to access net via proxy server in 12.2

Hi,

I am using 12.2 gnome. I need to access the net via a proxy server which i am unable to configure.

In YaST -> proxy i did the following:

  1. Checked the box ‘Enable Proxy’.
  2. In proxy settings i typed http://'proxy_name’.
  3. Checked the box ‘Use the same proxy for all Protocols’ —> I use this setting on a CentOS 5 desktop.
  4. Wrote my name and password in ‘Proxy Authentication’.

But when i click ‘Test Proxy Settings’ i get an error — Could not resolve proxy.

Airplane mode is off. Also,

Activities -> Applications -> Network Connections -> Wired -> In IPv4 settings -> Manual -> I’ve put address, netmask, gateway, DNS servers correctly and checked the box ‘Require IPv4 addressing for this connection to complete’.

My /etc/sysconfig/proxy has:

PROXY_ENABLED=“yes”
HTTP_PROXY="‘proxy_name’"
HTTPS_PROXY="‘proxy_name’"
FTP_PROXY="‘proxy_name’"
GOPHER_PROXY=""
NO_PROXY=“localhost, 127.0.0.1”

I’m stuck. Pl advise. Thanks.

On Fri 09 Nov 2012 02:46:01 PM CST, samrat rao wrote:

Hi,

I am using 12.2 gnome. I need to access the net via a proxy server
which i am unable to configure.

In YaST -> proxy i did the following:

> 1) Checked the box ‘Enable Proxy’.
> 2) In proxy settings i typed ‘http://‘proxy_name’
> (http://%27proxy_name)’.
> 3) Checked the box ‘Use the same proxy for all Protocols’ —> I use
> this setting on a CentOS 5 desktop.
> 4) Wrote my name and password in ‘Proxy Authentication’.

But when i click ‘Test Proxy Settings’ i get an error — Could not
resolve proxy.

Airplane mode is off. Also,

> Activities -> Applications -> Network Connections -> Wired -> In IPv4
> settings -> Manual -> I’ve put address, netmask, gateway, DNS servers
> correctly and checked the box ‘Require IPv4 addressing for this
> connection to complete’.

My /etc/sysconfig/proxy has:

> PROXY_ENABLED=“yes”
> HTTP_PROXY="‘proxy_name’"
> HTTPS_PROXY="‘proxy_name’"
> FTP_PROXY="‘proxy_name’"
> GOPHER_PROXY=""
> NO_PROXY=“localhost, 127.0.0.1”

I’m stuck. Pl advise. Thanks.

Hi
From the GNOME shell desktop, have you tried configuring in via
Menu -> System Settings -> Network -> Network proxy


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 1:08, 3 users, load average: 0.05, 0.04, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

Hi Malcolm,

I had done that as well, but i just realized that the problem lies a few stages before.

The ethernet card has not been detected.** ifconfig** does not show any eth0 or eth1 entry.

It is Atheros Communications Inc. AR8162 Fast Ethernet [1969:1090] (rev 10)
Subsystem: Lenovo Device [17aa:3978]

I read somewhere that compat-wireless needs to be installed. I could not find it in the standard repos + Packman. Do i have to compile the driver?

On Fri 09 Nov 2012 04:46:01 PM CST, samrat rao wrote:

malcolmlewis;2502570 Wrote:
> Hi
> From the GNOME shell desktop, have you tried configuring in via
> Menu → System Settings → Network → Network proxy
>
> –
> Cheers Malcolm °¿° (Linux Counter #276890)
> openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
> up 1:08, 3 users, load average: 0.05, 0.04, 0.05
> CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

Hi Malcolm,

I had done that as well, but i just realized that the problem lies a
few stages before.

The ethernet card has not been detected.* ifconfig* does not show any
eth0 or eth1 entry.

It is Atheros Communications Inc. AR8162 Fast Ethernet [1969:1090]
(rev 10)
Subsystem: Lenovo Device [17aa:3978]

I read somewhere that compat-wireless needs to be installed. I could
not find it in the standard repos + Packman. Do i have to compile the
driver?

Hi
Ahh wondered about that… ok, please start a new thread in the
wireless subforum, see the stickies on what commands/output to post
(please use code tags).

Then I’m sure you will grab the attention of user lwfinger :wink:


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 2:34, 3 users, load average: 0.08, 0.07, 0.06
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU