ulimit problem

I can’t get ulimit -l unlimited to “stick” - I’ve tried sudo ulimit -l unlimited - that doesn’t work. I’ve tried setting it as superuser, but my regular users accounts don’t pick it up. I tried setting:

@users soft memlock unlimited
@patti soft memlock unlimited

…in etc/security/limits.conf

But I still get
patti@OS121-TY3:~/ModelE/modelE_AR5_v2_branch_04-30-2013/decks> ulimit -a
core file size (blocks, -c) 0
data seg size (kbytes, -d) unlimited
scheduling priority (-e) 0
file size (blocks, -f) unlimited
pending signals (-i) 2067141
max locked memory (kbytes, -l) 64
max memory size (kbytes, -m) unlimited
open files (-n) 1024
pipe size (512 bytes, -p) 8
POSIX message queues (bytes, -q) 819200
real-time priority (-r) 0
stack size (kbytes, -s) 8192
cpu time (seconds, -t) unlimited
max user processes (-u) 2067141
virtual memory (kbytes, -v) unlimited
file locks (-x) unlimited

I cannot run my programs which need ulimit -l as superuser, so how do I set this correctly so it affects the users?

/etc/security/limits.conf is the right file to modify; did you
logout/login after doing that? ulimit is a per-session/shell setting so
setting it as sudo, or setting it in one shell and then launching a
program in another, will not help… kind of like any environment variable
being set.

Good luck.

The @patti bit is probably wrong… @patti literally means the ‘patti’
group, and it looks like you may just mean ‘patti’, as in the patti user.

Good luck.

You also need to increase hard limit. soft limit cannot exceed hard.

Yes, I even rebooted. Is there a syntax problem with that file? :confused::confused::confused::confused:

I tried the hard limit first, then when that didn’t do it, I added the soft limit line. Something is messed up here - is there a way to diagonse? The only way I was able to get ‘unlimited’ to be reported by ulimit -l was to do it as superuser, but it didn’t seem to affect my normal user(s). And I can’t run my software as superuser.

Which should I use here, soft or hard?

hard is absolute limit and soft - default for new session. So you need hard in any case and additionally soft if you want change default.

Thanks for the information, everyone! I have a thick skull. Here is what worked:

  •                 hard    memlock         unlimited

@users hard memlock unlimited
@users soft memlock unlimited
patti soft memlock unlimited

…I’m not sure what exactly fixed it, but now I get:
patti@OS121-TY3:~/ModelE/modelE_AR5_v2_branch_04-30-2013/decks> ulimit -l

On 2013-05-12 23:46, PattiMichelle wrote:
> Thanks for the information, everyone! I have a thick skull. Here is
> what worked:

Please use code tags for printouts and commands. Advanced editor, ‘#’
button. Posting in Code Tags - A Guide

This is important.

Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)