{UEFI, legacy} x {full, net} install on Dell 7710 all fail

I have a new Dell 7710 that came with Ubuntu. I am trying to switch to OpenSUSE Tumbleweed.

Since the hardware does UEFI, I initially did a UEFI install. The install process appeared to work fine, but it would not boot. In the BIOS, there was no bootable version of SUSE. Also, oddly, after the install, the BIOS refused to UEFI boot the USB media (something obviously changed in the install process). If I just let it boot, I got a blank black screen. In the BIOS setup, I could not find any bootable UEFI systems.

I also tried legacy boot. Again, I could go completely through the install process. However, I was told by the BIOS that there was nothing bootable on any of the disks (I tried each of them as primary, since the BIOS does not identify them in any way).

At this point, I have tried both UEFI and legacy booting for both the full DVD image and the net install and all are failing.

I can take the Dell recovery media and re-install Ubuntu just fine, and it will work. Unfortunately, KDE is (still) a second-class citizen on Ubuntu. And, the Dell Ubuntu installer offers to encrypt the disk, but never actually does it. This is the real deal-breaker.

So, what’s the difference? Admittedly, my UEFI knowledge is weak compared with legacy, but even legacy was failing.



I found this here:


…“Storage Samsung SM951 MZVPV256HDGL m.2 PCI-e”

Can you describe on which kind of boot medium you tried to install? Have TW/LEAP on several older Dell notebooks/workstations on SATA HDD/SSDs, without problem (both UEFI and legacy). So maybe it’s a driver problem with “m.2 PCI-e”?

You may need to edit the BIOS to add Tumbleweed to the boot options.http://www.dell.com/support/article/us/how-to-install-ubuntu-developer-edition-on-a-dell-pc-configured-for-the-unified-extensible-firmware-interface-(uefi)-bios/04/SLN297060/en?lang=EN

Thanks for the reply, raspu.

The storage installed is two m.2 SSD drives and one 2.5in SATA SSD. The drivers appear to work fine during install. During the last iteration, I left Ubuntu installed, and I could see the OpenSUSE install on one of the other drives. So, clearly the drivers work in the install kernel.

And, I never get to a kernel, so any problems there are waiting for me to find.

Thanks for the reply, Metapsych](https://forums.opensuse.org/member.php/96724-Metapsych).

Tumbleweed did not show up in the UEFI list after install; it did show up in the UEFI boot list when I put in the USB drive with the install media.

I followed the instructions there for legacy boot, and I can continue to legacy boot the USB drive, but I cannot get the system to legacy boot the OS installed on the disk. It says something about no operating system found (I re-installed Dell Ubuntu for the nth time, so I don’t have access to the exact message at the moment).

Does it install it in EFI or legacy BIOS mode?

So, what’s the difference?

Well, one obvious difference is, that recovery media can use any vendor specific undocumented tricks that normal Linux installation cannot. Did you try to install Ubuntu using standard install medium?

Could you post output of “efibootmgr -v” after finishing openSUSE install in EFI mode?

Thanks for the reply, arvidjaar.](https://forums.opensuse.org/member.php/69818-arvidjaar)

I tried both installing in EFI and legacy mode. None booted after install.

I have not tried normal Ubuntu media. That’s a good idea.

Also, I see that there are some other things in the Dell page that Metapsych](https://forums.opensuse.org/member.php/96724-Metapsych) referenced that I am going to try. I’ll be back to post after a new install try. I’ll also get the efibootmgr -v output, assuming I can get it from the installed system before it tries to reboot.

There is no need to be in installed system. Just boot in any live Linux media (openSUSE installation DVD would do) in EFI mode.

I tried both installing in EFI and legacy mode.

It does not answer my question - does Dell recovery install Ubuntu in EFI or legacy BIOS mode?

The Dell recovery installs in UEFI mode.

Tumbleweed install is proceeding right now; hopefully I will know more in a few minutes.

I have no clue what I did differently, but this time the install succeeded and it appears that everything is working and all storage is encrypted.

A wild guess about the solution is that I installed over the existing Ubuntu install rather to a different SSD.

That’s great news. Enjoy Tumbleweed! I sure do.