UEFI based dual boot system

I had a BIOS based dual boot system, with two hard drive: openSuse Leap 15.4 (sda) and Windows Server 2019 (sdb).
I moved those hard drives to a UEFI based system where the GRUB dual boot work properly.
Now, I installed openSuse Leap 15.5, in place of Leap 15.4, and DRUB no longer gives me the possibility to boot with Windows.

How can I make GRUB list the option to start Windows?
(I have no experience on systems with UEFI.)

Thank you in advance.

Adrián E. Córdoba

Did you install it in BIOS or UEFI mode.

Mark that in multi-boot all systems should use the same.

1 Like

One be sure fast boot is off in Windows . Fast boot leaves drives unmountable in other OS.
Two Be sure no fancy setting in Windows ie encryption or compression is on
Three be sure that bot OS us the same boot methods. Can not have Windows in EFI and Linux in legacy.

I think I installed in UEFI mode. (I don’t remember taking any option in that regard.)

Depends on how you booted install which would be an option in the BIOS/UEFIBoot it in legacy it will default to installing in legacy. And that depends on settings in the BIOS

I think Windows in BIOS boot method. (Windows was installed in BIOS system.)

Maybe, Can you boot Windows from BIOS. Possibly you missed something in the move.

IF EFI boot you would need the original UEFI partition since it holds the EFI booting OS’s boot info

1 Like

So, I need reinstall Windows on UEFI boot system in order to Windows appear as an option in GRUB. Wright?
(I remember, when I installed Leap 15.5, /boot/efi partition was created.)

Yes, I can boot Windows from BIOS.

Then that is the cause of your problem.

Grub with UEFI booting cannot boot Windows with BIOS booting.

Your options:

(1) Reinstall Windows for UEFI booting;
(2) Convert Windows to UEFI booting (you can google to find how). But this might not be possible or easy, depending on your setup.
(3) Convert Leap 15.5 to use BIOS booting.

1 Like

Thank you, nrickert!
I will reinstall Windows for UEFI booting, only for learning.
But, for curiosity, how can I convert Leap for BIOS booting?

You can use Yast → Bootloader
and change “GRUB2 for EFI” to “GRUB2”. You might also need to make changes in your BIOS settings so that it will boot using CSM.

1 Like