Two graphics cards

I’ve got a laptop (ACER Aspire 8935G) with two graphic cards, one is an ATI Mobility Radeon HD 4670 (no entry in the wiki page about compatibility with openSUSE for the Mobility version…) and the other is a low-power Intel graphic card (for low power). I’ve installed Fedora on the laptop, but it sticks to the Intel card, and I didn’t manage to change it, nor did I get an answer on Fedora forums.

Is there any general option to do that under SUSE? I understand that it might not work with this configuration of hardware, but is it even possible to choose the graphic card to be used? If yes, could you provide some link to/name of the feature, so I can look further into it?


How much RAM does this laptop have ? To get a handle on what I am going to recommend, please first read post#1 (ATI) and post#3 (Intel) in this practical theory guide: openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

So , now that you know some graphic card theory for openSUSE, you could download an openSUSE liveCD, and then see what you can do with that. That way you do NOT need to install anything to test. Note I stated a liveCD and NOT a DVD. You can not test from a DVD like you can from a liveCD.

Also try an openSUSE-11.2 liveCD and not an 11.3 miletone liveCD (as 11.2 has the tool sax2 on the liveCD, where 11.3 milestone releases do not). Download the liveCD, do the md5sum check of downloaded iso vs md5sum on download website and if that passes then burn iso to a +R or -R CD (not an RW) at slowest speed your burner allows.

Then boot to that liveCD. At first splash/boot menu, select F3 and selected TEXT ! Then boot the liveCD and it should boot to a full screen text mode. When greeted with a text login prompt, login as user “linux” and use <enter> as password. Then type “su” (no quotes) to switch users to root (administrator) using <enter> as password.

Then use the openSUSE tool “sax2”.

Then type:

sax2 -p

to see what graphic cards sax2 recognizes. Hopefully you will see a chip-0 and a chip-1, where one of these two is your Intel and the other your Radeon.

If that is the case, you can test both (one at a time) with the basic vesa driver.

For chip-0:

sax2 -r -m 0=vesa

and if that works, exit sax2, type “exit” to get rid of root permissions (that is VERY important) and then type “startx” to boot to X.

Alternatively, for chip-1 (instead of chip-0 above):

sax2 -r -m 1=vesa

and if that works, exit sax2, type “exit” to get rid of root permissions (that is VERY important) and then type “startx” to boot to X.

Now lets say you know chip-0 to be Intel. Then you could instead of vesa try:

sax2 -r -m 0=intel

and if that works, exit sax2, type “exit” to get rid of root permissions (that is VERY important) and then type “startx” to boot to X.

Of course if the intel was chip-1 then it would be “sax2 -r -m 1=intel”.

Now lets say you know chip-1 to be the Radeon. Then you could instead of vesa try the radeonhd driver:

sax2 -r -m 1=radeonhd

and if that works, exit sax2, type “exit” to get rid of root permissions (that is VERY important) and then type “startx” to boot to X.

… but its possible the ‘radeonhd’ did not work, in which case you could try ‘radeon’ driver. So to try chip-1 as the radeon driver you could try:

sax2 -r -m 1=radeon

and if that works, exit sax2, type “exit” to get rid of root permissions (that is VERY important) and then type “startx” to boot to X.

Note both the radeon and radeonhd driver as packaged in openSUSE-11.2 are buggy, … but there are updates available. So if you have at least some functionality with one of those two (necessary to prove there is some chance of this working), then there is a further chance you can get it working better after installation by updating to a more cutting edge (less buggy) version of the driver.

Note those sax2 commands should be run from run level 3 (a full screen text mode with NO X running anywhere on the PC) and not from run level 5.

Thanks for the quick reply :slight_smile:

The only configuration that worked was the intel for the intel chip, even vesa drivers wouldn’t start up the ATI card. Is it possible to download the newest realese of radeon or radeonhd packages into my hard drive and use them from the liveCD?

Also SUSE wouldn’t detect my network hardware. Neither the wireless, nor the cable.

I got myself into quite some trouble with this laptop :smiley: it seems.

Sorry to read that. Is it possible for you to provide more technical information? Did you get any errors? What was in the /var/log/Xorg.0.log when you tried the various drivers? (you can post it on

What was the output of

sax2 -p

when run as root. I know you can see that but those trying to help can not.

I recommend you keep a digital camera handy, so you can take pix of errors, and not have to write them down all the time. :slight_smile:

Yes, but you need a PC with lots of RAM (at least 4GB IMHO) and as soon as you switch OFF the power, all the work one does to set it up (and there is a lot because one is doing this from a LiveCD as opposed to a regular install) is lost.

Again, more technical information to confirm this would be helpful.

I’m no expert in wireless, and I mess up things quite often, but I am rather skeptical here: re your statements without any more detail. I confess I have acquired a healthy skeptism over the years, and as long as I can improve my ability to be tactful, then asking questions can sometimes help point one in the right direction.

I’m no expert neither. I only said it didn’t use them on it’s own. With some searching I’m sure I would be able to make it work, but that’s only if I manage to get the graphic cards working how I want them to (otherwise I’m just sticking to my Fedora and being a lame Linux user untill I have more time to learn how to properly use it :smiley: )

Ok, I’ve managed to copy the config files to my hard drive and >> the outputs too

sax2 -p:

Chip: 0  is -> Intel Mobile Intel® GM45 Express Chipset 00:02:0 0x8086 0x2a42 PCI intel
Chip: 1  is -> ATI ATI MOBILITY  RADEON HD 4670 01:00:0 0x1002 0x9488 AGP radeonhd

outputs of both
sax2 -r -m 1=radeon
sax2 -r -m 1=radeonhd
are the same:

SaX: initializing please wait...
SaX: no X-Server is running
SaX: will start own server if needed
ISaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199. //(repeated about 6 times)

SPP: prepare device [0] profile: Depth24
SPP: prepare device [0] profile: Intel
SPP: calling device [0] profile script: Intel
SPP: prepare device [0] profile: AIGLX
SPP: prepare device [0] profile: Composite
SPP: prepare device [0] profile: Virtual2k
SPP: prepare device [0] profile: Virtual
SPP: including prepared profile(s)...

SaX: startup

xc: sorry could not start configuration server
xc: for details refer to the log file:


xc: abort...

the line with “//(repeated about 6 times)” added to it didn’t get into the file, but went to the console output. and it appeared there about 6 times

the .log files produced are rather long:


SaX2 log     : SaX2 version 8.1 - SVN Release: 1.49 2003/03/17
DESCRIPTION  : X11 configuration log file to collect information
             : about detection, startup and configuration.
             : There are three parts of logging:
             : ---
             : 1) INIT     ( detection, 3D )
             : 2) STARTUP  ( xorg.conf, X11 log, glxinfo )
             : 3) CONFIG   ( config actions )
             : ---
VERSION      : SaX2 compiled for: [OTHER]
PARAMETER    : -r -m 1=radeonhd -r
LOG DATE     : Sun Mar 21 19:31:08 UTC 2010
Framebuffer Info:
Framebuffer is active

21-Mar 19:31:09 <I> Initializing...
21-Mar 19:31:10 <I>  Sysp: Mouse detection data
	Mouse0    =>  Protocol   : explorerps/2
	Mouse0    =>  Device     : /dev/input/mice
	Mouse0    =>  Buttons    : 5
	Mouse0    =>  Wheel      : 1
	Mouse0    =>  Emulate    : 0
	Mouse0    =>  Name       : SynPS/2 Synaptics TouchPad
	Mouse0    =>  VendorID   : 0x0002
	Mouse0    =>  DeviceID   : 0x0007
	Mouse0    =>  Profile    : <undefined>
	Mouse0    =>  RealDevice : /dev/input/by-path/platform-i8042-serio-2-event-mouse
	Mouse0    =>  NutShell   : 0
21-Mar 19:31:10 <I>  Sysp: Keyboard detection data
	Keyboard0 =>  XkbModel   : microsoftpro
	Keyboard0 =>  XkbLayout  : us
	Keyboard0 =>  Name       : AT Translated Set 2 keyboard
	Keyboard0 =>  VendorID   : 0x0001
	Keyboard0 =>  DeviceID   : 0x0001
	Keyboard0 =>  Profile    : <undefined>
	Keyboard0 =>  RealDevice : /dev/input/event0
21-Mar 19:31:10 <I>  Sysp: Server detection data
	Card0     =>  DomainId   : 0x0
	Card0     =>  BusId      : 0x0
	Card0     =>  SlotId     : 0x02
	Card0     =>  FuncId     : 0x0
	Card0     =>  Vendor     : Intel
	Card0     =>  Device     : Mobile Intel® GM45 Express Chipset
	Card0     =>  VID        : 0x8086
	Card0     =>  DID        : 0x2a42
	Card0     =>  Module     : intel
	Card0     =>  BusType    : PCI
	Card0     =>  Detected   : 2
	Card0     =>  Flag       : DEFAULT
	Card0     =>  SUB-VID    : 0x1025
	Card0     =>  SUB-DID    : 0x019f
	Card0     =>  DrvProfile : Depth24,Intel,AIGLX,Composite,Virtual2k
21-Mar 19:31:29 <I>  Sysp: XStuff detection data
	Card0     =>  DDC        : CMO1807
	Card0     =>  DDC[2]     : CMO1807
	Card0     =>  Name       : N184H6-L02 LCD Monitor
	Card0     =>  Vendor     : CMO
	Card0     =>  Name[2]    : N184H6-L02 LCD Monitor
	Card0     =>  Vendor[2]  : CMO
	Card0     =>  Primary    : 00-02-0
	Card0     =>  Chipset    : <undefined>
	Card0     =>  Vsync      : 60
	Card0     =>  Hsync      : 94
	Card0     =>  Vsync[2]   : 60
	Card0     =>  Hsync[2]   : 94
	Card0     =>  Vesa       : 1920 1080 94 60
	Card0     =>  Vesa[2]    : 1920 1080 94 60
	Card0     =>  Dacspeed   : 220
	Card0     =>  Dacspeed[2]: 220
	Card0     =>  Modeline   : <undefined>
	Card0     =>  Modeline[2]: <undefined>
	Card0     =>  Memory     : 262144
	Card0     =>  RandR      : VGA disconnected%LVDS connected
	Card0     =>  Current    : 00-02-0
	Card0     =>  RawDef     : None
	Card0     =>  Option     : EXANoComposite
	Card0     =>  Extension  : None
	Card0     =>  Module     : intel
	Card0     =>  Display    : LCD/TFT
	Card0     =>  Display[2] : LCD/TFT
	Card0     =>  Size       : 408x230
	Card0     =>  Size[2]    : 408x230
	Card0     =>  VesaBios   : 3.0
	Card0     =>  FBBoot     : 800 600 16 788
	Card0     =>  FBBoot     : 800 600 24 789
	Card0     =>  FBBoot     : 800 600 8 771
	Card0     =>  FBBoot     : 1024 768 8 773
	Card0     =>  FBBoot     : 1024 768 16 791
	Card0     =>  FBBoot     : 1024 768 24 792
	Card0     =>  FBBoot     : 1280 1024 8 775
	Card0     =>  FBBoot     : 1280 1024 16 794
	Card0     =>  FBBoot     : 1280 1024 24 795
21-Mar 19:31:30 <I>  Sysp: 3D detection data
	Card3D0   =>  Install    : <none>
	Card3D0   =>  Remove     : <none>
	Card3D0   =>  Packages   : <none>
	Card3D0   =>  Active     : 0
	Card3D0   =>  Answer     : no
	Card3D0   =>  ScriptReal : <none>
	Card3D0   =>  ScriptSoft : <none>
	Card3D0   =>  Flag       : <none>
21-Mar 19:31:33 <X> Startup...
21-Mar 19:31:33 <X> Startup on new Server: <:0.0>
21-Mar 19:31:33 <X> Logging File contents: /tmp/sax2-3634/xorg.conf 
	# /.../
	# SaX generated X11 config file
	# Created on: 2010-03-21T19:31:33+0000.
	# Version: 8.1
	# Contact: Marcus Schaefer <>, 2005
	# Contact: SaX-User list <>
	# Automatically generated by [SaX2] (8.1)
	Section "Files"
	  FontPath     "/usr/share/fonts/misc:unscaled"
	  FontPath     "/usr/share/fonts/local"
	  FontPath     "/usr/share/fonts/75dpi:unscaled"
	  FontPath     "/usr/share/fonts/100dpi:unscaled"
	  FontPath     "/usr/share/fonts/Type1"
	  FontPath     "/usr/share/fonts/URW"
	  FontPath     "/usr/share/fonts/Speedo"
	  FontPath     "/usr/share/fonts/PEX"
	  FontPath     "/usr/share/fonts/cyrillic"
	  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
	  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
	  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
	  FontPath     "/usr/share/fonts/latin2/Type1"
	  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
	  FontPath     "/usr/share/fonts/baekmuk:unscaled"
	  FontPath     "/usr/share/fonts/japanese:unscaled"
	  FontPath     "/usr/share/fonts/kwintv"
	  FontPath     "/usr/share/fonts/truetype"
	  FontPath     "/usr/share/fonts/uni:unscaled"
	  FontPath     "/usr/share/fonts/CID"
	  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
	  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
	  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
	  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
	  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
	  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
	  FontPath     "/usr/share/fonts/hellas/Type1"
	  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
	  FontPath     "/usr/share/fonts/xtest"
	  FontPath     "/opt/kde3/share/fonts"
	  InputDevices "/dev/gpmdata"
	  InputDevices "/dev/input/mice"
	Section "Module"
	  Load         "dri"
	  Load         "dbe"
	  Load         "extmod"
	  Load         "glx"
	Section "ServerFlags"
	  Option       "AIGLX" "on"
	  Option       "AllowMouseOpenFail" "on"
	  Option       "ZapWarning" "on"
	Section "InputDevice"
	  # Driver "kbd" will be disabled unless 'Option "AutoAddDevices" "off"' 
	  # is set in "ServerFlags" section. 
	  Driver       "kbd"
	  Identifier   "Keyboard[0]"
	  Option       "Protocol" "Standard"
	  Option       "XkbLayout" "us"
	  Option       "XkbModel" "microsoftpro"
	  Option       "XkbRules" "xfree86"
	Section "InputDevice"
	  # Driver "mouse" will be disabled unless 'Option "AutoAddDevices" "off"' 
	  # is set in "ServerFlags" section. 
	  Driver       "mouse"
	  Identifier   "Mouse[1]"
	  Option       "Buttons" "5"
	  Option       "Device" "/dev/input/mice"
	  Option       "Name" "SynPS/2 Synaptics TouchPad"
	  Option       "Protocol" "explorerps/2"
	  Option       "Vendor" "Sysp"
	  Option       "ZAxisMapping" "4 5"
	Section "Monitor"
	  DisplaySize  408 230
	  HorizSync    30-94
	  Identifier   "Monitor[0]"
	  ModelName    "N184H6-L02 LCD MONITOR"
	  Option       "DPMS"
	  Option       "PreferredMode" "1920x1080"
	  VendorName   "CMO"
	  VertRefresh  43-60
	  UseModes     "Modes[0]"
	Section "Modes"
	  Identifier   "Modes[0]"
	  Modeline 	"1920x1080" 172.80 1920 2040 2248 2576 1080 1081 1084 1118
	  Modeline 	"1920x1080" 136.25 1920 1968 2000 2080 1080 1083 1088 1111 +HSync -Vsync
	Section "Device"
	  Driver       "radeonhd"
	Section "Device"
	  BoardName    "Mobile Intel® GM45 Express Chipset"
	  BusID        "0:2:0"
	  Driver       "intel"
	  Identifier   "Device[0]"
	  Option       "EXANoComposite"
	  Option       "monitor-LVDS" "Monitor[0]"
	  VendorName   "Intel"
	Section "Screen"
	  DefaultDepth 24
	  SubSection "Display"
	    Depth      15
	    Modes      "1920x1080" 
	    Virtual    3840 1200
	  SubSection "Display"
	    Depth      16
	    Modes      "1920x1080" 
	    Virtual    3840 1200
	  SubSection "Display"
	    Depth      24
	    Modes      "1920x1080" 
	    Virtual    3840 1200
	  SubSection "Display"
	    Depth      8
	    Modes      "1920x1080" 
	    Virtual    3840 1200
	  Device       "Device[0]"
	  Identifier   "Screen[0]"
	  Monitor      "Monitor[0]"
	Section "ServerLayout"
	  Identifier   "Layout[all]"
	  InputDevice  "Keyboard[0]" "CoreKeyboard"
	  InputDevice  "Mouse[1]" "CorePointer"
	  Screen       "Screen[0]"
	Section "DRI"
	    Group      "video"
	    Mode       0660
	Section "Extensions"
	  Option       "Composite" "on"
21-Mar 19:31:35 <X> Logging File contents: /var/log/xlog 
	(II) config/hal: initialized
	X.Org X Server 1.6.5
	Release Date: 2009-10-11
	X Protocol Version 11, Revision 0
	Build Operating System: openSUSE SUSE LINUX
	Current Operating System: Linux linux #1 SMP 2009-10-26 15:49:03 +0100 i686
	Build Date: 02 November 2009  12:05:39PM
	Before reporting problems, check
	to make sure that you have the latest version.
	Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
	(==) Log file: "/var/log/Xorg.0.log", Time: Sun Mar 21 19:31:33 2010
	(++) Using config file: "/tmp/sax2-3634/xorg.conf"
	Parse error on line 108 of section Device in file /tmp/sax2-3634/xorg.conf
	This section must have an Identifier line.
	(EE) Problem parsing the config file
	(EE) Error parsing the config file
	Fatal server error:
	no screens found
	Please consult the The X.Org Foundation support 
	 for help. 
	Please also check the log file at "/var/log/Xorg.0.log" for additional information.
	(WW) xf86CloseConsole: KDSETMODE failed: Bad file descriptor
	(WW) xf86CloseConsole: VT_GETMODE failed: Bad file descriptor

The one produced by 1=radeon ends in the same manner (no screens found)

See if you can disable the Intel onboard from the BIOS, remove xorg.conf and retry to configure the card as oldcpu suggested. This way the ATI would become device0

It appears the radeon and radeonhd driver as packaged in openSUSE-11.2 does not work well with the radeonhd 4670. One needs the updates to the driver on the Xorg : x11 repository per post #11 here: openSUSE Forums - View Single Post - openSUSE Graphic Card Practical Theory Guide for Users unfortunately there is no real way to test that with a liveCD as it requires a reboot.

Hence that likely viable approach is not available to you.

You could (if your PC has sufficient RAM) now try the proprietary ATI graphic driver. I think you need at least 4GB of ram to try that. You need to boot to the liveCD run level 3, and then from zypper (not from yast as it will install to much) install kernel-source and kernel-syms (of the same version as the kernel to match the on the liveCD) and also linux kernel headers, gcc, make, automake. Do not go to yast to install this as it will try to install something like 400MB worth of rpms which one does not have the space to waste in a liveCD boot.

Then make the driver per the guidance here: ATI/The Hard Way - openSUSE while it states that wiki is out of date, frankly the one it refers to is IMHO worse, and I recommend the wiki I quote … ie from a text mode (you need a wired connection to the internet)

  • login as a regular user (not root)
  • download the ATI driver .run file
  • su #switch to user root
  • install the rpms I noted with zypper:
    zypper install kernel-source kernel-syms linux-kernel-headers gcc make automake
  • run sh ati*.run --buildpkg SuSE/SUSE112-AMD64
  • rpm -Uvh fgl*.rpm
  • ldconfig
  • aticonfig --initial
  • type: exit #to get rid of root permission
  • startx

You may need to play with aticonfig input arguments to get it to see and configure your graphic card.

I am in a similar situation to unfrog.

I have an Acer 8935g laptop, openSUSE 11.2, 4GB ram and two cards:
Chip 0: Intel GM45
Chip 1: ATI HD4670

I am able to get radeonhd working ok, but I want the full functionality of the card (extra speakers, mic etc) so tried to install the proprietary driver.

I have worked through all the various links that you suggest, but to no avail. I have tried ‘one-click’, the easy way, the hard way, been in and out of init 3 like a yo-yo, but the system will only recognise the first card (Intel) which has much reduced functionality.

Both the ATI driver executable and the rpm option appear to work, and subsequently aticonfig appears to work. But after installation various sax2 attempts all hang and when I reboot the systems starts ok but X hangs with a blank screen (I am able to go to a command prompt ok).

Unfortunately the Acer has a very restricted bios, there is no option to disable the intel card in the hardware.

Do you have any further suggestions? Do you know any way in SUSE that I can programmatically disable (hide) the Intel?

I understand this was likely painful, but in truth its too general a statement in order to not provide advice that may duplicate what you tried. You really DO have to be more specific. Heck, I can’t even tell if you were using a 32-bit or a 64-bit openSUSE, nor can I tell what desktop (KDE ? Gnome ? LXDE ? Xfce ? ) … it should not matter but …

Also when you tried the radeon/radeonhd driver, what rpms were you using? Did you try the cutting edge driver/rpms from the X11 : Xorg repository? And if you did, what commands did you use to try to configure the /etc/X11/xorg.conf file? What did the file look like ( is a good place to put such a file. Do NOT post it here).

when you tried the proprietary driver, what version did you try? What comamnds did you use to try to configure the /etc/X11/xorg.conf file. What did the file look like ( is a good place to put such a file. Do NOT post it here).

You are correct:
I am using 64bit with KDE4.

(Just tried to register with PasteBin but registration not available now therefore xorg.conf extract at end of message.)

  1. First, I followed the instructions with the proprietary driver, using the automatic option:
    sh ./ati-driver-installer-10-3–
    aticonfig --initial
    reboot, the screen hung so I repeated this time with:
    aticonfig --initial -f.
    screen hung.

  2. Second, I generated a distribution specific package (fglrx64_7_4_0_SUSE112-8.712-1.x86_64.rpm) and installed with rmp Uvh …
    aticonfig --initial -f.
    Screen hung.
    I tried aticonfig --initial --input=/etc/X11/xorg.conf.
    Screen hung.

  3. Found your various (excellent) posts and made sure all the packages were installed from Xorg : x11 repository (as per post #11).
    Screen hung.

  4. Next I found this link and carefully followed the instructions as listed.
    Screen hung.

  5. Various attempts to use sax2 -r -m 0 (or 1) =fglrx (or redeonhd) all failed: ‘(ww) fglrx no matching device section for instance (Bus ID PCI:0@1:0:1) found’.

  6. fglrxinfo produces ‘segmentation fault’.

Is there more I can send you?

xorg extract:
Section “Device”
Identifier “Device[0]”
Driver “intel”
VendorName “Intel”
BoardName “Mobile Intel GM45 Express Chipset”
Option “EXANoComposite”
Option “monitor-LVDS” “Monitor[0]”
BusID “0:2:0”

Section “Device”
Identifier “aticonfig-Device[0]-0”
Driver “fglrx”
BusID “PCI:1:0:0”

Section “Screen”
Identifier “Screen[0]”
Device “Device[0]”
Monitor “Monitor[0]”

??? ehh … no need to register to post on pastebin. ???

Of course that did not work. You forgot to install the rpm fglrx.

Similar problem. You forgot to un-install the fglrx rpm (from before) , before you installed the new rpm.

Sorry, thats too general. What rpms did you install ? What version numbers? Did you do a quality check to ensure you actually did install the rpms? Many users think they installed them and they did not. And finally, after rpms were successfully installed, did you reboot to run level 3 and configure an /etc/X11/xorg.conf file with the appropriate sax2 arguments. My guess is you did not.

… well, … apologies, I’m from Missouri, but all the above approcahes were not accurate, and the approach you quoted requires an edit to a command to work in openSUSE-11.2, so I’m not convinced you were able to implement that edit correctly.

None of those will work if the 1st 4 example you quoted were not followed correctly. As far as I can read, every one of examples 1 to 4 were not followed correctly.

I confess I don’t know where to start. :\ As far as I can read, you were not able to follow the directions in any of the cases above. Hence I’m reluctant to provide any specific recommendations as I am afraid they will not be followed exactly.

Where do we go from here?

Show me huh! - Thanks for the quick response.

Help me understand this:
You say “(1) Of course that did not work. You forgot to install the rpm fglrx.” then you say " (2) You forgot to un-install the fglrx rpm (from before) , before you installed the new rpm."

At no point did I knowingly install fglrx separately. The first installation (1) and the rpm file (2) were both generated using the ati installer script. Are you saying that the fglrx should be installed before using the script? If so where from?

No, I am saying in (1) that the “fglrx” rpm is created by the script. After that it MUST be manually installed by yourself. That instruction is written in every guide that I have seen about using the ATI .run file.

For (2) , in case you already had the “fglrx” rpm installed, then it must be removed before you try to install a new version of the “fglrx” rpm.

You say: " None of those will work if the 1st 4 example you quoted were not followed correctly. As far as I can read, every one of examples 1 to 4 were not followed correctly." It is not clear to me what you base this statement on.

I followed the ATI installation instructions in (1) and (2) very carefully. They did not require installation of fglrx first. If they do - show me where please, and I will start again.

As for the rpms, I did as one of your posts suggested:
zypper install kernel-source kernel-syms linux-kernel-headers gcc make automake
rpm -Uvh fgl*.rpm
aticonfig --initial
type: exit #to get rid of root permission

Unfortunately your interpretation of (1) and (2) seems to have hindered your acceptance that I did indeed follow (4) as required.

I know how easy it is to make mistakes when you are tired so I have attempted to get this working over a period of days, each time returning and following the various guidance as carefully as I can.

It may be that a new code release is required and that no-one can resolve it right now.

Of course I could be wrong. I based my assessment on your description of the activities you performed.

Typically, with a propietary ATI graphic driver, if installing it via what is called “the hardway” (which is not hard), one will first ensure one has the kernel-source and kernel-syms of the EXACT same version as one’s kernel installed, and also have linux-kernel-headers and the openSUSE “base development” pattern installed. Then in run level 3 one will do ALL of the activities from a full screen run level 3 (and not from run level 5).

  • delete any old fglrx rpm that may be installed.
  • then run the ATI*.run file with the appropriate syntax/arguments;
  • then install the new fglrx rpm created by the ATI *.run file;
  • then run the ATI ati-config executeable with the appropriate syntax and arguments to create an xorg.conf file.
  • reboot to test (or run startx as a regular user to test)
    I definitely did NOT get the impression you did that. Just the contrary. I was left with the impression you skipped steps.

Yes, most definitely it has. I don’t see how I can assume anything else.

Good luck with your efforts.

Also, you may try take a look at “man sax2”. Even though depreciated, if I recall correctly, sax2 has arguments that can be run to specifically setup 2 graphic devices on a PC. Also, I do not have 2 graphic devices on any of my PCs, so this sax2 capability is not something I can help you with.


Just to be clear, I worked through exactly the steps that you describe, more than once.

I have come across a reference to agpgart and the question whether config_agp was enabled when the kernel was built. I do not have agpgart loaded (only intel_agp) so will check this out and let you know if it is fruitful.

OK, that was not clear to me.

Did you also look at “man sax2” like I described, and check out its options for multiple sound cards?

Sax2 provides the ‘-c’ option to specify which chip to be used for configuration, which I will try.

I have also loaded agpgart (and will blacklist intel_agp). Will return to laptop and test (from the top) again.


For the record:

Using the -c option in sax2 made no difference and the agp issue seems irrelevant.

Having worked carefully through all the various approaches, each time returning the machine to a clean state, the solution still evades me.

Either I get a blank screen, sax2 returns an error or the Intel card is used. I have not found a non-bios way of disabling or by-passing the on-board Intel card so that sax will use the ATI card.

It seems that I will have to settle with the radeonhd driver for now and hope a new release of a proprietary driver addresses the problem.