TW using only 1 core (1 thread) out of 8


Since yesterday (a couple of days ago), I noticed that the air fans where too active (much more than usual) but I kind ignored thinking it was just for the moment.

But yesterday using btop, htop, KDE’s system monitor, etc, I noticed that only 1 thread of 1 core is active.

The remaining 7 (4 cores total, 2 threads per core), are inactive, they’re ALL recognized with ~lspci~ , lscpu and almost everything I found on the internet is only about the cores not being recognized but in my case they’re being recognized but not used.

So came back to an ubuntu partitions i haven’t used in a while, and there’s no problem there. All cores/threads work as usual.

So I tried restoring one of snapper’s snapshots as I thought something(s) I installed could have caused that (opensnitch, intel_gpu_top, etc), but to my surprise it doesn’t make any difference. In all I’ve tried the problem is still present.

I don’t know what else to do, and the PC is pretty slow with the fans being over-active all the time for very simple tasks.

I’m a new openSUSE user (for about 11 days) and so far I’ve been liking the PROVED-&-TESTED Rolling Distribution model, and I would love to keep using it --kernel 6.1 is excellent!!! , but my days of continuous tinkering are almost completeley gone, for commitment reasons I cannot dedicate much time to make it work. I need it work without much of a fuss and all docs and reference I found about TW seemed to indicate that’s the case.

Please can someone point in the right direction? I would hate to have to reinstall all over again from zero, and even would hate having to use another distribution as theoretically and pragmatically (until now) I’ve loved openSUSE Tumbleweed.

Thanks and hopefully someone can help soon.

PS. I would like to attach the output of lspci and lspcu (or anythng really) but there seems no way to do that here --although I didn’t found anything unusual.

My CPU is a i5-8250U and I don’t have any additional drivers apart from the ones from the installation

I have at six core AMD CPU and to aktivate all cores I need to do that in my BIOS. See if your BIOS has a setting where you can activate all cores that way.

I had a similar problem on an HP desktop, it not only was using only one core, but was extremely slow to boot hanging for a very long time on cpu. I added the option noapic to my bootloader, and it remedied my problem.

splash=silent quiet noapic security=apparmor

You can edit the bootloader in Yast, to see if adding it will make a difference for you.

If there was a bad BIOS setting, his Ubuntu wouldn’t be running on all threads.

What is output from cat /proc/cmdline on a normal boot?

Logs you might wish to attach you should susepaste, then paste here only the resulting URI. e.g. dmesg | susepaste

1 Like

I had the same problem a while ago, but I use a AMD proc
My solution was to check the powersave options
You can set the powersave options with performance / powersave /default/ondemand/schedutil

echo powersave | sudo tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor

There is also an app cpu-powersave-gui in the repos
I do not know if this works with intel.

1 Like

If it is about the powersave options, you can check it through cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor

You may also install cpupower and check the status of your cpu through cpupower --cpu all frequency-info. I realized that something has changed there after an update (probably kernel) some days ago but my amd cpu is working fine right now.


Many Thanks everyone for their input!

I’ve tried each of your recomendations and so far nothing has changed, but haven’t seen anything out of the ordinary in the output of utilities. Maybe is tlp-related thing but now I’m seriously considering reinstalling SUSE.

That’s because I chose what i now consider a mistake when I accepted the suggestion of the installer for encrypting the disk, and now even when using the Ubuntu installation (which is in a different disk), I need to provide the passphrase everytime I need to read from any partitions located in the same disk of SUSE.

That’s quite an inconvenience since I relied on opening files at those partitions automatically at login, so I could start working right away without any manual intervention.

So I think I’ll remove the encryption (using the most recent responses @ linux - How to remove LUKS encryption? - Unix & Linux Stack Exchange) and then reinstall openSUSE again.

Do you suggest a way that I can kind of “CLONE” the openSUSE packages I have installed so far so I can restore the after installation?

I can restore my home folder easily but I would prefer not to reinstall everything else manually but have it automated.

Is there a way to do that with zypper/Yast?

The idea is to be able to replace the old Ubuntu installation (which is in an ssd) with openSUSE but for that I need to make sure everything works mostly fine with opensuse.

Many thanks!

BTW is it possible that the opensuse installer is able to remove the encryption for the disk? or do I need to do it previous to the installation?

You can output a list of installed packages to package.txt by: zypper se -i | grep i+ | awk '{print $3}' > package.txt

Backup the file and reinstall everything by something like: cat package.txt | xargs sudo zypper install

1 Like

I’m unsure what you are asking here.

If your plan is to do a clean install, then just ignore the request for password during install. The install can then reuse the partition and that will wipe out the encryption header.

1 Like

Yeah I’m also unsure I understand your response :sweat_smile:

If I understand you correctly, I don’t need to do any decryption BEFORE starting a new clean install of SUSE, as the installer will simply get rid of the existing encryption?

IoW, from then on, I’m no longer will be asked for the passphrase everytime I Turn-On/Restart the PC, or everytime I mount a partition from that disk?


Yes, that’s right. You won’t be prompted for an encryption key after the reinstall.

1 Like

Your question is very unclear.

Installer will get rid of the encrypted data and you will no longer be able to access it. It will be wiped out. That is rather different from “removing encryption” which is most naturally understood as “replacing encrypted data with its original plain text version” preserving data.

OK now I’m confused/worried.

The disk where SUSE is installed is a 2TB HDD with 3 partitions:

  • sda1=EFI-boot
  • sda2=NTFS. Huge partition with important data to keep.
  • sda3=SUSE

Last time of installation I thought that ONLY sda3 was going to be encrypted, but since every time I start the pc, AND everytime I try to mount sda2 I get asked for the passphrase, I guess the installer encrypted ALL partitions --am I right?

Now I wanna get rid of all the encryption without losing the data @sda2.

Is that possible to do just by reinstalling openSUSE and ignoring every encryption option it provides?

Or do I need something else before AND/OR after the installation to remove the encryption but KEEP the data @sda2?

I hope that clears it!

Thanks for your response!!!

That seems unlikely. Could it just be asking for root password to mount?

As root:


and post the output. That should indicate what is encrypted.


The output of sudo blkid is:

/dev/sda1: UUID=“92B2-C204” BLOCK_SIZE=“512” TYPE=“vfat” PARTLABEL=“boot” PARTUUID=“ed9d152c-3109-43e7-8fbb-5732c22bfbc1”
/dev/sda2: LABEL=“barradata” BLOCK_SIZE=“512” UUID=“3B8D99077E157E78” TYPE=“ntfs” PARTLABEL=“barradata” PARTUUID=“c5f66fc7-d65f-4522-b82f-ebbd076afc9c”
/dev/sda3: UUID=“ba9ef45f-d86b-444b-8ab2-b653f21e5d1a” TYPE=“crypto_LUKS” PARTUUID=“1f33a7ef-12a7-4059-85d0-0df6b062b302”
/dev/sdb1: UUID=“7E1C-4AE6” BLOCK_SIZE=“512” TYPE=“vfat” PARTLABEL=“EFI system partition” PARTUUID=“426c85cb-fe86-4308-bd8a-34a475123622”
/dev/sdb3: BLOCK_SIZE=“512” UUID=“BC8620EF8620ABB8” TYPE=“ntfs” PARTLABEL=“Basic data partition” PARTUUID=“b459cffa-a114-4fe0-9267-a9c4d113ebf1”
/dev/sdb4: UUID=“859c9448-4467-40ad-a3e6-61d11e2a6153” UUID_SUB=“96b8fede-2b10-4228-8922-0a08f6b67bbe” BLOCK_SIZE=“4096” TYPE=“btrfs” PARTLABEL=“linux” PARTUUID=“db95efa1-4822-4a7a-b6f8-54ef4f4ba017”
/dev/sdb2: PARTLABEL=“Microsoft reserved partition” PARTUUID=“d7e9c950-e0bf-4a00-8ca4-d9fd10753646”
/dev/mapper/luks-ba9ef45f-d86b-444b-8ab2-b653f21e5d1a: UUID=“9d79904b-e251-473f-91f3-a3d389d12a97” UUID_SUB=“f97627cc-075b-4286-a0c9-9bd692f53d2c” BLOCK_SIZE=“4096” TYPE=“btrfs”

Not sure how to read this, it mentions 2 luks partitions but it seems both refer to the same physical partition sda3.

Many thanks!

It is not seeing any encryption on your NTFS partition (“/dev/sda2”).

Yes, “/dev/sda3” is LUKS encrypted. And the last entry (the “/dev/mapper/*” entry is what is inside that LUKS partition (after decrypting with the passphrase that you provide).

To get back to your earlier question, a reinstall without encryption should not affect that NTFS partition. Just be sure that, during the install, you do not tell it to format or delete that partition.


Thanks for your assessment. Part of what throws me off is why it asks for the passphrase @ boot time if the efi partition is not encrypted?

It’s like the boot partition @sda1 needs decryption too just to read the grub data, kernel options and the rest of the options just to be able to boot the OS proper.

Once logged in it also asks later for passphrase when trying to mount the Data partition, even when using the Ubuntu install @sdb, which didn’t asked before.

Many thanks!

Thanks for that!

Does that includes packages installed not on the command-line but through Yast?

If negative, do you know how do the same for the packages installed that way?

Many thanks!

That’s because grub needs to load the kernel, the initrd and to read the grub menu. These are normally in your root partition, which is encrypted.

Unfortunately, I cannot tell what you are seeing. However, if that partition were encrypted, it would not be recognized as NTFS. But it is so recognized.