TW does not boot to KDE-Plasma login screen anymore

I have TW running on a Dell laptop - it’s been running fine for months.
The root partition is BTRFS and includes /home (no separate /home partition).

I connect to my local home Wifi network using NetworkManager.

Normally, it boots to the KDE-Plasma GUI login - I log in and then presented with my KDE-Plasma Desktop.

A couple of days ago, I went into Yast GUI, in the Systems section, then clicked on Network Settings. An error was displayed that “networking is configured using NetworkManager, and Yast can’t modify some settings”.

So, I cancelled out and went to do other chores. I did a zypper dup, then rebooted the system and suddenly, the text console is displayed showing a login prompt. It did not boot up to the KDE-Plasma login screen.

So I logged in with my user account and ran “startx” and my KDE-Plasma desktop is displayed as usual and I have no problems using it.

Not sure what happened, though I have an idea … when I clicked on the Yast → Network Settings, some low-level network configuration settings were altered, even though I cancelled out after reading the “Yast can’t make changes” error message.

When I boot up, it’s as though the GUI login screen is going to be displayed, but then it shows the text-mode console screen

It shows a login prompt, then interrupts, showing information about the network connections, like it’s trying to connect to Wifi and ethernet 2 to 3 times, then the final login prompt is displayed.

Here’s the console output … and I also post the results from journalctl --boot -1

Started Avahi mDNSADNS-SD Stack
[ OK ] Started Authorization Manager.
Starting Modem Manager...
Starting Bluetooth service.
Starting Thunderbolt system service..
Starting firewalld - dynamic firewall daemon.
Finished Load extra kernel modules for sound stuff
Started User Login Management
[ OK ] Started Bluetooth service
Started Modem Manager.
Reached target Bluetooth Support.
Reached target Sound Card.

Starting Hostname Service...
[ O ] Started VirtualBox Linux kernel module.
[ O ] Started Thunderbolt system service
Starting vboxautostart-service.service...
Started vboxautostart-service.service.
Started Hostname Service.
Started firewalld - dynamic firewall daemon.

Reached target Preparation for Network.
Starting Network Manager...
Started Network Manager.

Reached target Network
Starting NTP client/server...
Starting CUPS Scheduler...
Starting System Logging Service...
Starting OpenSSH Daemon.
Starting Permit User Sessions...
Finished Permit User Sessions.

Starting Hold until boot process finishes up...

Starting Terminate Plymouth Boot Screen...
Welcome to openSUSE Tumbleweed 20230509 - Kernel 6.3.1-1-default (tty1).

daffy login:
Welcome to openSUSE Tumbleweed 20230509
Kernel 6.3.1-1-default (tty1).
wlo1 : fe80: :60e3:4f94:503a:9dcf

daffy login:
Welcome to openSUSE Tumbleweed 20230509 - Kernel 6.3.1-1-default (tty1).
wlo1: fe80::60e3:494:503a:9dcf

daffy login:
Welcome to openSUSE Tumbleweed 28230509
Kernel 6.3.1-1-default (tty1).
wlo1: 2600:1702:9e0:7499:c5b6:18e0:5a8b:6bad

daffy login:
Welcome to openSUSE Tumb leweed 28230589 - Kernel 6.3.1-1-default (tty1)
wlo1: 2600:1702:9e0:7490::32

daffy login:

Output from journal

how about

sudo systemctl enable sddm

then restart?

thanks … i will try this now …

@ycom1 … thanks for the suggestions, but the outcome is the same.

> sudo systemctl enable sddm
[sudo] password for root:
Created symlink /etc/systemd/display-manager.service /usr/lib/systemd/system/sddm.service.

It boots, then the openSuse GUI screen with spinning circle is shown … then is goes to the console and it shows the “login:” prompt over and over about 3-4-5 times, then it shows the final “login:” prompt and stops.

Notice every time it shows a “login:” prompt, it is interrupted and shows the text
wlol: xxxxxxx

… then the login prompt … each time it shows the “em2 (ethernet) and wlo1 (wifi}”, it shows the progress as it gets the IP address, 2-3 times.

[ 0.0790181[101 ] x86/cpu: SGX disabled by BIOS.
[ 0.9910 T2261 ] bbswitch: No discrete VGA device found

Welcome to opensusE Tumbleweed 20230509 Kerne1 6.3.1-1-default (tty1).


daffy login:
Welcome to opensuse Tumbleveed 20230509 kernel 6.3.1-1-default ttyl.

wlo1: fe80::60e3:4г941503а19dсf

daffy login:
Welcome to opensuse Tumbleweed 20230509 - kernel 6.3.1-1-defau1t (tty13.

wlo1: fe80: :6063:4r94:503a

daffy login:
Welcome to openSuse Tumblweed 20230509 - kernel 6.3.1-1-default (tty1)

wlo1: 2600: 1702:960:7490: 14a6:bdc3:e959:7d1c

daffy login:
Welcome to openSusE Tumbleweed 20230509 - Kernel 6.3.1-1-default tty1)

wlo1: 2600:1702:9e0:7490::32

daffy login:

Post the output from these commands (should match expected output below):

$ systemctl is-enabled display-manager
$ systemctl is-enabled sddm
$ systemctl status
● - Graphical Interface
     Loaded: loaded (/usr/lib/systemd/system/; indirect; preset: disabled)
     Active: active since Wed 2023-05-10 19:15:08 -03; 3h 11min ago
       Docs: man:systemd.special(7)

Warning: some journal files were not opened due to insufficient permissions.
$ systemctl --failed
0 loaded units listed.
1 Like

Thanks for the response @awerlang !! Here it is ( yes, differences):

daffy:~ # systemctl is-enabled display-manager
daffy:~ # systemctl is-enabled sddm
daffy:~ # systemctl status
● - Multi-User System
     Loaded: loaded (/usr/lib/systemd/system/; indirect; preset: disabled)
     Active: active since Wed 2023-05-10 16:51:03 CDT; 3h 51min ago
       Docs: man:systemd.special(7)

May 10 16:51:03 daffy systemd[1]: Reached target Multi-User System.
daffy:~ # systemctl --failed
0 loaded units listed.
daffy:~ # 

Enabling sddm sets display-manager as an alias which in openSUSE is normally a wrapper for specific display managers. Also for some reason multi-user text mode is the default target. Both need to be reverted.

$ sudo systemctl disable sddm
$ sudo systemctl enable display-manager
$ sudo systemctl set-default


1 Like

WOW !! Awesome fix ! Thank you so much @awerlang !!

And I’m confused , because I’ve made NO CHANGE to the display configuration (?)

The only thing I did was to click on Yast → Network Settings … I cancelled out of that because of the error displayed, then minutes later, did a zypper dup and a reboot .
Very strange

daffy:~ # systemctl disable sddm
Removed "/etc/systemd/system/display-manager.service".

daffy:~ # systemctl enable display-manager

daffy:~ # systemctl set-default
Removed "/etc/systemd/system/".
Created symlink /etc/systemd/system/ → /usr/lib/systemd/system/
daffy:~ #

I don’t see a relation to Network Settings. In YaST Services Manager though, there’s an option to set the default target, you might have changed it there by mistake.

1 Like

I think you are correct … I was in there looking at the Service settings.
I thought if you change the System Target type, the list of Services would change.

I must have left it at Multi-User Target and clicked OK button, not knowing what would happen (which did happen). Thanks again ! :+1:


Oh dear, I suspect that, we have an issue with respect to the graphical system administration human-machine interface –

  • Regarding Linux and “systemd”, please note the following non-GUI information:
 # systemctl status 
● - Graphical Interface
     Loaded: loaded (/usr/lib/systemd/system/; indirect; vendor preset: disabled)
     Active: active since Thu 2023-05-11 09:03:55 CEST; 3h 24min ago
       Docs: man:systemd.special(7)

Mai 11 09:03:55 ??? systemd[1]: Reached target Graphical Interface.

And, the following documentation information:
           The default unit systemd starts at bootup. Usually, this should be aliased (symlinked) to
  or See bootup(7) for more discussion.

           The default unit systemd starts at bootup can be overridden with the systemd.unit= kernel command line
           option, or more conveniently, with the short names like single, rescue, 1, 3, 5, ...; see systemd(1).

We may well need a change to the YaST Service settings window in that, it may well be that, some text indicating that, the services listed represent the complete list of all the (system) services available on the machine.

  • Please note that, the «user» services are neither listed in the YaST tool nor, the “systemadm” tool (systemd-ui RPM package) –
    You have to use “systemctl --user «Command»” to inspect and manage the user-specific services.

I’ll consider raising a suitable Bug Report to highlight this issue.

openSUSE Bug Report (Enhancement suggestion) submitted: <>.

Thanks !!
How this happened … I read another thread with user having a similar issue. The openSuse expert suggested to disable two “lvm2-*” Services. Keep in mind, the lvm2 Services suggestion had nothing directly to do with the final fix … but it was suggested to disable those two lvm2 Services because “if you’re not using LVM, might as well disable the service bloat” (my interpretation).

Since I do not use lvm2, I thought, “good idea, I’ll disable it too”. So I started up the Services module in Yast GUI. Then I saw the dropdown for System Target, and thought, “that’s great, you can see the services for each of the different Targets”.

… and you know the rest :slight_smile: I did not know the Target dropdown is a separate setting and the list of Services is not affected.

Thanks for noticing this and for the follow-up !!

Nope, not really – the YaST Module and, the systemd graphical tool, are neither as powerful as the CLI interface – which is why, the man page for “systemctl” is as long as it is … :sunglasses:

1 Like