Tumbleweed's almost twice as high power consumption as Manjaro's

I’ve noticed terrible battery life on Tumbleweed comparing to my previous system. Powertop reports roughly 13 W battery discharge rate without any applications launched. In comparison, on Manjaro with the same setup it was 7 W. The setup is a fresh install of KDE Plasma in X session with auto-cpufreq defaults. It reports temperatures of cores about 40 degrees so just like on Manjaro. Only battery discharge rate is higher.

  Info: 6-core model: AMD Ryzen 5 5600H with Radeon Graphics bits: 64
    type: MT MCP cache: L2: 3 MiB
  Speed (MHz): avg: 1556 min/max: 1200/4280 cores: 1: 1200 2: 3300 3: 1200
    4: 1200 5: 3300 6: 1200 7: 1276 8: 1200 9: 1200 10: 1200 11: 1200 12: 1200

Do you have power-profiles-daemon installed? It improves a lot on my laptop.

auto-cpufreq blocks power-profiles-daemon due to conflicts with its functionality so I removed it and started power-profiles-daemon but it doesn’t seem to make any difference sadly

Even with power saving mode?

Also, try running yast online update to install additional stuff your your amd card.

Welcome aboard the forum !

Did you initially calibrate powertop before a sampling ?

:-# powertop --calibrate

Wait about 15 minutes for it to finish.
Then run it for a sampling.

Here’s mine on a Dell laptop - I ran powertop for about an hour while doing some browsing, editing, watching videos …

PowerTOP 2.15     Overview   Idle stats   Frequency stats...                         
The battery reports a discharge rate of 4.27 W
The energy consumed was 62.7 J
The estimated remaining time is 12 hours, 10 minutes

Unfortunately yes.

Thanks for the suggestion, there was nothing to install. Maybe i should look at Lenovo/AMD forums.

Thanks! Initially, I did not.
I tried now but unfortunately, I do not go below 10 W w/e I do.

Looks like the issue is mainly because of something called “Radio device: ideapad_acpi” which drains half of the energy. I’ll try to find out how it can be fixed but initial search led me here: English Community-Lenovo Community and looks like disabling it might be the only option. What’s weird is that I didn’t even notice this Device existed on Manjaro, so maybe something can be done openSUSE-wise. Idk yet.