Tumbleweed won't boot

I have not used my computer in 2 weeks [been away] I shut it down when I left.
Upon arriving home I started the computer and it did not boot as usual. It takes me into “emergency mode” and asks for root password. When I give the root password I am taken to “localhost:~#”, which I am guessing is a command line program. Doing a bit of googling I found this post
https://forums.opensuse.org/t/welcome-to-emergency-mode/125107
and proceed to try commands suggested.
The “mount” command returned a list of what was mounted. The 1st listed was my root device on dev/sdf2 and my boot/efi on dev/sdf1, and so on … All devices/drives seem to be mounted. My root drive[SSD] is formatted in EXT4. The only thing on this SSD is root and boot/efi.
I also tried the suggestion from nrickert in this post:
https://forums.opensuse.org/t/computer-wont-boot/126354
where he suggests that altering a line in the grub-efi file should get it booting properly. This just took me back into emergency mode after trying to restart. While going through the restart it said "Timed out waiting for device dev/disk/by-uuid DEB2E95FB2E93D21. Is there a command that would give me alternate names of dev/disk to find out if this is the SSD where root resides?

Is the root file corrupted? Will I have to reinstall it or is there another way to get the computer to boot into GUI?

I am writing this from my Win 11 computer.

thank you

Try at root prompt update-bootloader --refresh then powercycle the machine.

Thank you Panorain for your help.
Did as you suggested, but it just took me back into emergency mode.

I believe it will be ok to try to regenerate dracut also but after this I am out of thoughts for you at the moment. I was considering to tell you to try GSmartControl on a live medium but that could create more damage if your disk/drive is failing so I am not able to recommend this right now. I suppose dracut --regenerate-all --force then update-bootloader --refresh powercycle and check. Do you have a backup by any chance? You can try lsblk to list the block devices too.

when doing lsblk I get a listing of all disks and it shows / and boot-efi and that they have the proper sizes, as well as all other disks. Also something else that shows at the beginning is:
e.g.
Name MAJ:MIN RM SIZE RO TYPE MOUNTPOINTS
loop0 7.0 0 55.7M 1 loop /snap/core18/2812

loop24 7:24 0 175.7M 1 loop /snap/spotify/74

and then it lists all my disks
sda
sda1 8:1 0 8.1G 0 part
sda2 8:1 0 8.1G 0 part /home

sdf
sdf1 8.01 0 500MB 0 part boot/efi
sdf2 8:02 0 100G 0 part /

As far as backup - all my most personal and work files are on separate disks including my /home files. If I am losing my SSD disk would that not save them? If I got a LIVE USB could I check and backup and files through that?
I will try the dracut command provided and report back.

Try to make certain to update-bootloader --refresh also after dracut --regenerate-all. Can you try to post the output of lsblk here and possibly even lsblk -f output? Oh I catch myself because you have EXT4 filesystem (btrfs layout is a bit different). Very good that you have a backup of your files as you stated as above. If you give more time a much more experienced users should be around also. It is possible to check BIOS and change /sdf drive to first to boot if you have not done so already.

-Regards

Thank you, panorain.
After doing dracut … and update-bootloader --refresh I still am sent to emergency mode.
I am downloading a LIVE rescue disk from openSuse and will at least try to acess my files.

I downloaded the LIVE openSuse Rescue disk and I am able to access my files. I will google using this disk, but any suggestions would be welcome.

The only reason for the systemd to enter emergency mode is failure to mount filesystem on boot. Post

cat /etc/fstab
lsblk -f -o +partuuid

where /etc/fstab is the file from your root filesystem (adjust the path if you booted live medium).

Thank you, arvidjaar.
the following is the requested output:

linux@localhost:~> cat /run/media/linux/RooT/etc/fstab
UUID=f6904808-22aa-4f19-850d-eed60b50199d  /                    ext4  defaults             0  1
#
UUID=9795d790-682a-483c-b9d5-7e98a881f6b7  /home                xfs   defaults             0  0
UUID=963442ff-647a-4eda-9076-e1749b44e7f9  /home/data003        ext4  data=ordered         0  2
UUID=bfcd2361-f23c-4d3d-ba44-ef97058a0151  /home/data001        ext4  data=ordered         0  2
#
#UUID=DEB2E95FB2E93D21                      /home/WDPassport     ntfs  fmask=133,dmask=022  0  0
UUID=DEB2E95FB2E93D21                      /home/WDPassport     ntfs-3g     defaults,locale=en_US.UTF-8 0 0
#
UUID=ff50b747-b05d-431e-8e04-6f68e7abebdf  /home/VShare         ext4  data=ordered         0  2
#
#UUID=4689BA926EBEEAFA                      /home/Picture2014Up  ntfs  fmask=133,dmask=022  0  0
UUID=4689BA926EBEEAFA                      /home/Picture2014Up  ntfs-3g     defaults,locale=en_US.UTF-8 0 0
#
UUID=4DD1-9A9D                             /boot/efi            vfat  utf8                 0  2

linux@localhost:~> 

linux@localhost:~> lsblk -f -o +partuuid
NAME FSTYPE FSVER LABEL UUID FSAVAIL FSUSE% MOUNTPOINTS PARTUUID
loop0 squashfs 4.0 0 100% /run/overlay/squashfs_container
loop1 ext4 1.0 5ec8c599-4f50-4382-9798-18ca934e0a11 761.4M 72% /run/overlay/rootfsbase
sda
├─sda1 swap 1 SwaP 62e36348-26f5-40b5-adf8-9f6359c1cdf7 6f59c54d-224a-4027-8c9c-aa5f80247598
└─sda2 xfs HomE 9795d790-682a-483c-b9d5-7e98a881f6b7 263.4G 9% /run/media/linux/HomE 2c2c7226-1d79-4665-9e7e-8c99927b5238
sdb
└─sdb1 ext4 1.0 VShare ff50b747-b05d-431e-8e04-6f68e7abebdf 2f973f53-01
sdc
└─sdc1 ntfs Picture2014Up 4689BA926EBEEAFA 0009bbd8-01
sdd
└─sdd1 ext4 1.0 data003 963442ff-647a-4eda-9076-e1749b44e7f9 00056467-01
sde
└─sde1 ext4 1.0 data001 bfcd2361-f23c-4d3d-ba44-ef97058a0151 a2600695-3b92-4735-84d4-8005df10f87c
sdf
├─sdf1 vfat FAT16 efiboot 4DD1-9A9D 08c078f3-1d79-4814-b91b-73cc3b526f17
└─sdf2 ext4 1.0 RooT f6904808-22aa-4f19-850d-eed60b50199d 74G 19% /run/media/linux/RooT ff1a36a4-af70-4c27-842c-3908b27f2e9c
sdg
sdh iso9660 Joliet Extension openSUSE_Tumbleweed_Rescue_CD 2024-01-06-00-23-03-00
├─sdh1 iso9660 Joliet Extension openSUSE_Tumbleweed_Rescue_CD 2024-01-06-00-23-03-00 0 100% /run/overlay/live cd077bbb-01
├─sdh2 vfat FAT16 BOOT C479-BB20 cd077bbb-02
└─sdh3 ext4 1.0 cow b03d28d2-bac0-49d1-b9bc-837717577f10 6.2G 1% /run/overlay/overlayfs cd077bbb-03
sr0
linux@localhost:~>

This UUID does not exist.

Any reason you post half of data with proper formatting and half of data near unreadable?

because I have it plugged into another machine at present. When I could not get this computer booting, i switched it to my laptop. If you need it on this computer I can switch it back and redo cammands requested.

Perhaps because I am not sure how to make it readable? I extended the terminal window as far as it would go, in order to get it to stretch out. Can you please tell me how to format to accomplish a more readable data table? I am guessing it is the lsblk command that looks sloppy.

Thank you.

I do not need it at all. But that is the obvious first reason for your system to enter emergency mode. If you do not need it, then comment it out. And double check that all other devices in /etc/fstab actually exist.

Appreciate your help, arvidjaar.

After commenting out that line in fstab, the computer booted into openSuse just fine.
Question: If I take that line right out of fstab, but still have my external drive plugged in will the external drive act like a removable [USB type] drive? If I am removing the external drive to plug into other computers at times ,what is the best way to set it up?

Can you please tell me how to format to accomplish a more readable output.
Is there a link i can follow to find out how to do this?

There is no one true “best way”. If you are using GUI and its file managers, then simply plugging in USB drive will usually open it in your file manager. No /etc/fstab is needed.

OK thank you, I will try that.

Oh a bad fstab entry that put you in emergency mode, it happen to me once after formatting a usb key on a raspberry pi :slight_smile:

You can add the nofail option in your fstab entry, that way if your external drive is not plugged ( or died ) you will still be able to boot normally but it will result in longer boot time ( see 3.2 external devices : fstab - ArchWiki )

I personally let my desktop environnement handle external drive for me, my encrypted ext4 ssd is perfectly mounted by kde when I plug it.

1 Like