Tumbleweed USB Installation Failure(s)

Yesterday, I tried to install Tumbleweed using the off-line installer on a USB and I simply couldn’t get anywhere with it. I kept getting no more disk space errors, although I have 1.8 TB free space on the computer and the USB had about 28 GB free space. Then, today, I ran across a page and the documentation saying that with a FAT-formatted USB, the full install might throw those disk space errors. It didn’t say what other format I might be able to apply to the USB. I took the alternate route of formatting it again and flashing the network install on it.

This time around, I got to the point in the installation where it starts downloading files from the mirrors. Until it just stopped and started giving me a “Bad media attach point” error. The details show that the installer is jamming on the “Create attach point” part. After searching around, I saw that others have reported similar issues when their /tmp directories had a lot of stuff in them.

I assume the problem is that, when the USB installer is created, it makes all the remaining space disappear. So, the 4+ GB full install made the USB stick look like it was 4 GB in size and full, and the 250 MB network install made it look like the stick was 250 MB in size and full. I don’t understand why I need more room on the USB itself in order to install Tumbleweed on my hard drive, either. So, I’m stuck.

Now what?

(P.S. As an added bonus, when I aborted out of the installer, I got another error but I can only upload one screenshot. The error said:

Internal error. Please report a bug report with logs.
Run save_y2logs to get complete logs.

Caller: /mounts/mp_0001/us/share/YaST2/lib/y2packager/product_spec_readers/full.rb:72:in ’ block in products’

Details: undefined method "split’ for nil

I don’t know how to run save_y2logs, alas.)

How did you create the USB?

If you used the recommended method (“Imagewriter” or “dd”), then that overwrites the USB, so the limits of FAT file systems do not apply.

For “save_y2logs”, you can use CTRL-ALT-F2 to get a command line, and run it there. Then you need to copy the logs to somewhere. Either mount another USB or find a partition on your hard drive that you can mount and copy to there.

1 Like

Others and I have had good luck using a Ventoy USB stick for installations, among other uses. Just copy the NET or DVD .iso onto it as you would copy any ordinary file, boot the Ventoy stick, and select whichever .iso you wish to use to install, maintain, rescue, or live boot from, whatever the .isos you copied to it are capable of. My Ventoy’s main partition is ext2 formatted, currently with 8 .isos on its 26G, with 8G freespace. The stick also has a 34M ESP FAT16 that it initializes from.

@dmvdoug
I simply use:

cp <name-of-iso-file> /dev/sdX

Has been working flawlessly with every version of openSUSE since 12.1

2 Likes

In this case cp wil do the same as dd, a byte for byte copy.

Old hands will prefer dd because they are then 1000% sure is will be a byte for byte copy. Just sentiment. :wink:

3 Likes

I would recommend ventoy to to anybody for usb installation, It supports just about anything you can put on it and you can even put txt,png,or even mp3/4 files and even videogame saves on it (it will take longer to scan though so i would recommend having a separate USB drive for rpms and drivers among other things)

So, using Ventoy got me a little further along in the process. I set it up on the USB stick, copied the ISO to the USB and tried again. I got a couple of write errors as before, but I was able to click next, and the process continued through the installer, until I got to the account creation page. I got stuck on the screen and completely unable to move forward or backwards, or do anything. I ended up hard resetting the computer (power button) after about 30 minutes frozen like this.

The kind of funny part to me (I guess?) is that I’m having these issues with a desktop computer, but when I started a VM with QEMU on my 2020 M1 MacBook Pro, I had no problems getting Ttmbleweed installed in the VM.

(P.S., Sorry for the slow reply. Life issues. I can go into detail more on the various ways I tried to create the USB installer before using Ventoy, but so far Ventoy has gotten me furthest along on the desktop machine.)

Venoty uses exfat for its large partition where you put ISOs, I’ve used it to perform at least 4 TW installations in the last few weeks. All good!

I would recommend doing the following:

  1. After copying the ISO to the USB drive, make sure all the data is flushed to disk by calling sudo sync.
  2. Just to be extra careful, unmount the USB, remount it and do a sha256sum of the ISO file so you know the file is not corrupted.

Sometimes the issue could be as simple as:

  1. Worn down port
  2. Bad USB drive, cable, or enclosure if you’re using one
2 Likes

Could you post the errors on the forum so that we can see them?

if those instructions from @pavinjoseph do not work then I would recommend re-downloading the ISO image

I will definitely do those things. I’m going to stop by the store and pick up a new USB stick too, just to sort of reset everything and try again. I’ll post an update.

Thank you, and everyone!, for all your help.

I didn’t document them, but just skipped ahead as far as I could get. When the install froze, I wasn’t able to do anything at all except reset the computer.

When I get a new USB stick and go through the process again, I’ll document better next time through. Even if “document” means terrible pictures of my screen with my phone. :joy:

INSTALLATION SCREENSHOTS:

You will need to mount a device that will not be written over by the install. So, if you have a data partition, you will use the following to mount it. Or, insert a second USB key formatted to ext4, use it to save your screenshots.

When the YaST graphical installer starts, press Ctrl + Alt + F2 - this will provide you with a root terminal.

Mount the drive or partition (replace the X with the correct device name or path):

mount /dev/sdX /media/

If you do not know the device #, you can find out with:

fdisk -l

Press Ctrl + Alt + F7 to return to the graphical installer.

When you want a screenshot, press PrtSc
A dialogue will appear asking you where to save the screenshot. Save it where you mounted the file system, above: /media/
You will have to do this for each screenshot. They are saved as png files.
When you finish taking all the screenshots, you should unmount the filesystem.
Use Ctrl+ Alt+ F2 to go to the virtual terminal, enter:

umount /media/
1 Like