Tumbleweed update to VirtualBox 7.0.8-5.1 problem

Updated from 7.0.8-4.1 to 7.0.8-5.1 and now VirtualBox VMs will not start.

Was on 7.0.8-4.1 here:

# 2023-06-04 22:32:45 virtualbox-7.0.8-4.1.x86_64.rpm installed ok
# Additional rpm output:
# /usr/lib/virtualbox/VBoxNetNAT: setting to root:vboxusers 4750 (wrong permissions 0755)
# /usr/lib/virtualbox/VBoxNetDHCP: setting to root:vboxusers 4750 (wrong permissions 0755)
# /usr/lib/virtualbox/VBoxNetAdpCtl: setting to root:vboxusers 4750 (wrong permissions 0755)
# /usr/lib/virtualbox/VBoxHeadless: setting to root:vboxusers 4750 (wrong permissions 0755)
# 
2023-06-04 22:32:45|install|virtualbox|7.0.8-4.1|x86_64||download.opensuse.org-oss_1|c392f03925a133f414f1b4aed5a0b89531c2b585d990a79e0e8a1dffe6471
b29fb74c9751de498239699924fd2fa27c2a2d611d17e20c9c8408441ae55fcf5ef|

Updated to 7.0.8-5.1 here:

# 2023-07-03 14:27:21 virtualbox-7.0.8-5.1.x86_64.rpm installed ok
# Additional rpm output:
# /usr/lib/virtualbox/VBoxNetNAT: setting to root:vboxusers 4750 (wrong permissions 0755)
# /usr/lib/virtualbox/VBoxNetDHCP: setting to root:vboxusers 4750 (wrong permissions 0755)
# /usr/lib/virtualbox/VBoxNetAdpCtl: setting to root:vboxusers 4750 (wrong permissions 0755)
# /usr/lib/virtualbox/VBoxHeadless: setting to root:vboxusers 4750 (wrong permissions 0755)
# 
2023-07-03 14:27:21|install|virtualbox|7.0.8-5.1|x86_64||download.opensuse.org-oss_1|0e9a2f58677ac7dcc68d735a623c093993bf567076a6318b84f7c2a90f3d8d96911c97a3180fe625a7266de2a79d92c779755b59134fd540c531e69f2259c650|

I had two VMs defined, one Windows, on Linux (Tumbleweed).

The Windows10 VM tries to start. Pops up a “starting” progress box with a bar that goes to “20%” then wedges there and goes no further. I left it long enough to do the grocery shopping, just to be sure.

The Tumbleweed VM seems like it tries to start, but doing so hangs the host OS, which then eventually reboots.

I tried making a new Tumbleweed VM with the network install ISO. It does the same as the Win10 VM. Progress box, 20%, goes no further.

Thinking that this is a bad update. Would like to go back to the working 7.0.8-4.1 but that’s not in the Tumbleweed repos anymore of course. Would be equally happy with a working 7.0.8-5.1 or whatever, just so it works again.

Adding some more information.

I upgraded a second (physical) machine to 7.0.8 and it seems to be working fine. The difference is that I haven’t upgraded the VBox extensions pack on that one.

I downgraded the extensions pack on this one to 7.0.4, now all three VMs do the 20% progress bar and stop thing.

So, maybe VBox 7.0.8 itself is ok? Not sure. Take care if you’re upgrading.

I have VirtualBox running on Tumbleweed - I have guest additions 7.0.8 for all guests except windows 11 - stay with 6.1.40 or 6.1.42 as 7.0.X will lock up after a while.

Virtualbox guests can hang booting in nat mode if the network adapter name in VirtualBox is not the same as the Host has named it. for example - VirtualBox is eth0 and host is em1 or e0p12 or any other network name.

I suggest that you uninstall and reinstall VirtualBox rebooting after each step.

Step 1
sudo zypper rm virtualbox virtualbox-kmp-default
sudo reboot

Step 2
sudo zypper in virtualbox virtualbox-kmp-default
sudo reboot

Step 2

as user start VirtualBox
then each guest.
nothing else is needed unless you have local networking and you need the VirtualBox Extension Pack

Thanks, larryr. I haven’t gotten to the guest additions yet, no idea what version they are. Probably still something in the 6.x line, I don’t recall having updated them in a while.

Interesting that the guest can hang while booting with NAT. That seems to describe what I’m seeing here. I have three interfaces defined:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 48:9e:bd:d8:1d:a7 brd ff:ff:ff:ff:ff:ff
3: wlp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 5c:61:99:5a:6b:63 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.24/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp1s0
       valid_lft 86259sec preferred_lft 86259sec

wlp1s0 (WiFi) is the one in use, but that had been working ok previously. I don’t see where VirtualBox has the network name defined, just “NAT” in the GUI interface. In the .vbox file, I see:

        <Network>
          <Adapter slot="0" enabled="true" MACAddress="080027AD13A8" type="82540EM">
            <NAT localhost-reachable="true"/>
          </Adapter>
        </Network>

I removed and reinstalled VirtualBox as suggested, that did not help. With the Extension Pack installed, starting the VM hangs the host OS. After several minutes, the host OS reboots. Without the Extension Pack, the guest OS hangs at “Starting”.

Weird - my NAT stuff looks like this - mine has the eth0:

<Network>
    <Adapter slot="0" enabled="true" MACAddress="0800276F0995" promiscuousModePolicy="AllowAll" type="82540EM">
      <DisabledModes>
        <BridgedInterface name="eth0"/>
        <InternalNetwork name="intnet"/>
        <NATNetwork name="NatNetwork"/>
      </DisabledModes>
      <NAT localhost-reachable="true"/>
    </Adapter>
    <Adapter slot="1" MACAddress="0800271492C5">
      <DisabledModes>
        <NAT localhost-reachable="true"/>
      </DisabledModes>
    </Adapter>
    <Adapter slot="2" MACAddress="0800274AB62D">
      <DisabledModes>
        <NAT localhost-reachable="true"/>
      </DisabledModes>
    </Adapter>
    <Adapter slot="3" MACAddress="08002745B73E">
      <DisabledModes>
        <NAT localhost-reachable="true"/>
      </DisabledModes>
    </Adapter>
    <Adapter slot="4" MACAddress="08002724D3C0">
      <DisabledModes>
        <NAT localhost-reachable="true"/>
      </DisabledModes>
    </Adapter>
    <Adapter slot="5" MACAddress="080027D9EA58">
      <DisabledModes>
        <NAT localhost-reachable="true"/>
      </DisabledModes>
    </Adapter>
    <Adapter slot="6" MACAddress="08002774798D">
      <DisabledModes>
        <NAT localhost-reachable="true"/>
      </DisabledModes>
    </Adapter>
    <Adapter slot="7" MACAddress="080027B4271E">
      <DisabledModes>
        <NAT localhost-reachable="true"/>
      </DisabledModes>
    </Adapter>
  </Network>

Weird indeed. I wonder if “DisabledModes” is important, or being “disabled”, it can be ignored?

The .vbox file says “do not edit”, but I’m tempted to try adding to it, to see what happens.

Any other ideas?

Here’s a bare new .vbox, just created. Hasn’t even been able to boot yet to install the OS or anything like that.

<?xml version="1.0"?>
<!--
** DO NOT EDIT THIS FILE.
** If you make changes to this file while any VirtualBox related application
** is running, your changes will be overwritten later, without taking effect.
** Use VBoxManage or the VirtualBox Manager GUI to make changes.
-->
<VirtualBox xmlns="http://www.virtualbox.org/" version="1.19-linux">
  <Machine uuid="{00b72002-7fbc-4c27-a6d7-86c3bdeca4e1}" name="OpenSUSE Test" OSType="OpenSUSE_64" snapshotFolder="Snapshots" lastStateChange="2023-07-04T14:30:00Z" aborted="true">
    <MediaRegistry>
      <HardDisks>
        <HardDisk uuid="{22fd7d41-4415-44fc-bcfa-732be80f4d7e}" location="OpenSUSE Test.vdi" format="VDI" type="Normal"/>
      </HardDisks>
      <DVDImages>
        <Image uuid="{6d228098-6f75-45db-aae9-959911da5f2b}" location="/home/dgersic/Downloads/openSUSE-Tumbleweed-NET-x86_64-Snapshot20230701-Media.iso"/>
      </DVDImages>
    </MediaRegistry>
    <ExtraData>
      <ExtraDataItem name="GUI/LastNormalWindowPosition" value="640,274,640,531"/>
    </ExtraData>
    <Hardware>
      <CPU>
        <PAE enabled="false"/>
        <LongMode enabled="true"/>
        <X2APIC enabled="true"/>
        <HardwareVirtExLargePages enabled="true"/>
      </CPU>
      <Memory RAMSize="8092"/>
      <HID Pointing="USBTablet"/>
      <Display controller="VMSVGA" VRAMSize="16"/>
      <BIOS>
        <IOAPIC enabled="true"/>
        <SmbiosUuidLittleEndian enabled="true"/>
      </BIOS>
      <USB>
        <Controllers>
          <Controller name="OHCI" type="OHCI"/>
          <Controller name="EHCI" type="EHCI"/>
        </Controllers>
      </USB>
      <Network>
        <Adapter slot="0" enabled="true" MACAddress="08002757450C" type="82540EM">
          <NAT/>
        </Adapter>
      </Network>
      <AudioAdapter codec="AD1980" useDefault="true" driver="Pulse" enabled="true" enabledOut="true"/>
      <RTC localOrUTC="UTC"/>
      <Clipboard/>
      <GuestProperties>
        <GuestProperty name="/VirtualBox/HostInfo/GUI/LanguageID" value="en_US" timestamp="1688480940985381000" flags=""/>
      </GuestProperties>
      <StorageControllers>
        <StorageController name="IDE" type="PIIX4" PortCount="2" useHostIOCache="true" Bootable="true">
          <AttachedDevice passthrough="false" type="DVD" hotpluggable="false" port="1" device="0">
            <Image uuid="{6d228098-6f75-45db-aae9-959911da5f2b}"/>
          </AttachedDevice>
        </StorageController>
        <StorageController name="SATA" type="AHCI" PortCount="1" useHostIOCache="false" Bootable="true" IDE0MasterEmulationPort="0" IDE0SlaveEmulationPort="1" IDE1MasterEmulationPort="2" IDE1SlaveEmulationPort="3">
          <AttachedDevice type="HardDisk" hotpluggable="false" port="0" device="0">
            <Image uuid="{22fd7d41-4415-44fc-bcfa-732be80f4d7e}"/>
          </AttachedDevice>
        </StorageController>
      </StorageControllers>
    </Hardware>
  </Machine>
</VirtualBox>

The section is interesting, showing only in it.

Selecting the “not attached” from the pulldown in the GUI adds this:

      <Network>
        <Adapter slot="0" MACAddress="08002757450C" type="82540EM">
          <DisabledModes>
            <NAT localhost-reachable="true"/>
            <InternalNetwork name="intnet"/>
            <NATNetwork name="NatNetwork"/>
          </DisabledModes>
        </Adapter>
      </Network>

to the .vbox file. So I guess that’s where that comes from.

Deselecting “attached” on network, so should have no network attached to the VM at all, and it still wedges the VM on startup at “20%” started.

safe it edit if all virtualbox is stopped - no running anything

The Problem is ibt. You must start tumbleweed with a kernelparameter ibt=off.

Ah, thank you hsmoerder. That was indeed the problem. Works now.

Related threads with more information:
https://forums.virtualbox.org/viewtopic.php?t=108948
https://forums.virtualbox.org/viewtopic.php?t=109587