Tumbleweed installation stops/halts at driver initialization (12%)

My Hardware is exactly: https://www.computeruniverse.net/en/medion-erazer-x7855-md60839-439-cm-173-notebook-schwarz (couldn’t find a better site)
As there is no CD drive on my notebook i boot it over a usb-drive (64gb/3.0).
Tried the Universal USB-Installer (UUI) first with no sucess, then used Rufus which did work. (Simple ISO copy not the DD variant./did, not change the result, normal ISO variant just works fine)
Downloaded my ISO here: https://download.opensuse.org/tumbleweed/iso/ (openSUSE-Tumbleweed-DVD-x86_64-Snapshot20190704-Media.iso)
Tried other distros before like the gnome-live-CD from OpenSuse, but that only boots up to the bootable menu, whatever i selected it froze my notebook entirely.

Rigth now i have Windows 10 and Linux Xubuntu installed, latter one doesn’t seem to like me either.
For home i use a second 27 inches monitor, but as soon as i go in the settings to activate the monitor (display) it freezes the OS.
Just in case, my monitor, connected via hdmi: https://www.samsung.com/uk/monitors/led-sf350/LS27F350FHUXEN/
I did not use Linux for some time, but i have some good experience with OpenSuse and i would prefer it, i already have a +/- 40gb ext4 partition on my SSD as well as 2 gb swap space.
I will simply overwrite Xubuntu if i finally get OpenSuse to work.

My knowledge of Linux is higher than most average users, but i’m far from an expert, my best guess is, that some drivers are missing and/or my devices hardware isn’t fully supported?
Like i wrote, this isn’t my first failure rigth now, i remember it being way easier to set up most linux distros.
Basic UEFI (i will still call it bios), nothing special USB 3.0 Stick in USB 3.1 connection on PC, that also worked for me before just fine, don’t think there’s a problem.
It also is booting and loading up normal, it appear to be frozen and just suddenly stops at about 12%. It does not crash, it stays there until i reset it.
It’s not like my hardware is high-end or outdated and because of that not implemented.
I really have no clue.
It feels a bit like Linux doesn’t like my notebook.

https://www.idealo.de/preisvergleich/OffersOfProduct/5897442_-erazer-x7855-md-60845-medion.html (edit: It’s the MD60845, not the MD60839, my notebook does have an i7, not an i5)
As it looks like that i’m unable to edit the post, i decided to reply here.

It is probably the Nvidia graphics that is causing your problems.

On the boot menu line, hit ‘e’. (I am assuming the EFI boot menu).

That should give an edit window. Scroll down until you find a line that begins “linux” (or “linuxefi”).
Hit END to get to the end of the line. Append " nomodeset" (without the quotes).
Hit CTRL-X to resume booting.

That will probably get the installer to run properly, though with poor graphics. You can install Nvidia drivers later to fix the graphics.

This did solve my problem, thank you.
The installation did run extremely fast, about half an hour for a full dvd, i’m really surprised.
Greeting from OpenSuse

I’m glad you have things working. And thanks for reporting back.