Tumbleweed Installation fail

I’m trying to install the openSUSE from the Tumbleweed-NET disk. Next, Idescribe my actions in the most detail.

1. In theboot menu select the item "Installation".
2.In the terminal we observe the load. Then a pseudographics appears.
3.It is suggested to enter ESSID (Network Name).
4.Enter "D-link_DSL-2760U".
5.The "WLAN Authentication."
6.Choose "WPA-PSK".
7.Enter the WPA Key.
8.Enter ... (Password)
9.Please make sure your installation medium is available. Choose theURL to retry. "Http://download.opensuse.org/tumbleweed/repo/oss".
10.The message "Sending DHCP request to wlp2s0 ..."
11.A second later on a red background: "DHCP configuration failed."
12.Then return to 9 points.

Sorry for my badenglish.

Try a wired connection rather then WiFi. Some WiFi cards require special drivers.

Your steps look okay. It’s hard to debug the problem from here.

I suggest that you try the live media from HERE. Pick either KDE or Gnome, based on your own preference.

The difference is that with live media you can setup your WiFi connection before you even start the install. And it uses NetworkManager for the network, which is different from the command line tools used with the NET installer.

Click on “Install” after you have the network running.

I’ve tried two options for connecting to a network: a wired connection Ethernet and a nonwired connection Wi-Fi. The result was the same.

Like others said, download a live image, boot from it with a wired connection. That way we could find out what the Wifi card is and what is needed to get it working. But wired should work. The live image also allows you to install to hard disk.

The NET installer uses the same method for both kinds of network. That is to say, it uses “wicked”.

For me, “wicked” is unable to acquire a DHCP address (bug 1080832). There’s a workaround that I have in place (see the discussion of that bug). But the workaround doesn’t help while installing.

However, “NetworkManager” has no problem acquiring a DHCP address. If you use the live media, you will be using “NetworkManager” for connecting during the install.

I do not know whether that is your problem. But it is at least worth trying the live media. And note that install using the live media is really the NET install, apart from the difference in setting up the initial network connection.

I should mention another option. You can manually assign an IP address to your system. That’s actually what I used when installing Leap 15.0. But you would need to know something about networking for this. In addition to manually assigning an IP address (from the range of your home LAN), you would need to configure a gateway (usually your home router) and a DNS server (usually your home router). And you might need to configure a subnet mask (probably would work).

I cite a screenshot taken at a time when the installation was interrupted.
Pay attention to the line
"no/incomplete answer.".
It seems that the installer has incorrectly set the interval for waiting for a response from the router.
In just one second he decides that there is no answer.
In fact, to establish communication with my router, it takes 6-8 seconds.

Try Live KDE or Gnome at the bottom of this list https://download.opensuse.org/tumbleweed/iso/

It’s not that I can not install the opensuse on my laptop. I somehow get out and find a workaround option. The fact is that there is a bug in the distribution Tumbleweed-NET and this bug must be eliminated. If I knew English better, I would write in openSUSE bugzilla.

I’m not seeing any indication of that.

In just one second he decides that there is no answer.

It seems more likely that it received an answer which did not include an IP address.

In fact, to establish communication with my router, it takes 6-8 seconds.

That’s likely the time for several steps, of which the IP address is only one.

Here’s a link for that bug report that I previously mentioned:

Bug 1080832

There’s a change in the way “wicked” is handling DHCP requests. My router does not support the newer way, and it seems likely that your router also does not support it.

The bug report gives a way to revert to the older method, but that’s unlikely to work with the NET installer.

My workaround for intalling was to manually assign an IP address (with a wired connection). I had to also manually set a subnet mask, a route and a DNS server. After intall, I used the workaround in the bug report, so that everything now works normally.

Once again, I suggest you try one of the live media, and install from there. Live media are using a different method to setup the network, and are not affected by this particular problem.

Last time I showed you the console ALT-F3, now I’ll show you the console ALT-F4.


Can you explain the meaning of the line to me?

**“tg3 0000:07:00.0 enp7s0: Board does not support EEE!”

**The search in google did not work.

As best I can tell (from the results of Google search), “EEE” here stands for “Energy Efficient Ethernet”.

I would think that’s a message that you can safely ignore.

Last time I tried to connect to the Internet via a wireless access point. The laptop could not connect to the access point. I continued my experiments. Now I tried to go online through a wired connection. Connection to the Internet occurred, but the system still could not boot. I show you the console ALT-F3.


Can you explain to me why the installer does not find the files it needs in the repository?

404 Not Found ???

I can only guess.

It looks as if your access to the Internet is being restricted. I might expect something like this to happen if I am going through a captive portal such I encounter at hotels.

It’s also possible that the download site (or the mirror to which you were redirected) was undergoing maintenance at the time you connected.

“It looks as if your access to the Internet is being restricted.”

I’m not seeing any indication of that.” !!!

Assuming that you’re using typical home equipment,
You should have DHCP running on both your wired and wireless networks.

Connecting with a wired connection should “just work” and avoids problems associated with wireless.
Remember, you have to turn off your wireless or your machine may still attempt to use the wireless and you’ll continue to see the same error.

To test whether you’re connecting properly,
I recommend you download a LiveCD image as others have suggested, although you might or might not be able to install from it, at least you’ll be able to figure out how set up a wired connection properly.

  1. Download and create a bootable LiveCD for LEAP 15. Select any one from the following page

  2. With your LiveCD created (on CD, DVD or USB),

  • Disable your wireless, preferably by hardware switch, key, or key combination… Whatever is required for your machine.
  • Connect your patch cable from your machine to the switch, hub or router.
  • Boot your LiveCD
  1. From within your LiveCD,
    Run the following and include in a post to this Forum
    If you don’t have a network connection, take a picture of your screen displaying the result with your mobile phone and post that.
ip addr

Once you are able to set up a wired connection with your LiveCD,
You can then try installing again.


I connected to the same openSUSE repository, to which the installer Tumbleweed-NET is connected. See the screenshot:


If the installer does not find, for example, an “autoinst.xml” file, then from the screenshot, I see that there is really does not exist “autoinst.xml” file in the repository. This indicates the apparent inconsistency of those developers who make the distribution Tumbleweed-NET and those developers who accompany the openSUSE repository.

I’ll tell you more.
Two weeks ago I downloaded the image Tumbleweed-NET and tried to install the system on a PC with a wired connection to the Internet.
At that time, all the files needed to download the PC on the site were present and the PC was booted up to the point where it was already possible to start the installation.
So the repository Tumbleweed-NET was broken approximately 4-5 days ago.