TUMBLEWEED install on Dell XPS 15 9570


Just wondering if there is anyone here who has installed TUMBLEWEED on a Dell XPS 15 9570. I was running Debian distribution successfully previously. It does basically work but I am having a couple of problems

  1. The wireless device does not seem to be getting configured/started correctly - I see it via ip -a link and it’s status is DOWN.
  2. I want to modify the display resolution, the default is pretty high and hard to read, any pointers on how I should go about fixing that would great!


If you can open a terminal session and switch to root user and tail the journal, then in another terminal see if think can be brought up;

terminal 1:

journalctl -f

terminal 2:

ip link set wlan0 up
ip addr

Also check your wifi password :wink:

The problems you mention, wireless not working and changing the display resolution is something that can be fixed (also very likely for Debian)

You might be lucky that switching to Tumbleweed WiFi works out of the box, although I still think you need to use Network Manager to connect to the AP.

You can easily change the display resolution through Settings → System Settings → Display and Monitor, although you might want to stick with the default resolution of the monitor (1920x1080) en increase the font sizes (Appearance → Fonts)

Last remark: Just try to run Tumbleweed as Live image for the USB stick, that way you can test without installing. The Live image can be booted using the normal image you an get via https://get.opensuse.org/tumbleweed#download

Most Dell laptops I have seen require firmware for wireless. Could well be that Debian is simply not distributing that. Just try an Opensuse live cd/stick.

While desktop widget scaling or font sizing seems to be the preferred way of making small screens readable, I found that the results are medocre at best. For me, tinkering with xorg screen size, ie the millimeters instead of dpi, yields much nicer screens. My current Thinkbook 13s has hardware dpi 167 which I tuned down to 144 by overriding the detected screen size with my own. May not work as well for real hdpi screen in the 200+ dpi range.


So I decided to start again and copied down the dvd image and burned that onto my usb stick.
This time I went with the KDE desktop variant. This are better but still having issues.

@malcolmlewis - I tried your suggestions, but on doing so I don’t see the device (wlan0) some how the installation did not create that I do see the physical device wlp59s0. It shows up via ‘ip a’ as

2: wlp59s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
link/ether 46:… brd ff:ff:ff:ff:ff:ff permaddr 9c:…

I tried using this device name but that did not do anything. So I guess that I need to have that wlan0 device/alias(?) created.

@marel - Yea, after I used the KDE distribution I could use the Display management utility, which I did not see under the basic installation, and that helped!

@markdd - I think you have a point there, during installation even though the system recognized my Qualcomm device, I was not allowed to select the ath10k
firmware packages? But why do I see the wlp59s0 in that state if the firmware is not there?

On the live, you should be able to install kernel-firmware-atheros.

Wow - I deleted all current configs, switched over to NetworkManager and all is working now!