Tumbleweed Boot Error (Dependency Failed for Swap)

Hello everyone!

please I need help ������


Thank you

There is dev id mismatch from the grub boot file. How do I fix this problem?


You will need to be able to access the system to get information. You can do that by booting to a live CD (or live USB) from just about any linux. Or use the Tumbleweed live rescue CD. Alternatively, you can boot into your install media in rescue mode. Fixing the problem will also require access and chroot access. So the Tumbleweed live rescue or the install media in rescue mode are best for that.

Grub seems to take your swap to be “/dev/sda1”.

What is the output from

grep swap /etc/fstab

and what is the output from


(maybe from “blkid /dev/sda1” could be sufficient if that is the correct swap device).

I later realized that my reply may have been too brief if you are relatively inexperienced.

So let’s try again.

I am assuming, based on your output, that your root partition is “/dev/sda2” and your swap partition is “/dev/sda1”.

From your rescue boot, login as root (usually doesn’t require a password, though that depends on which media you are using).


fsck /dev/sda2
mount /dev/sda2 /mnt
grep swap /mnt/etc/fstab
blkid /dev/sda1

and post the output.

I’m mainly looking for the output from the last two commands. You can skip the output from the others if that makes it easier.

I can make a guess as to what happened. Possibly you reformatted the swap partition. That could happen in several ways, but the most likely would be that you tried installing some other distro in a spare partition, and that install reformatted the swap partition. And that would change the UUID of that swap partition.

While you are logged into the rescue boot, here’s something that you could try. You could attempt to edit “/mnt/etc/fstab”. I would normally use “vi” for that, but if you are not familiar with “vi”, then see if “nano” is available in that rescue setup. It should be very easy to use “nano”.

While editing, find the line for swap. And insert the “#” character at the beginning. That comments out the line. And then see if maybe your system will boot without swap. If you can boot that way, it will be easier to fix things from a more familiar environment.

To exit the rescue session, use either

shutdown -r now

to reboot, or

shutdown -h now

to halt the system.

I run the commands you described, however “grew swap /etc/fstab” returns no output


blkid output

blkid /dev/sda1

fsck /dev/sda2


grep swap /mnt/etc/fstab


Also, “/mnt/etc/fstab” returns permission denied

Your output does not show any obvious problems. The UUID of swap seems to match what you are using.

Try this:

During boot, hit the ‘e’ key. (I think you have experience with that).
On the grub2 edit screen, scroll down to the line that begins with “linux” (following some spaces).
Scroll over to the “splash=silent”. And use your delete key or backspace key, as needed, to delete “splash=silent”. Maybe also delete “quiet”. Then continue booting with CTRL-x.

You should see a noisy boot screen. Then see if there are other messages with more details of what is going wrong. Or take a picture of the lines leading up to the failure.

After editing the grub2 from boot menu, A blurry (Noisy)boot screen appears:


then the system stuck here



I suggest that you file a bug report. You can use this link:
openSUSE:Submitting bug reports

In your report, I suggest you provide a link to this forum thread.