tsmuxer startup issue

I have installed

libtsmux0 | package | 0.3.0-2.7   | x86_64 | packman          
tsmuxer   | package | 2.6.11-11.1 | x86_64 | (System Packages)

txmuxer should be an update for Leap 42.2 x86_64 and the package is installed from this OBS url

Trying to start the “TsMuxerGUI” application from Gnome, nothing happends.

Has someone been able to get it to start - possibly suggestions how to troubleshoot and solve this?
As far as I’ve checked via YaST2, no missing dependices is reported.

Terje J. H

In general the starting point in diagnosing “not starting” GUI programs is to start them from a terminal emulator to see if there are any messages.

Yes, your right. I didn’t recall I did try this aslo some weeks ago, and didn’t come furhter then. Here it goes again;

rpm -ql tsmuxer
- lists the help file similar like a man page; here is the beginning:

Network Optix tsMuxeR.  Version 2.6.11. www.networkoptix.com

tsMuxeR is  simple  program to  mux video to  TS/M2TS files or create BD disks.
tsMuxeR does not use external filters (codecs).

    tsMuxeR <media file name>
    tsMuxeR <meta file name> <out file/dir name>
/usr/bin/tsMuxerGUI: error while loading shared libraries: libQtGui.so.4: cannot open shared object file: No such file or directory

I think here is something. I have libQt5Gui5 and libqt4-x11 among several libqt packages installed, but zypper cannot find any ‘libQtGui’ elsewhere either:

zypper se libQtGUI
Loading repository data...
Reading installed packages...
No matching items found.

Does ‘libQtGUI’ exist for Leap somewhere, or is it discontinued and possibly replaced by another package?

By the way, the important missing thing here seems to be to have a symlink ‘libQtGui.so.4’ (?)


I forgot to ask, but as with every Multimedia problem: did you do the Vendor switch to Packman? And when yes, because you seem to have installed some extra packages, maybe repeating it is not a bad idea (and it never hurts).

libQtGui.so.4 is in the package libqt4-x11.

But, tsmuxerGUI is a (closed source) 32bit binary:

file tsMuxerGUI
tsMuxerGUI: ELF 32-bit LSB executable, Intel 80386, version 1 (GNU/Linux), statically linked, stripped

Even the 64bit package contains that 32bit binary.

So you actually need libqt4-x11-32bit. And maybe some other 32bit libraries as well, haven’t tried.

PS: I did just try it.
Installing libqt4-x11-32bit is indeed enough (it does pull in 40 other packages though) and makes tsmuxerGUI run.

Thank you very much, that worked for me too :slight_smile:
I was somewhat fooled because the installed “tsmuxer” was a 64-bit package, while its GUI part included obviously is 32-bit.

This also recalled me about using

zypper se --provides libQtGui.so.4
Loading repository data...
Reading installed packages...

S | Name             | Summary                    | Type   
i | libqt4-x11       | Qt 4 GUI related libraries | package
i | libqt4-x11-32bit | Qt 4 GUI related libraries | package

Istalling libqt4-x11-32bit pulled in “only” 8 new 32-bit packages on my system.