Trying to understand proxy server settings in 12.3

Hi there,

I’m trying to understand how the proxy server settings work in OpenSUSE 12.3. I’m using KDE as my desktop environment. I’ve been using SLES 11 SP2 and Ubuntu 12.04.2 thus far, they both work as I would expect I guess you could say – that is, you configure the proxy server settings in 1 place and everything on the system immediately honors the setting.

OpenSUSE with KDE seems to be different in this regard, but maybe I’m just missing something simple.

If I configure the proxy server settings in YaST, I can only access the internet via the command line (zypper, etc) – but not with anything else.
If I configure the proxy server settings in KDE + Yast, KDE apps and the command line access the internet – but not with FireFox.
If I configure the proxy server settings in KDE + Yast + Firefox itself, then all 3 can access the internet.

I’ve not tried any GTK apps, but I will need to use them in addition to the above (Pidgin, etc). So that’s probably a 4th place I’ll have to configure the proxy server settings.

Is there a way to centrally configure the proxy server settings so that the entire system honors the setting, like in SLES and Ubuntu? Having to change it in 3-4 different places is a no-go for me because my Linux desktops are all laptops and I’m on and off different networks, VPNs, etc daily. Hopefully I’m missing something simple, as I would like to migrate to 12.3 KDE but can’t (er, won’t) until this issue is figured out.

I personally haven’t had to set a proxy in a while but I did some tests. Within KDE you can set the proxy in the Configure Desktop (cli: systemsettings) program. Select Proxy and select the “Use system proxy configuration” option. Within Firefox, select Edit > Preferences > Network > Settings then select “Use system proxy settings”. Just to be sure that everything took system wide, you may want to log out and log back in to ensure that the network settings take hold.

Good luck!


That’s what I tried, but it doesn’t seem to work that way. I still have to set everything individually…