trying to set up virtual box

I installed virtual box. The first time I ran it I had an error saying I had to become a member of vboxusers. I tried to add this group in yast under users and group management and received this error " There is a conflict between the entered
group name and an existing group name.
Try another one."
Do I need vboxusers or can I name it something else?

I’m not sure what you did there.

It sounds as if you tried to create a new group, when what was needed was to just add that group to an existing user.

You can look at “/etc/group” to see which groups already exist. I think Yast will normally only show the non-system groups.

Maybe try:

grep vbox /etc/group

to see if you already have that group. And, if you do, just add that group to the user with Yast (append “,vboxusers”) to the line for that user.

ok thanks. I found that under my existing user name, checked the vboxusers and it’s working. I was trying to create a new group on the next tab in yast. Kind of confusing.

Now I’m getting this error
Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver is either not loaded or not set up correctly. Please try setting it up again by executing


as root.

If your system has EFI Secure Boot enabled you may also need to sign the kernel modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) before you can load them. Please see your Linux system’s documentation for more information.

I have an AMD chip and it does have secure boot enabled.

This is what I did to fix it as root or add sudo to each line:

cd /etc/uefi/certs/
mokutil --import BDD31A9E-kmp.crt --root-pw
mokutil --list-new

reboot and accept the digital signature screen (you have to enter the root password) and agree to all the prompts.

if you do not get the screen - something went wrong.

Please post:

zypper se -si kernel virtualbox signkey-cert
zypper lr -d

I just disabled secure boot and it started working.