trying to set up ldap

i am trying to set up ldap on opensuse 11.3 and the closest i get with yast is this error

/usr/sbin/slapadd: symbol lookup error: /usr/sbin/slapadd: undefined symbol: ber_sockbuf_io_udp

i also have tried to uninstall openldap and install it manually and set it up manually but even then when i go to add my first user it will ask for a password which i input the default password “secret” according to slapd.conf anyway it tells me i have invalid credentials.

at this point i try my root password which gives me the same invalid credentials error. Would anyoen be able to point out the issue or lead me to a guide to get it running on opensuse 11.3?

i am pretty sure beteween reinstalls i deleted everything ldap database and everything before i started to get it back on any advice would be appreciated

What is the output of:

ldd /usr/sbin/slapadd
ldd /usr/sbin/slapadd =>  (0x00007fffdadff000) => /usr/local/lib/ (0x00007fe4377e7000) => /usr/local/lib/ (0x00007fe4375d8000) => /usr/lib64/ (0x00007fe4373ce000) => /usr/lib64/ (0x00007fe437097000) => /usr/lib64/ (0x00007fe436e7d000) => /usr/lib64/ (0x00007fe436c62000) => /lib64/ (0x00007fe4368b3000) => /lib64/ (0x00007fe436678000) => /lib64/ (0x00007fe43646d000) => /lib64/ (0x00007fe436250000) => /lib64/ (0x00007fe435ef0000) => /lib64/ (0x00007fe435cd9000) => /lib64/ (0x00007fe435a7d000) => /lib64/ (0x00007fe435879000) => /lib64/ (0x00007fe435663000)
    /lib64/ (0x00007fe437a36000)

on a side note this time around i am installing openldap via yast and i noticed that the directory /usr/local/etc/openldap back when i did this manually isnt there anymore where would the slapd.conf file be when i install via yast?

Edit: nvm realized i figured out how to find it

should i post my slapd.conf file?

and i try to start slapd manually with


and i also get the same error as i do with yast

/usr/lib/openldap/slapd: symbol lookup error: /usr/lib/openldap/slapd: undefined symbol: ber_sockbuf_io_udp

oh and just in case you ask

ldd /usr/lib/openldap/slapd

yields =>  (0x00007fffb87e8000) => /usr/local/lib/ (0x00007f4494e5b000) => /usr/local/lib/ (0x00007f4494c4c000) => /usr/lib64/ (0x00007f4494a42000) => /usr/lib64/ (0x00007f449470b000) => /usr/lib64/ (0x00007f44944f1000) => /usr/lib64/ (0x00007f44942d6000) => /lib64/ (0x00007f4493f27000) => /lib64/ (0x00007f4493cec000) => /lib64/ (0x00007f4493ae1000) => /lib64/ (0x00007f44938c4000) => /lib64/ (0x00007f4493564000) => /lib64/ (0x00007f449334d000) => /lib64/ (0x00007f44930f1000) => /lib64/ (0x00007f4492eed000) => /lib64/ (0x00007f4492cd7000)
    /lib64/ (0x00007f44950aa000)

aha! i dont know how i missed this thread in my search before i started this thread but i fixed it. Turns out to be the same issue this guy had on this thread

ldap-server start error