Trying to get a USB kiosk

I’ve been trying for a while to get an 8GB usb stick configured with a bootable version of openSUSE. Without any real luck.

We are running the 64 bit 11.0 on the server and I’ve tried various versions of the kiwi build process, without much luck. I’ve tried building against different versions of Suse and both 32 and 64 bit version.

I’ve tried copying 11.2 to a usb stick - I was able to get that to boot, but it was read only, then when I tried adding an additional partition, it wouldn’t work.

I’ve tried installing 11.2 to a USB drive and I then had a problem with GRUB.

I’ve also tried thependrive linux link - that worked (with 11.2) up until I applied the script in the last step.

Has anyone successfully done something like this? Which approach did you take? I want to be able to plug the usb stick in to a PC, boot it, and have the desktop automatically login with a couple of applications on the desktop.


Get an account on SUSE Studio and build it
from that, you can then use dd to create the image on a USB device.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 1 day 14:25, 2 users, load average: 0.11, 0.11, 0.05
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18