Trying record audio with headset but only get noise

I’ve HP Probook 640 G1 laptop with a dock. I’ve 9mm lineout from dock to either speakers or headset’s earphone jack.
Headset’s microphone jack is connected to dock’s line in. Output plays without problems from either one. If I
try to record audio to Audacity (playback and recording device set to Pulse). Headset is Creative Fatality,
it’s mic on/off -switch is set on and volume slider to max.

My packages are up to date. On Windows with same machine microphone is working. I don’t have other external headset
or microphone to test. I’ve run the configuration to cards in Yast->Sound. I’ve tried a lot of different Pavucontrol
-combinations and change volumes with alsamixer but no success. All tips are welcome.

$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 1: PCH [HDA Intel PCH], device 0: 92HD91BXX Analog [92HD91BXX Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

$ cat /proc/asound/cards 
 0 [HDMI           ]: HDA-Intel - HDA Intel HDMI
                      HDA Intel HDMI at 0xd0730000 irq 30
 1 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xd0734000 irq 31

ALSA information.

Configuration: Built-in audio for HDMI -card if turned off another built-in card is set: Stereo Duplex.
Input Devices: Port of ‘Built-in Audio Analog Stereo’ is ‘Line in (plugged in)’
Recording: For audacity ‘Built-in Audio Analog stereo’ is selected. Blue bar is jumping due noise.
Doesn’t react if I speak to microphone.

I’havent got all the recommended packages on my system (since I don’t need most of them). From multimedia
guide I’ve all but ‘vlc vlc-codecs libxine2 libxine2-codecs’. There’s some multimedia packages I have.

A sentence got cut tried to say: If I try to record audio with Audacity (playback and recording device set to Pulse) and listen the record, only background noise can be heard.

by 9mm lineout I ment 3,5mm. And in addition, if I speak very loudly to mic, I can hear it very faintly when listening the record.

More info: headset’s headphones are recording the audio, not microphone. So if I talk to headphones, sound is ok. Jacks are connected to right ports in dock. I got another headset to test with same results. Pavucontrol’s Input devices tab’s port has options: “Line in (plugged in), Microphone (unplugged), Internal microphone”.

Docking station is probably confusing input lines

I would like to help, but I am confused as to the symptoms you report.

Are you trying to record with a built in mike that comes as part of the headphones?

or are you trying to record with a built in mike in the HP Probook 640 G1 laptop ?

Could you also run a diagnostic script to provide more detailed information ? ie. with mixer and pavucontrol setup for proper recording with the desired mic, open a konsole/xterm and with PC connected to the Internet , as a regular user, copy and past the following into the konsole/xterm:


select the SHARE/UPLOAD option when prompted, and let the script run to completion. After it completes look in the konsole/xterm and it will provide you with a link where the diagnostic information was uploaded. Please paste that link here. That will help us propose either further tests or a solution, once you also clarify what mic you are attempting to use.

I confess I don’t fully understand the symptoms you report. Are you saying you can not record with the mic that is built in with the headset ? Nor can record with any integrated mic that is part of the laptop ? But for some reason the small headphone speakers record sound ?

I also note in your mixer:

**Simple mixer control 'Mic Mute-LED Mode',0**
  Capabilities: enum
  Items: 'On' 'Off' 'Follow Capture' 'Follow Mute'
  Item0: 'Follow Mute'
**Simple mixer control 'Internal Mic Boost',0**
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]

Is “Follow Mute” the correct setting? I don’t know myself. I am just asking.

Further is 0% boost for Front left and right correct for the Internal Mic Boost? Again, I don’t know myself, I am just asking.

I also note:


**** List of CAPTURE Hardware Devices ****
**card 1**: PCH [HDA Intel PCH], device 0: 92HD91BXX Analog [92HD91BXX Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

which is also what you reported.

By default, applications will go to card 0 for recording. So the applications need to be pointed to card-1 for recording, as card-0 (as setup on your PC) does not record.

One can also switch the sound device card-0 and card-1, to over come any limitation there (if that is the problem - it may not be).

Swapping sound devices sounds worth trying. Don’t yet know how to do it.

I cannot record with headset’s microphone and hear audio from it’s headphones. If I plug headsets microphone plug to line-in and headphone plug to line-out, audio works, but headset’s mic doesn’t record. Headphones then both playback audio and record it (yes, I have to speak to headphones, surprisingly adequate quality :)). If I swap the plugs (microphone to line-out, headphones to line-in), recording with headset’s microphone works fine, but audio only comes out of laptops own speakers.

I don’t use laptop’s own internal microphone, so that doesn’t matter. I can disable ‘follow mute’ and ‘mic mute-led mode’, but that doesn’t change the problem.

Ok I think I solved this. Problem lies in the line-in socket. Seems it doesn’t work with a microphone plug. My laptop or dock doesn’t have an microphone socket so it seems I can’t use this kind of headset with this computer but need an usb- or bluetooth microphone instead.

I suppose you could also try hdajacksensetest (this will need be installed) and hdajackretask (this may also need to be installed) to see if you can play with your jack assignments.

I’ve never done that myself - and I have only read of others doing this.

[QUOTE = Cerule; 2889839] Tamam, sanırım bunu çözdüm. Sorun giriş soketinde yatıyor. Görünüşe göre mikrofon fişi ile çalışmıyor. Taklit bilgisayarımda veya yuvamda mikrofon soketi yok, bu bilgisayarla bu tür bir kulaklığı kullanamıyorum, ancak bunun yerine bir usb veya bluetooth mikrofona ihtiyacım var. / QUOTE]

Ben de aynı sorunu yaşadım, çözdüm.

Thank you very helpful.](

Thank you very helpful. I solved my problem too

I also faced the same problem.](