Trust HD Webcam support

Hi all

I have a Trust HD webcam which is causing me a headache. Its vendor id is 0x145F and its product id is 0x01A1. The Trust id number is 18163. The video works absolutely fine in HD, but I can’t get the microphone to work. It is recognised by the sound system - the mixer has an entry for it, and Audacity recognises it too, but it will not produce any input sound.

Does anyone know of how to get this working? (It works OK in Windows).

I have even downloaded the very latest kernel but it just refuses to work. Perhaps it needs a special driver, but I have been unable to find any Linux support at all. Trust has also discontinued this product. Any help welcome!

I am using Opensuse 13.2, and the latest kernel I downloaded was from

Before diving any further into this: your openSUSE ( that’s how it’s writen ) is very outdated, and no longer maintained.
My advice: download a Tumbleweed or Leap 15 live image, write that to a USB stick, boot from it and see if it works.

Furthermore, we need to know which desktop environment is being used.

If you still can, install pavucontrol and check that the proper input level etc are OK.

I would like to see if I can help.

Could you, with webcam plugged in and mixer setup recording an audio (where you note mic not working) run in a konsole/xterm as a regular user (with PC connected to the internet) this diagnostic script:


select the ‘UPLOAD/SHARE’ option when prompted, and let the script run to completion. When it has completed look in the konsole/xterm and it will tell you where the diagnostic information it obtained has been uploaded to an alsa temporary storage site. Please post the web-address/URL of where that script was uploaded.

Our sound experts can then look at that script content, and we may find a misconfiguration - and then may have some suggestions to get this working for you.

Firstly it’s taken me several months to get around to this so apologies for the long delay…here is the web address of the uploaded file from running the alsa-info script.

I don’t know if you can help from this info but I would appreciate any assistance you can offer.


With regard to upgrading my system, I have a perfectly working system now and do not want to upgrade just for the sake of it. If it turns out that in order to get the webcam working, an upgrade is required then I’ll consider it. But in the meantime if your alsa experts can offer help, then great.

Apologies - I’ve been away from the forum for a while.

OK, for your USB webcam mic, I note this in ‘arecord’ from the diagnostic script


**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 2: ALC887-VD Alt Analog [ALC887-VD Alt Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
**card 1:** **Webcam [Trust HD Webcam]**, **device 0:** **USB Audio [USB Audio]**
  Subdevices: 1/1
  Subdevice #0: subdevice #0

We can see there that your USB microphone is hw:1,0 *

So lets see with a konsole/xterm if we can get it to record …

open up a konsole/xterm and copy/paste this command into it.

arecord -vv -f S16_LE -c2 -D hw:1,0 soundtest.wav

Then talk such that your webcam mic should pick this up. After about 20-seconds, press simultaneous to abort the recording.

Then play the file ‘soundtest.wav’ with an audio player. Some as simple as:

aplay soundtest.wav

Does that work ? If not, try unmuting the ‘auto gain control’ switching ‘Playback’ to “ON” (although frankly I don’t think that is an issue here).

Simple mixer control 'Auto Gain Control',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback **[off]**

Let us know how this works out.*

Thanks for your swift response. Here is the latest.

When I ran the arecord command, there was no sound recorded - the level meter stayed at 0%.

However I then ran pavucontrol and selected Input devices and looked at the levels on the webcam microphone.

The levels on both channels were set at 100% but there was no output registered on the meter. I moved the slider to just below 100% and the meter started working. After that no what (positive) level I selected, there was output on the meter - all well and good.

I quit pavucontrol and reran the arecord command which then successfully recorded sound from the webcam microphone.

I rebooted and tried again - no sound until I once again went into pavucontrol and changed the level setting - even just slightly and then the meter would work again - microphone registering sound.

I have Linux Mint 19 installed too and tried with this system - it worked fine without any intermediate steps.

So it seems that something in Opensuse 13.2 is by default after boot/reboot preventing the microphone level from being correctly initialised until I intervene with pavucontrol, and I only have to touch the level slider and move it by the smallest amount for the microphone input to be registered by the sound system.
I have a working solution which is great, but it would be good to understand why!!
Thanks for your help.

I think it is because you are comparing the latest Linux Mint 19 to an old not supported version of openSUSE. Note that

  • Linux Mint 19 - alsa 1.1.3, kernel-4.15
  • OpenSUSE-13.2 - alsa 1.0.28, kernel 3.16.6

If you wish a more exact comparison of Linux Mint to openSUSE-13.2, try installing an old not supported Linux Mint 14 and see how the sound functionality works with your hardware in that Linux Mint version.

Alternatively, install openSUSE-LEAP-15 (which I note still has an older kernel-4.12.14) and has alsa-lib 1.1.5 and see how that functions in comparison to Linux Mint 19…

My suspicion is you will continue in many areas find where a newer version of Linux Mint will function where an old not supported version of openSUSE will not function. I believe that should pretty much go without saying.

I am glad to read that you now have a work around.