Trouble adding flatpack repo

Hi there,

I’ve just now installed Leap 15.2 RC.

Trying to get flatpak to work, I run into some issues.
Flatpak seems already installed by default:

'flatpak' is already installed.No update candidate for 'flatpak-1.6.3-lp152.2.1.x86_64'. The highest available version is already installed.
Resolving package dependencies...


Nothing to do.

but when trying to add flatpak repo as suggested on flatpak’s website, I get the following error:

flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
error: While opening repository /var/lib/flatpak/repo: opendir(objects): No such file or directory

Is this a know bug in Leap 15.2 RC?

Thank you.

Hello,

I see you have real problems in using Flatpak.

What I did is trying to find out what Flatpak is. I am still not sure I understand it. It seems to be something like a software distribution package, but I do still not understand what it’s place is in the openSUSE world.

Also, from the lack of reactions on your threads, I come to the conclusion that not many openSUSE users (that are also members on these forums) use it. The fact that probably not many people here use it is of course a bad starting point for getting help. So please understand that may be the reason you do not get the respons you hoped for.

Maybe an explanation where you need Flatpak for might lead to people pointing you to an alternative solution.

Does

mkdir -p /var/lib/flatpak/repo/objects

help? If yes, open bug report on openSUSE bugzilla.

Being widely used nowadays and taking into account that flatpak is already part of Leap 15.1, I think it’s quite vital for it to be working.


$ var/lib/flatpak/repo> ls
objects tmp
$ flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
error: While opening repository /var/lib/flatpak/repo: openat(config): No such file or directory

Seems like there is an issue with permissions.

I found a solution here

sudo rm -r /var/lib/flatpak/repo

You are right. When it is part of the distribution, you may expect it to be working. And of course you may ask for help here. The only thing is that when only few people here use it, answers may not come in abundance. But see, wait a bit and people seem to have seen bug reports and the like. And the bug reports even contain by-pass solutions.

Hope it works for you.

As mentioned in https://forums.opensuse.org/showthread.php/540296-Flathub-Won-t-Install, there is a bug report about this problem:
https://bugzilla.opensuse.org/show_bug.cgi?id=1172316