Tried to configure sound after installation, now i have sound but 7.1 card is listed as 4 devices

i have a weird audio problem, i recently installed opensuse on my pc and had not audio.
I looked into phonon and found all of my audio cards listed but i in the configuration tab none of them played the test sound.
So i went to: YAST -> HARDWARE -> Audio: all of my cards where listed here too, but the test sound from this menu/option played fine!

Then i maybe made some strange mistakes, i will give you a brief list of the thinks i had done:

  • in Yast/Hardware/Audio i selected my on board soundcard as default and enabled pulseaudio support
  • i installed pavucontrol via yast because i read that this could help
  • this resulted in changing my audio symbol in the task bar to a blank page symbol
  • i removed pavucontrol, because phonon did not showed my sound cards anymore
  • i rebooted my pc

Now i have sound, but i think i messed something else up, because phonon lists each channel of my cards as single device now (see in the attached figure)!](

And in the second tab of phonon (the configuration tab) i was able to at least set a profile for each card (this did not helped at all btw) but not 3 of my 4 cards are listed, the default is not listed anymore.
Yes i have sound now, but it is all messed up, what can i do?

btw: My 4 sound devices are:

  • Creative X-Fi integrated 71. sound card (this is my main card)
  • Asus Xonar D1 (5.1 or 7.1 PCIe card, iam not sure, i do not need it at the moment)
  • NVIDIA gtx 580 has an integrated sound chip for HDMI
  • USB wireless sterio headset

this morning i restarted my PC and in phonon everything was normla again:

  • my 7.1 device was listed as only one device (i chosed the 7.1 profile)
  • the NVIDIA hdmi device was listed as only one device too (there where 3 hdmi devices listed yesterday)

but i have no sound anymore.
At least the 7.1 device plays a sound when playing the testsound frpm YAST but not the testsound from phonon, the hdmi device plays no testsound at all.

Have you tried disabling Pulseaudio completely?

As root:
setup-pulseaudio --disable

Then reboot and check the Multimedia panel in KDE and look at the devices (you may have a lot of them now but don’t worry about it)

The sound seemd to work even without disabling pusleaudio completely. I do not know why.
Phonon lists each device only once now but none of them can play testsound (at least my default device plays test sound via yast) why is that so?

Does the Test Sound actually give an error?

Have you opened KMix to see if any of the devices actually play anything (it’ll show up as activity in the device clearly) or are they perhaps muted or have low PCM volume?

May we know which version of openSUSE?

KMix does not show anything when playing test sounds from phonon, even when playing the test sound for the default device which i can actually hear, nothing happens in KMix.
No device is muted either.
I use openSUSE 13.1

Nothing happens in kmix it is a mixer so you should not see any changes it allows you to make adjustments to volume

So not sure what you expect to see.

Reinstall pavucontrol or veromix and they are very useful in adjusting the pulse sound system Both allow adjustments to individual applications as well as selecting input/output devices

I have known a reboot to be needed to kick the sound system in. Also changing the order of devices in yast has worked here at times.

Playback Streams under KDE Mixer actually shows you the list of applications that are playing audio.

But I agree, veromix would show him the results pretty nicely too - it’s not available in the basic repos though, you’ll need to get it from;

Ha! never expanded the kmixer window and did not know about those tabs. Interesting. In any case I no longer really use it any more just use veromix since it gives pin point control.

Ok problem solved, i reinstalled pavucontrol and did a reboot.
I do not know why but know most of my problems are gone, all devices can play a test sound from phonon the top device is used by all of the programs (browser, vlc …) and even VLC plays sound now when using the pulseaudio output.