traditional (ifup) and networkmanager problems using KDE 11.4

thank you in advance for any assistance.

I have just installed 11.4 KDE (having used 11.3 for a while).

I was able to use YAST in 11.3 to switch from network manager, to using ‘traditional’, to connect to wireless network without problems.

Since installing (fresh install) 11.4, only network manager seems to work without issue; using traditional never sets up the wireless connection - or should i say appears not to as no apps will connect (as they do fine using the network manager connection).

using ‘ifstatus wlan0’ , seems to suggest there is no configuration file when using the ‘traditional’ gui.

Has any one had similar problems; any suggestions please?

(PS: I am not very linux literate yet, so please use simple clear terms, thank you)

further to my original above:

I have used ‘ifconfig -a’ and that confirms that the wlan0 ‘device’ is up and running so to speak, with assigned address etc

If i use ‘ping’ on an internal address (192.167…) then ping delivers its output. If i ping external (e.g. ‘www.somesite.com’) then the message ‘connect: no network connection’ is shown.

None of the apps that use the internet can get out either, but internally - it seems ok. I have checked the suse firewall and that isnt showing anything obvious and in anycase, when the connection is managed through ‘network manager’, it all works as i said earlier.

Please paste the contents of /etc/resolv.conf file when using ifup.
Also compare the output of this command when using ifup and NetworkManager :

/usr/sbin/iwconfig

Best regards,
Greg

thank you kindly for replying and assisting.
below are the outputs produced.

the iwconfig do not look much different; the resolv.conf file for ifup (see below) was different when using network manager - the difference being the line ‘search site’ just above ‘nameserver’ line.

thank you

iwconfig - network manager

wlan0 IEEE 802.11bg ESSID:“BBBWireless2”
Mode:Managed Frequency:2.437 GHz Access Point: 00:14:6C:67:24:28
Bit Rate=48 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thr off Fragment thr off
Power Management off
Link Quality=48/70 Signal level=-62 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:30 Missed beacon:0

iwconfig ifup

wlan0 IEEE 802.11bg ESSID:“BBBWireless2”
Mode:Managed Frequency:2.437 GHz Access Point: 00:14:6C:67:24:28
Bit Rate=12 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thr off Fragment thr off
Power Management off
Link Quality=52/70 Signal level=-58 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:37 Missed beacon:0

/etc/resolv.conf for ifup

/etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:

NETCONFIG_DNS_STATIC_SEARCHLIST

NETCONFIG_DNS_STATIC_SERVERS

NETCONFIG_DNS_FORWARDER

or disable DNS configuration updates via netconfig by setting:

NETCONFIG_DNS_POLICY=’’

See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

Please remove (at least) this line when you modify the file!

nameserver 192.168.0.1

Can You ping the nameserver address ? Can You ping 8.8.8.8 public ip address ? If yes than add a nameserver line pointing to 8.8.8.8 and it might help :slight_smile:

Best regards,
Greg

i’ll give it a go and post back.

in my initial post i did mention that under ifup, that i could not ping any external address, only internal.

I will try the 8.8.8.8 address and see what happens.

thank you

hello again

no joy - as i said i cannot ping anything external, only internal.

its weird - everything works with ‘network manager’, but not with ‘ifup’. and it was all ok in version 11.3.

is this a bug do you think with 11.4?

thank you

On 03/13/2011 03:36 PM, badbetty wrote:
>
> hello again
>
> no joy - as i said i cannot ping anything external, only internal.
>
> its weird - everything works with ‘network manager’, but not with
> ‘ifup’. and it was all ok in version 11.3.
>
>
> is this a bug do you think with 11.4?

No. It is a configuration problem. Please post the output of


/sbin/route -n
can /etc/resolv.conf

Well the funny thing is I’ve got a similar problem. My wireless works flawlessly when using NetworkManager but when I switch to ifup I get something like 30% packet loss so I’ll be looking at your advice here with great interest. There are no differences in /etc/resolv.conf or my routing table when using ifup or NetworkManager and I can ping the internet with both. The funny thing is that iwconfig when using ifup shows speed up to 150Mb/s (just like on Windows and I guess it’s the max for my hardware 1969:1063 ) and using NetworkManager it never exeedes 54Mb/s and works much faster because there is no packet loss :slight_smile:

Best regards,
Greg

On 03/13/2011 05:06 PM, glistwan wrote:

> Well the funny thing is I’ve got a similar problem. My wireless works
> flawlessly when using NetworkManager but when I switch to ifup I get
> something like 30% packet loss so I’ll be looking at your advice here
> with great interest. There are no differences in /etc/resolv.conf or my
> routing table when using ifup or NetworkManager and I can ping the
> internet with both. The funny thing is that iwconfig when using ifup
> shows speed up to 150Mb/s (just like on Windows and I guess it’s the max
> for my hardware 1969:1063 ) and using NetworkManager it never exeedes
> 54Mb/s and works much faster because there is no packet loss :slight_smile:

Routing and DNS resolution mostly affect the making of a connection.

In this case, the wireless driver is failing with the 802.11n rates. In
addition, I suspect it is not reporting its failure rates correctly. If you are
using a standard driver, then report the problem in bugzilla.kernel.org, or the
mailing list on linux-wireless@vger.kernel.org.

Yes I’m using the ath9k driver that comes with the standard openSUSE 11.4 kernel.

Thanks for the link. I’ll be sure to report the problem.

Best regards,
Greg

hello, thank you for joining in on this - appreciated.

and yes there are some differences, probably as you suspected. i wonder why this is as there was not a problem in 11.3.
and why it is seemingly not configuring it properly
and what the solution may be

i took an assumption that ‘can /etc/resolv.conf’ was supposed to be ‘cat /etc/resolv.conf’ and posted is the output below for ifup and nm modes:

thank you again for your time to assist.

re: ifup

cat /etc/resolv.conf

/etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:

NETCONFIG_DNS_STATIC_SEARCHLIST

NETCONFIG_DNS_STATIC_SERVERS

NETCONFIG_DNS_FORWARDER

or disable DNS configuration updates via netconfig by setting:

NETCONFIG_DNS_POLICY=’’

See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

Please remove (at least) this line when you modify the file!

nameserver 192.168.0.1

route -n

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 wlan0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo

re: nm

cat /etc/resolv.conf

/etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:

NETCONFIG_DNS_STATIC_SEARCHLIST

NETCONFIG_DNS_STATIC_SERVERS

NETCONFIG_DNS_FORWARDER

or disable DNS configuration updates via netconfig by setting:

NETCONFIG_DNS_POLICY=’’

See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

Please remove (at least) this line when you modify the file!

search site
nameserver 192.168.0.1

route -n

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 2 0 0 wlan0
0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 wlan0

You’re assumption was right on the spot.

This is the problem. You don’t have a default gateway and thus You can’t go outside your local subnet which is 192.168.0.0/24. You should get the default gateway from DHCP and You don’t get it because of some configuration problem. Please post the output of this command here :

sudo cat /etc/sysconfig/network/ifcfg-wlan0

and

sudo ls -la /etc/sysconfig/network/

Be careful because the file ifcfg-wlan0 might store your wireless password in clear text. Be sure to not post it here :slight_smile:

Best regards,
Greg

On 03/14/2011 02:06 PM, badbetty wrote:
>
> hello, thank you for joining in on this - appreciated.
>
> and yes there are some differences, probably as you suspected. i
> wonder why this is as there was not a problem in 11.3.
> and why it is seemingly not configuring it properly
> and what the solution may be
>
> i took an assumption that ‘can /etc/resolv.conf’ was supposed to be
> ‘cat /etc/resolv.conf’ and posted is the output below for ifup and nm
> modes:
>
>
> thank you again for your time to assist.
>
>
> re: ifup
>

> route -n
>
> Kernel IP routing table
> Destination Gateway Genmask Flags Metric Ref Use
> Iface
> 192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0
> wlan0
> 169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0
> wlan0
> 127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0
> lo
>

There is no default gateway here, and wlan0 has been assigned the Windows-stupid
zero-configuration address. You have a problem in
/etc/sysconfig/network/ifcfg-wlan0. Either use the man pages for ifcfg or YaST
to make that correct.

> route -n
>
> Kernel IP routing table
> Destination Gateway Genmask Flags Metric Ref Use
> Iface
> 192.168.0.0 0.0.0.0 255.255.255.0 U 2 0 0
> wlan0
> 0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0
> wlan0

This is what it should look like.

me again

response to glistwan: here are the outputs for both nm and ifup

response to lwfinger, how do i change setting using YAST - i have had a look into sysconfig editor but i cannot see any options for entering addresses etc.
i will check out ifcfg in the mean time

i still wonder whats gone wrong/changed from 11.3 to 11.4 for it not to be doing this as it did before. however, at least I’m learning a bit more.

thanks again to both of you

re: ifup

ls -la

total 96
drwxr-xr-x 6 root root 4096 Mar 13 11:30 .
drwxr-xr-x 5 root root 4096 Mar 13 11:21 …
-rw-r–r-- 1 root root 12798 Mar 14 21:45 config
-rw-r–r-- 1 root root 9956 Mar 14 21:45 dhcp
-rw-r–r-- 1 root root 60 Mar 1 13:42 ifcfg-eth0
-rw------- 1 root root 172 Feb 18 21:24 ifcfg-lo
-rw-r–r-- 1 root root 28066 Feb 18 21:24 ifcfg.template
-rw------- 1 root root 818 Mar 13 20:16 ifcfg-wlan0
drwxr-xr-x 2 root root 4096 Mar 2 11:54 if-down.d
-rw-r–r-- 1 root root 239 Feb 18 21:24 ifroute-lo
drwxr-xr-x 2 root root 4096 Mar 2 11:54 if-up.d
drwx------ 2 root root 4096 Feb 18 21:35 providers
drwxr-xr-x 2 root root 4096 Mar 2 11:54 scripts

cat

BOOTPROTO=‘dhcp’
BROADCAST=’’
ETHTOOL_OPTIONS=’’
IPADDR=’’
MTU=’’
NAME=‘RT2561/RT61 802.11g PCI’
NETMASK=’’
NETWORK=’’
REMOTE_IPADDR=’’
STARTMODE=‘auto’
USERCONTROL=‘no’
WIRELESS_AP=’’
WIRELESS_AP_SCANMODE=‘1’
WIRELESS_AUTH_MODE=‘open’
WIRELESS_BITRATE=‘auto’
WIRELESS_CA_CERT=’’
WIRELESS_CHANNEL=’’
WIRELESS_CLIENT_CERT=’’
WIRELESS_CLIENT_KEY=’’
WIRELESS_CLIENT_KEY_PASSWORD=’’
WIRELESS_DEFAULT_KEY=‘0’
WIRELESS_EAP_AUTH=’’
WIRELESS_EAP_MODE=’’
WIRELESS_ESSID=‘3xxxxxxx2’
WIRELESS_FREQUENCY=’’
WIRELESS_KEY=’’
WIRELESS_KEY_0=‘3xxxxxxxx3’
WIRELESS_KEY_1=’’
WIRELESS_KEY_2=’’
WIRELESS_KEY_3=’’
WIRELESS_KEY_LENGTH=‘64’
WIRELESS_MODE=‘Managed’
WIRELESS_NICK=’’
WIRELESS_NWID=’’
WIRELESS_PEAP_VERSION=’’
WIRELESS_POWER=‘yes’
WIRELESS_WPA_ANONID=’’
WIRELESS_WPA_IDENTITY=’’
WIRELESS_WPA_PASSWORD=’’
WIRELESS_WPA_PSK=’’

re: nm

cat

BOOTPROTO=‘dhcp’
BROADCAST=’’
ETHTOOL_OPTIONS=’’
IPADDR=’’
MTU=’’
NAME=‘RT2561/RT61 802.11g PCI’
NETMASK=’’
NETWORK=’’
REMOTE_IPADDR=’’
STARTMODE=‘auto’
USERCONTROL=‘no’
WIRELESS_AP=’’
WIRELESS_AP_SCANMODE=‘1’
WIRELESS_AUTH_MODE=‘open’
WIRELESS_BITRATE=‘auto’
WIRELESS_CA_CERT=’’
WIRELESS_CHANNEL=’’
WIRELESS_CLIENT_CERT=’’
WIRELESS_CLIENT_KEY=’’
WIRELESS_CLIENT_KEY_PASSWORD=’’
WIRELESS_DEFAULT_KEY=‘0’
WIRELESS_EAP_AUTH=’’
WIRELESS_EAP_MODE=’’
WIRELESS_ESSID=‘3xxxxxxxxxx2’
WIRELESS_FREQUENCY=’’
WIRELESS_KEY=’’
WIRELESS_KEY_0=‘3xxxxxxxx3’
WIRELESS_KEY_1=’’
WIRELESS_KEY_2=’’
WIRELESS_KEY_3=’’
WIRELESS_KEY_LENGTH=‘64’
WIRELESS_MODE=‘Managed’
WIRELESS_NICK=’’
WIRELESS_NWID=’’
WIRELESS_PEAP_VERSION=’’
WIRELESS_POWER=‘yes’
WIRELESS_WPA_ANONID=’’
WIRELESS_WPA_IDENTITY=’’
WIRELESS_WPA_PASSWORD=’’
WIRELESS_WPA_PSK=’’

ls -la

total 96
drwxr-xr-x 6 root root 4096 Mar 13 11:30 .
drwxr-xr-x 5 root root 4096 Mar 13 11:21 …
-rw-r–r-- 1 root root 12799 Mar 14 18:51 config
-rw-r–r-- 1 root root 9956 Mar 14 18:51 dhcp
-rw-r–r-- 1 root root 60 Mar 1 13:42 ifcfg-eth0
-rw------- 1 root root 172 Feb 18 21:24 ifcfg-lo
-rw-r–r-- 1 root root 28066 Feb 18 21:24 ifcfg.template
-rw------- 1 root root 818 Mar 13 20:16 ifcfg-wlan0
drwxr-xr-x 2 root root 4096 Mar 2 11:54 if-down.d
-rw-r–r-- 1 root root 239 Feb 18 21:24 ifroute-lo
drwxr-xr-x 2 root root 4096 Mar 2 11:54 if-up.d
drwx------ 2 root root 4096 Feb 18 21:35 providers
drwxr-xr-x 2 root root 4096 Mar 2 11:54 scripts

in addition with just a general observation - having you pointed out the ‘problem’ i have quickly searched the forum/google/etc for dhcp client not setting gateway and it seems there is previous history on this ‘issue’.

i do wish i was more linux savvy to understand the complexities a bit easier :wink:

On 03/14/2011 05:36 PM, badbetty wrote:
>
> in addition with just a general observation - having you pointed out the
> ‘problem’ i have quickly searched the forum/google/etc for dhcp client
> not setting gateway and it seems there is previous history on this
> ‘issue’.
>
> i do wish i was more linux savvy to understand the complexities a bit
> easier :wink:

You edit the configuration using YaST on the same set of pagrs that you switch
from ifup to NetworkManager.

There are no major changes from 11.3 to 11.4. Both methods work when set up
correctly.

You might try:


ifconfig wlan0 down
ifconfig wlan0 up
iwconfig wlan0 essid "BBBWireless2" ap 00:14:6C:67:24:28
dhcpcd

If dhcpcd returns “process already running” use

kill <process ID>

without the “<>” for each PID listed.
Then

ping 216.239.51.99

The above will reset the DHCP client and might get your DNS back in order.

re: lwfinger

Using YaST does not affect any changes to make a solution; especially it does not change any values shown when ‘route -n’ is run - i had already tried YaST previously.

There must be something wrong somewhere as I have changed nothing in terms of hardware or what i setup from 11.3 to 11.4. all i did was install it [11.4] and switch to using ifup using YaST. in 11.3, there was nothing to do as such - it just worked!

It’s strange. I will keep plugging away as they say. thank you

re: bsilvereagle
thank you to you too; this did not work as on running ‘dhcpcd’ no instance found message was shown.

ok - i have sorted out how to use ‘ip’ to set the tables up as it was suggested it should look (see above by lwfinger).

however, if i take down the services and bring them back up (ifdown/ifup), nothing of the changes i made are present and the default routing table appears again with no gateway and some entries (168.x.x.x) i have no idea about!

i wonder if it is the dhcp that is picking something up! goodness me this is a struggle.

either way, any changes i manage to make manually are lost; YaST doesnt appear to have anywhere to make the necessary changes - i do suspect something is amiss with 11.4 than it was with 11.3 in this respect. what i dont know.

thanks again all