Tracker- can o remover it

I can barely use this machine after starts and reboot, for about 2 or more minutes.
Something is causing my HDD to spin for all that time. It ‘eventually’ goes away, but, it is still a hindrance.
When I run TOP, tracker-store and tracker-extract are bot very prevalent at the top of the output.

Can I safely remove it?
Can it be set to do it’s thing on a schedule?

Hi
This is probably a good reference: How To Completely Disable Tracker, GNOME's File Indexing And Search Tool - Linux Uprising Blog

All I did was;


tracker3 status
systemctl --user mask tracker-miner-fs.service
tracker3 reset -s -r

Reboot and check status…

I’ve tried several times to do what you suggested.
I don’t have tracker3 nor tracker2, so I am depending on ‘tracker --help’ for command help. There is no man page.

My ‘tracker’ does not offer the 'r 's options for reset. Only the -r
The page you listed as a reference also did not have ‘tracker covered’. But it was good reading,

Following is a listing of what I get.

bill@Bill-HP:~> tracker status Currently indexed: 0 files, 0 folders
Remaining space on database partition: 54.3 GB (50.98%)
All data miners are idle, indexing complete

bill@Bill-HP:~> systemctl --user mask tracker-miner-fs.service
bill@Bill-HP:~> tracker reset
Usage:
tracker reset [OPTION…]

Help Options:
  -h, --help          Show help options

Application Options:
  -r, --hard          Kill all Tracker processes and remove all databases
  -e, --soft          Same as --hard but the backup & journal are restored after restart
  -c, --config        Remove all configuration files so they are re-generated on next start
  -f, --file=FILE     Erase indexed information about a file, works recursively for directories

bill@Bill-HP:~> tracker reset hard
Usage:
  tracker reset [OPTION…]

Help Options:
  -h, --help          Show help options

Application Options:
  -r, --hard          Kill all Tracker processes and remove all databases
  -e, --soft          Same as --hard but the backup & journal are restored after restart
  -c, --config        Remove all configuration files so they are re-generated on next start
  -f, --file=FILE     Erase indexed information about a file, works recursively for directories

bill@Bill-HP:~> tracker reset -r  **(the -r = a hard reset)**
CAUTION: This process may irreversibly delete data.
Although most content indexed by Tracker can be safely reindexed, it can’t be assured that this is the case for all data. Be aware that you may be incurring in a data loss situation, proceed at your own risk.

Are you sure you want to proceed? [y|N]: y
Found 3 PIDs…
  Killed process 1648 — “tracker-miner-fs”
  Killed process 2064 — “tracker-extract”
  Killed process 2215 — “tracker-store”
_g_io_module_get_default: Found default implementation dconf (DConfSettingsBackend) for ‘gsettings-backend’
Setting database locations
Checking database directories exist
Checking database version
Checking whether database files exist
Removing all database/storage files
  Removing database:'/home/bill/.cache/tracker/meta.db'
  Removing db-locale file:'/home/bill/.cache/tracker/db-locale.txt'
  Removing journal:'/home/bill/.local/share/tracker/data/tracker-store.journal'
  Removing db-version file:'/home/bill/.cache/tracker/db-version.txt'

**AFTER A Shutdown and restart(same thing happens with a reboot)**
bill@Bill-HP:~> tracker status
Currently indexed: 2303 files, 42 folders
Remaining space on database partition: 54.3 GB (50.99%)
Data is still being indexed: Estimated 03m 51s left

There were times during my trying this the estimated time was over 6 minutes, and i took every second of it!

Could there be something in the boot or restart that are overriding my attempts??

I did this sequence for Tracker2 from the https://www.linuxuprising.com/2019/07/how-to-completely-disable-tracker.html Malcomlewis provided, and after another restart, ‘tracker status’ reported "could not establish a connection to Tracker.

systemctl --user mask tracker-store.service tracker-miner-fs.service tracker-miner-rss.service tracker-extract.service tracker-miner-apps.service tracker-writeback.service
tracker reset --hard

Thanks @malcolmlewis, the link you posted did the trick.
I’ve got usage of my machine back after start up instead of waiting for tracker to complete it’s things.
I don’t know the full ramification of masking the tracker things, but masked they are!