Touchpad troubles on Dell Latitude D520 and OpenSuse 11.0


I got my first problem wich I had with the touchpad fixed…

At first after changing some settings with gsynaptics my cursor would not move after logon. So I tweaked some gconf settings for the touchpad and voilla everything is fine…

I needed to change the maximum speed and minimum speed to some reasonable value to make the mouse cursor move…

but now, this one… In OpenSuse 10.3 I could use edge-scrolling…

Now I can’t… When I enable scrolling horizontally, the size of the area in wich my finger can make a horizontal scroll… Is way to big…

And vertical scrolling does not work overall…

Anybody have an Idea on how to fix this? In 10.3 I used to edit xorg.conf… But now, it does not seem to make any real difference.

I want to scroll vertically and horizontal…

In openSUSE 11 the touch pad settings seems to have moved to the users configuration… The issue with losing the mouse movement after changing settings with the gsynaptics applet (found in control center) should be fixed if you installed the final of 11, I did have the issue up to RC1.

I’m also interested to know where the settings are exactly stored now but have not had time to track it down yet… It should be somewhere in your user profile.

btw, I’m mainly using GNOME… you as well?


Yes I use Gnome.
I think I some how fixed the issue,

My xorg.conf was setup wrong by the installer:
This is what made it work for me:

Section "InputDevice"
  Driver       "synaptics"
  Identifier   "Mouse[3]"
  Option       "AccelFactor" "0.01"
  Option       "BottomEdge" "800"
  Option       "CircScrollDelta" "0"
  Option       "CircScrollTrigger" "0"
  Option       "CircularScrolling" "0"
  Option       "Device" "/dev/input/mice"
  Option       "EdgeMotionMaxSpeed" "15"
  Option       "EdgeMotionMinSpeed" "15"
  Option       "Emulate3Buttons" "on"
  Option       "EmulateMidButtonTime" "75"
  Option       "FingerHigh" "15"
  Option       "FingerLow" "14"
  Option       "HorizScrollDelta" "20"
  Option       "LeftEdge" "120"
  Option       "MaxSpeed" "0.5"
  Option       "MaxTapMove" "110"
  Option       "MaxTapTime" "180"
  Option       "MinSpeed" "0.2"
  Option       "Name" "Touchpad"
  Option       "Protocol" "auto-dev"
  Option       "RightEdge" "800"
  Option       "SHMConfig" "on"
  Option       "TopEdge" "120"
  Option       "UpDownScrolling" "1"
  Option       "Vendor" "ALPS"
  Option       "VertScrollDelta" "20"
  Option       "ZAxisMapping" "4 5"

Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[3]" "CorePointer"
  InputDevice  "Mouse[1]" "CoreEvents"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"

Problem was with the RightEdge setting, this was set to 850… I moved it back to 600, and I got my vert-scroll back. Tweaked it to 800, so only the most right part of the pad is for the vert-scroll.

And i changed to BottomEdge to 800, I do not want to scroll horizontally.

To test this i had disabled ‘touchpad’ from ‘control center’ → ‘sessions’. So my personal settings wouldn’t kick in.

Which I later enabled. And all kept working,

This is my config for gconf, /desktop/gnome/periphals/touchpad/

        <entry name="coast_enable" mtime="1214089178" type="bool" value="false">
        <entry name="edge_motion_use_always" mtime="1214089178" type="bool" value="false">
        <entry name="circ_scroll_trigger" mtime="1214089062" type="int" value="5">
        <entry name="max_speed" mtime="1214119302" type="int" value="734">
        <entry name="min_speed" mtime="1214089124" type="int" value="500">
        <entry name="accel_factor" mtime="1214088910" type="int" value="67">
        <entry name="circular_scrolling" mtime="1214089176" type="bool" value="false">
        <entry name="circ_scroll_delta" mtime="1214089176" type="int" value="0">
        <entry name="horiz_scroll_delta" mtime="1214119251" type="int" value="0">
        <entry name="vert_scroll_delta" mtime="1214119294" type="int" value="20">
        <entry name="max_tap_time" mtime="1214119294" type="int" value="180">
        <entry name="off" mtime="1214119294" type="bool" value="false">

Cool! thanks for that info, I had searched for the config file but was looking for gsynaptics and thus missing it :smiley:

Good to hear you got it sorted.


It is not fixed in openSUSE 11.0 final. For example, if you use gsynaptics and simply uncheck (disable) tapping and scrolling, close, and reboot, the mouse pointer for that particular user account will be frozen.

In my case this is with GNOME on a Dell XPS M1330 notebook.

Has this been filed as a bug report yet?

There was a report for it that is marked as resolved but the issues are mixed with each other. Seeing it’s not fixed it would be good to add your comments and findings & open a new report if needed.


Yes these are two different problems,

My width and height of the touchpad was incorrectly defined in xorg.conf. So I was not able to use my vertical scrolling feature. And my horizontal scroll kicked in as soon as I touched the center of the pad.

The other problem is with gsynaptics… Changing some settings with that application makes your mouse freeze (after a restart).

There is a workaround:

Edit your gconf settings with gconf-editor by hand using the settings I have provided above for the touchpad section.

Or disable loading your personal touchpad preferences, this can be done by unchecking ‘touchpad’ in the ‘sessions’ applet from your control panel.

I think this is the relevant bug report.

Ii just wanted to thank you for this bro.

After reading this post I noticed that the upper right hand side of of my D520 touchpad worked decently , but the center to bottom left would not work and I noticed the horizontal scroll problm when on the taskbar.

I had some other settings you did not , but the only thinks I set for mine was


Mimicing your settings.

I had a Mouse 3 section and a mouse 5 section and set your settings in both. Rebooted and the touchpad works soooo much better now.

Thank you again. Rep incoming.

P.S. I’m oin KDE4 and have the same issue on both desktops.

One last question… Do you know which setting would reduce the size of the vertical sroll even more ? Still seems like a slightly big section for me. I’d like to make it a barely accessible edge if pssible.

Anyone know which line to adjust ( right edge ? ) and how so in order to reduce the size of the vertical scroll feature ?

Currently I have a good 3/4" of scroll section and I’d prefer to drop that down to about a 1/4" section to allow me to only scroll when I specifically try to get to that section .

thanks for this post. i know more about laptop.

Well I will have to look into this, right now with the new Suse 11.1 I do not have this issue anymore. But my pointer speed is way off.

Just be patient :wink: